Previous 1 2 Next 15 Replies Latest reply: Apr 24, 2013 8:15 AM by ClaudeSp
Leann O. Level 3 (635 points)



Does anyone here use Google 2 step verification? If so, how have you gotten it to work with iCal? I am doing the steps just as Google says to do them (generate an application-specific password and enter that password instead of my regular Google password) but I keep getting an error message. I was able to set up Gmail in the Mail app just fine with the Google 2 step verification application-specific password. I am not sure why iCal is giving me problems. I have searched Google and can't really find a good answer or a step by step solution. I am running Lion. I hope someone can help me. Thank you.



iMac, Mac OS X (10.7)
  • cheesesilk Level 1 (10 points)

    I am also having this problem.  Kind of annoying.  On my iPod, the app-specific password works fine, when I generate another one for use with iCal, iCal says it's invalid. 

  • cheesesilk Level 1 (10 points)

    Just got it to work.  I just entered the app-specific password through the system preferences / Mail Contacts & Calenders window.  Then, I quit iCal completely and restarted it.  Works like a charm.  Hope it helps.

  • Leann O. Level 3 (635 points)

    Hey! Thanks for replying. Your solution is a good one, and I also found another solution a few days ago. I actually totally forgot about this thread until I logged in and saw that you had replied to it! Here is the other solution I found:



    Hopefully if someone else has the same problem, they can do a Google search for it and find this thread!


    Thanks again for replying! 

  • Hassc Level 1 (0 points)

    None of these solutions work for me. I removed my Google account from iCal and am now trying to add it. I have tried using the google guide but it didn't work (it said the server wasn't a caldav server).

  • Braaco Level 1 (10 points)

    Cheesesilk, thanks so much man that did the trick for me.


    Steps for anyone else stuck:


    1. Go to Apple icon (top left of screen) > System Preferences > Mail, Contact & Calendars

    2. Delete your current gmail account by selecting it and pressing the "-" button

    3. Add a new Gmail Account by pressing the plus and selecting Gmail

    4. Type in your account details but when you get to the password stage, generate a new application specific password from:

    5. Type that new password in (you can copy paste it)

    6. Hit Setup and it shoud be now syncing up your calendar and mail account again!

  • ceebeeee Level 1 (0 points)

    Thanks for this great solution

  • meghanclare Level 1 (0 points)

    Thank you. I realize this is an old thread but this completely worked for me and wanted to give a thumbs up in case anyone else is having the same issue. Thanks!

  • Braaco Level 1 (10 points)

    No problem at all!

  • cheesesilk Level 1 (10 points)

    You're welcome! And Thanks for making this user friendly, specific and accessible! It's nice when we can solve each other's problems

  • sorens Level 1 (0 points)

    replied in the wrong spot

  • sorens Level 1 (0 points)

    One note: I have many calendars in my google calendar. In order to make all those calendars sync as well, I had to follow the above steps plus:


    1. launch iCal
    2. open Settings -> Account
    3. click the appropriate Google CalDAV account
    4. select the delegation tab
    5. enable all the appropriate calendars that you want sync'd with iCal
    6. close Settings
    7. confirm calendars now show up in Calendar List
    8. Refresh All, this should cause all the added calendars to fail, one will even pop-up a password dialog box.
    9. Paste in the generated google password from the initial steps and click OK
    10. Click each of the error triangles in turn, pasting in the password into the dialog box that pops up and click OK
    11. refresh all and cofirn they all sync now
  • Jonathan Woodruff Level 1 (0 points)

    The above solutions work well for me for a period of time.  Mail has never been the issue, but Calendar is still the culprit.  After a day or so, I am again prompted for a password in Calendar.  As such, even when going through the steps it appears that the password doesn't 'stick.'  I'm resorted generating a new password, pasting it in and then it works for a day or two.


    UPDATE: I'm running 10.8 Mountain Lion

  • numinumi Level 1 (0 points)

    This worked great for me -  Thanks, Braaco.

  • Braaco Level 1 (10 points)

    Awesome Thanks for letting us know!

Previous 1 2 Next