Previous 1 2 3 4 Next 53 Replies Latest reply: Dec 28, 2011 10:19 AM by JPLogan
cody4king Level 1 Level 1

I'm having trouble sharing movies via iTunes through home sharing.  Everything I have is Mac, a 2008 iMac, Airport Extreme, (2) Apple TV 2's, and a Macbook Pro.  Everything was fine with this entire setup with all of the movies I've ripped (using the Apple TV 2 settings in Handbrake) until Lion came out. Suddenly I got the 'Content cannot be displayed. Try again later' error message.  After much searching, I found that disabling IPv6 was a good solution, temporarily, that is until Apple released iOS 5.  I updated the ATV2's, iPhone, and iPad, and iMac with everything that came out during the update, and the issue came back.

 

I've tried everything I can think of, changing router channels, disabling IPv6 everywhere I saw it, wireless, hardwired, reloading the library, disabling the firewall, countless restarts of all my equipement etc.  All of these movies worked perfectly before the updates, and suddenly I cant stream anything through my local MAC network. 

 

Has anyone else seen this? Has anyone found any solutions for this problem? I could really use the help, Apple support is... limited. 


AppleTV 2, Mac OS X (10.7.2)
Solved by cody4king on Oct 19, 2011 4:16 PM Solved

Problem solved for me!  After trying every possible setting on my equipment, including changing firmware revs on my router, rebuilding my library, re-encoding certain movies, changing all my iTunes, Network, Security, Sharing, and WiFi settings, I finally figured it out. 

 

It looks to be a bug with the new iOS release V4.4 - Assuming you have your movies encoded in 5.1AC3 surround, you have to go into the Audio & Video settings on your ATV2, go down to Dolby Digital, and change the setting from Auto to On.  For me at least, it was simple as that.  I've tried all the same movies I was trying to play before, only then I was getting 'An error occurred loading this content.'  After changing the setting from Auto to On, every single movie began working again, in full surround sound. To test it, I switched the setting back to Auto and the same problem came back.  I'm sure Apple will have a fix for this later, but for now, we can assume 'Auto' means 'You cant stream your movies.'

 

I hope this helps!

Reply by Vanderlei Loula1 on Oct 28, 2011 10:00 PM Helpful

I can confirm that logout from iTunes store solves the streaming problem. Go to settings on apple tv and log out. The videos will stream like a charm again. It's not a solution, but a workaround until apple fixes it.

Reply by Tom Stazer on Oct 29, 2011 9:29 AM Helpful

MAYBE Apple fixed this overnight? I had the same experience - but even before updating. Video had ceased to work - just a spinner. I checked for an update, saw one, assumed it would fix it. Instead it seemed to reset a lot of basics; had to rename my unit and restore a few settings, but video didn't work. Searched the support forums, and did not see this thread. Guess it started after i gave up.

So this morning I removed the last week or so of films I had ripped by handbrake (thanks to poster who noted it is NOT illegal to hand brake movies you own) thinking one of those files was causing the bug.
SO this afternoon this thread had me all ready to go log out of the store as has worked for many, but when I turned it on everything worked anyway.
Was it the removal of some recent hand brakes or Apple fixing the store login while I snoozed?
Will check back and update you on my situation if it changes.

All replies

  • mauijiminar Level 4 Level 4

    Maybe it is not allowing you to watch illegal copied movies?  Evening using "hand break" is illegal.

  • cody4king Level 1 Level 1

    The issue resides with movies I've purchased from iTunes as well, for example, Toy Story 3 does not work and I purchased that one directly from Apple.  It seems like small filesizes still work but any of the larger files do not, even though they have worked before.  This is a very strange and frustrating issue; I can't imagine I'm the only one with this problem.

  • digbyrich Level 1 Level 1

    Yes, I'm having issues, too. I have two Apple TV 2's. After the latest update, one worked fine, and the other wouldn't connect. It was telling me to make sure Apple TV ws connected to the same network as my computer. They are.

     

    Now this morning, my second usit won't connect either. This after workng fine yesterday! I've tried rebooting both units to no avail.

  • cody4king Level 1 Level 1

    Problem solved for me!  After trying every possible setting on my equipment, including changing firmware revs on my router, rebuilding my library, re-encoding certain movies, changing all my iTunes, Network, Security, Sharing, and WiFi settings, I finally figured it out. 

     

    It looks to be a bug with the new iOS release V4.4 - Assuming you have your movies encoded in 5.1AC3 surround, you have to go into the Audio & Video settings on your ATV2, go down to Dolby Digital, and change the setting from Auto to On.  For me at least, it was simple as that.  I've tried all the same movies I was trying to play before, only then I was getting 'An error occurred loading this content.'  After changing the setting from Auto to On, every single movie began working again, in full surround sound. To test it, I switched the setting back to Auto and the same problem came back.  I'm sure Apple will have a fix for this later, but for now, we can assume 'Auto' means 'You cant stream your movies.'

     

    I hope this helps!

  • gavin86 Level 1 Level 1

    I have a similar problem but this is specific to playing movies from my ome sharing collection.  Music is fine but when. Select a movie no matter what size it just sits there with the spinning circle in the middle of the tv for ages.

    This is after the upgrade to ver 4.4.2, and after restore of the appletv , a reset all, and a full power reset.

    I dont know if this thing is looking for activation even if you're playing a movie from home sharing on itunes.

    Hope someone has a similar issue with a resolution.

  • rmillsnyc Level 1 Level 1

    Thanks, but did not work for me.

  • Vanderlei Loula1 Level 1 Level 1

    Just tried and it doesn't work for me. The thing is my movies do not have ac3 track only AAC. I tried "on", "off" and "auto" but the is still just spinning. The vide that plays are the wwdc podcasts I have stored, all movies, both purchased and ripped just spins. Apple please solve it. It's Saturday and the kids wants to have fun.

  • CommanderClif Level 1 Level 1

    Problem still not fixed and this audio switch didn't fix it either. Trailers work, Netflix works, but under Computer, I can get music to stream, podcasts (video and audio) to sream, but nothing under TV shows and nothing under Movies are working.

  • matthewmac Level 1 Level 1

    Same here. Ran the update tonight, now only music, photos and podcasts play via Home Sharing.  Big fun, indeed.

  • gavin86 Level 1 Level 1

    Hows this.  If you let the timer spin it eventually times out to the screen saver. Then pressing the down direction button on the remote takes itnout of screen saver mode and you get the option of starting from the beginning or resuming and it plays from there.

    Come on apple fix this.

  • Yuval Kordov Level 1 Level 1

    I am having the same probem since updating to 4.4.2. No TV shows I've purchased through iTunes work. Just have the endless spinning wheel. Unacceptable.

  • econ-mit Level 1 Level 1

    Gavin, that didn't work for me.

  • Thomas Merriewether1 Level 1 Level 1

    Tried your fix.  No go!

    Please un-mark this as solved if possible.

     

    The more responses I see the more certain I an that this is an authentication/authorization problem.  The audio playback format has absolutely nothing to do with it.  That might be an HDMI/receiver problem but that is not the problem here.

     

    It it not reasonable to assume that those who are having this problem have been using the wrong audio codec!

    It worked until a couple hours ago.  This is most probably an Apple server problem that Apple must resolve once an for all!

  • gavin86 Level 1 Level 1

    It works if you try it on a part played movie from your collection. Havent got an unwatched one to work yet.

Previous 1 2 3 4 Next