Skip navigation

Create Windows install disk option in Lion Bootcamp?

116876 Views 132 Replies Latest reply: Dec 9, 2013 4:35 AM by Backkom RSS
  • NoEfX Calculating status...

    No, I got an error saying, "unable to partition drive from USB" but I think I got this error because of how old this USB is. I am currently trying to find alternate solutions....

     

    Solution 1: Burn my ISO to a DVD and use that as my boot disk

    Solution 2: Try a different external hard disk or USB

     

    Problems with solution 1 - error: "cannot partition disk because some files cannot be moved"

    ...have not tried solution 2 yet.

  • marthafrommavamv Calculating status...
    Currently Being Moderated
    Feb 9, 2012 12:24 PM (in response to wippler)

    It also worked for me, but only after I quit BootCamp Assistant and then restarted.

  • draketb Calculating status...
    Currently Being Moderated
    Feb 10, 2012 4:44 PM (in response to codecex)

    codecex's worked for my Late 2010 MacBookAir3,2 (13") with OS X Lion 10.7.1

     

    Thanks

  • teeza Calculating status...

    This method worked for me as I was having the same problem the others were. Though I tried this first, and it didn't work. So I read on and found a post saying something about making a copy of the info.plist file, modifying it, then replacing the original with my MBA31 string on the top. Worked like a charm, un-grayed, and with another reformat of my usb stick using diskutil, the files were copied. Thanks.

  • jondempsey Calculating status...

    GOT IT!

     

    It's not the order that's the problem... if you notice, all the entries are rounded off to the tens place... I have a MBA3,2. It didn't work when I used MBA32, but then I changed it to MBA30 and it worked like a charm... thus, it is not looking for the specific identifier but the series (perhaps). Thanks

  • Jaygyver Level 3 Level 3 (725 points)
    Currently Being Moderated
    Feb 16, 2012 8:41 PM (in response to NoEfX)

    Don't forget, not all USB thumb drives are bootable it seems.

     

    For those that can ungrey the option but can't boot from a known bootable drive some people have some limited success with changing  the "DARequiredRomVersions" also slightly above the one mentioned.

  • grimrp3r Calculating status...

    Oh wow, I love you

  • nikal.giv.xxx Calculating status...

    Hello,

     

    I can confirm that adding lines to plist.info helps definitelly.

     

    I have MBP 5,5 and fresh install of Lion 10.7.3 (on OCZ Vertex 2 60GB)

     

    So I decided to buy Optibay and to put 640GB HDD in it - to split it for Windows and Users dir  (later is not possible??? - to split HDD to NTFS and HFS)

     

    Anyway, first option Create Windows 7 boot disk was greyed out, untill I edited contetnt of Boot Camp Assistant (info.plist)

     

    I added two lines:

    <string>MBP50</string>

    <string>MBP55</string>

     

    Just copy original file somewhere, edit it in Text Edit, and move it back to original dir (confirm that you want to replace). For security - first copy original info.plist on safe (some other dir).

     

    After that you have option to create Windows 7 boot disk with required drivers.

     

    Thanks to all of you commented in this post.

  • elroadrunner Calculating status...

    I confirm this solution!

     

    Bootcamp is creating that usable iso image on a flash drive at the time I am writing this.

     

    Just as a warning, be careful editing those plist's if you don't have something like XCode to edit them with. And even if you do have XCode, be careful anyways.

     

    And jacktourist, you can have my internets. No really, I insist. This problem had been bugging me for hours until I read your solution.

  • postnocomments Calculating status...
    Currently Being Moderated
    Mar 1, 2012 11:18 PM (in response to jmjm003)

    Confirmed. I followed the instructions as dictated first and the option to create the bootable thumb drive was still grayed out. Once I put my MBP in its correct order the option became selectable. Thank you!

  • Xavier Vasquez Calculating status...

    I tested this because my option to create a USB disk was greyed out. I edited the info.plist file and moved, in my case, MP51 to the top and double checked that my syntax was correct. The first time I did this it did not work even with moving up my hardware model. What I did to correct this was open the .plist file in Text Edit. When I tried to edit the file directly it asked me if I wanted to duplicate. I said yes. I edited the duplicated file. I then saved it to my desktop. I right clicked on the Boot Camp Assistant in Utilities and browsed to the info.plist file and deleted the original. I was asked to authenticate to remove the file. Once the file was deleted I then copied the duplicated file back (name it exactly the same). I was asked to authenticate again. Once I did that and the file was copied I closed all windows and re-openned Boot Camp all was good I had the option to make a USB drive.  I then proceeded to make my Windows installed boot drive.

     

    So at first the orginal process did not work for me but with a little trial and error all worked in the end. I am using 10.7.3 Lion build with Lion Server 10.7.3 installed.

     

    Thank you.

  • ahorriblemess Calculating status...

    I have a MacBook 5,1 so I simply replaced MB80 with MB51 and it worked. Thanks, OP. No thanks, Apple for being lame.

  • nikal.giv.xxx Level 1 Level 1 (0 points)

    Ok guys, that USB creation went fine - BUT !!! I can not boot from such USB on my MacBook Pro 5,5

     

    On other hanf that USB can boot up my HO dv6 notebook.

     

    Apple still got me, after several days of trying, I am still not able to install Windows 7 64bit PRO on second HDD in Oiptibay.

     

    Any ideas? Please just do not point me to DVD - I do not have USB case for Superdrive (and I do not want to buy one).

     

    Thanks for any good advice.

     

    ps. rEFIt doesn't work too ;(

  • Jaygyver Level 3 Level 3 (725 points)

    Some computers have an issue with Windows reading the Optical drive as an external drive and then won't boot, Windows won't install TO an external disk, try installing the new drive into the original spot and try again.

  • Kid Dynamic Level 1 Level 1 (35 points)

    I know I'm coming in late to the conversation, but there's another way to "burn" an ISO to a USB drive, using UNetbootin. See this guide:

     

    http://www.addictivetips.com/windows-tips/install-windows-7-from-usb-drive-requi res-2-simple-steps/

     

    If you have the Windows 7 ISO, it's a two step process: Install UNetbootin and Burn the ISO.

     

    That way you don't need to edit system files to get Boot Camp to make it happen.

     

    Just a thought.

1 2 3 4 5 6 ... 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.