12 Replies Latest reply: Sep 22, 2012 10:55 PM by larez2
mattwolf_98 Level 1 Level 1

This has been happening ever since I opened the phone. When connected to wifi, Siri says, "Sorry, I'm having trouble connecting to the network." Yes, wifi works for all other apps. Webpages load just fine.  This happens on both my home and work wifi.  Also at McDonalds and at S

 

On 3G everything works.

 

Any ideas? Anyone else having this issue?

  • Chuck Konfrst Level 4 Level 4

    Not having the issue, but you could try resetting the Network Settings.

     

     

    Settings=>General=>Reset=>Reset Network Settings

     

     

    This will clear everything out.  You'll need to re-input your wi-fi settings, but hopefully Siri will work via Wi-Fi.

     

    Good Luck

  • mattwolf_98 Level 1 Level 1

    I have tried this the other day (and again just now to make sure).  Nothing changed.  Same problems.

  • mattwolf_98 Level 1 Level 1

    My mistake, it works on wifis outside of my home and work.  Today it worked at McDonalds and at my health club.  Still not working on my home or work wifi.  Home is Airport Extreme, work is Time Capsule.

     

    I called Apple today and he suggested I restore my phone.  This was a huge waste of time and nothing has changed with the problem. 

     

    Clearly this is an issue with each of my wi-fi networks.  Is there some test I can do to make sure the settings are right so Siri can work over wifi?

  • Chuck Konfrst Level 4 Level 4

    How is your home network setup?  Any special settings such as proxies, firewalls, access controls, etc?  Is it only Siri that can't connect?

  • mattwolf_98 Level 1 Level 1

    There is no firewalls nor proxies that I'm aware of. It is a college campus network (I live and work on campus) but in both cases the ethernet cable comes out of the wall ready to "plug and play" into the time capsule or airport extreme. There is no sign in screen or anything.

     

    It's only Siri that can't connect.  Mail, Safari, App Store, facebook all connect well on wifi. Siri works great when I turn off 3G.

  • Chuck Konfrst Level 4 Level 4

    Do you have a spotty cell signal at home?  I've seen in a couple of forums that Siri doesn't seem to be great at switching to wifi when the cell signal is low. If you turn off the cell signal and only run on wifi, will Siri work?

  • mattwolf_98 Level 1 Level 1

    No, my cell signal is great at home and work (they are 1/8 mile from each other).  I just put the phone in airplane mode, then turned on wifi only.  Siri still won't work.

  • Chuck Konfrst Level 4 Level 4

    It's got to be something on the college network that is preventing Siri from working.  My guess is that Siri uses a specific port that is being blocked.  It can't be the phone because it is working everywhere but the college network.  It is not switching over to 3G because the phone thinks the wifi network is working fine.

     

    Maybe you can work with the IT staff at the college to determine what is causing this.

  • Chuck Konfrst Level 4 Level 4

    Does Facetime work on the college network?  It uses special ports - perhaps Siri uses some of the same.  See this article.

  • craisondigital Level 1 Level 1

    Ah.  I was having the same issue.  For me it was an issue w/ my wireless router settings.  I logged onto it, and found a checkbox which was unchecked and said something like.. "allow router to be pinged by internet services" or something to that effect.  I Checked the box so that it was now set to "allow" and hit apply, and siri is working over wifi now too.

     

    hth

  • Swyhart54 Level 1 Level 1

    I'm having the same issue. Siri isn't working on my home or work WiFi networks. If I turn WiFi off it works just fine, but who wants to do that every time they want to use it? Since I'm at home and work alot I'd really like to be able to use it in either place. Any help would be greatly appreciated?

  • larez2 Level 1 Level 1

    I know this is a pretty old thread but I was having this issue and manually assigned dns servers on my router - 8.8.8.8 and 208.67.222.222 - google and opendns's public dns servers. Siri started working after that.