1 Reply Latest reply: Oct 19, 2011 5:57 PM by michaelfromsanangelo
michaelfromsanangelo Level 1 Level 1

I have an iphone 4 with ATT and I recently purchased an iphone 4 from sprint for my wife.  Upon setting her's up, i believe i made the mistake of using the same apple id as my phone on her phone.  I also have icloud setup on my phone.  She noticed that all of my text messages being sent out to others, not sent to my wife, were being duplicated to her phone and replies back to my text messages were being duplicated to her phone.  I assume this is something to do with icloud and me originally signing in her phone with my apple id.  I have since turned icloud off on my phone and i have setup my wife with her own apple id and is signed in with it on her phone.  The duplicate text messages are still going on.to her phone and mine.  I did some looking online and haven't found anyone with this issue, so i posted it here to see if anyone had any advice. 


Let me know if you need additional info.


Thanks in advance,


iPhone 4, iOS 5
  • michaelfromsanangelo Level 1 Level 1

    I found the fix on this community.  It was a setting in imessages.  It was still holding my apple id under imessages.  fix is below


    Adjust the settings in Messages. Receive At should only have your phone number and your email on your phone and only your wife's phone number and her email on her phone. Caller ID should be set to your respective email addresses on each phone.