9 Replies Latest reply: Nov 28, 2011 5:29 AM by léonie
Shuttleworth125 Level 2 Level 2 (415 points)

We've always run Aperture with Faces turned off on our old iMac, however I decided to turn it on when we moved everything over to our new machine.

 

I went into the Faces view and started putting names to faces. In this process I also skipped a few faces and had a few "not a face" images as well. I was surprised when after putting names to 21 people I ran out of images to name. There are no images showing in the "Show Unnamed Faces" filmstrip under the corkboard. I know there are hundreds of unnamed faces still in my library. Also there seems to be no logic behind the way in which Aperture presented faces for naming, the face for one person in a shoot was shown (though not necessarily all photo's of that person) , but someone else in the same shoot has not been presented for naming.

 

Our library has just over 20,000 images, and the majority will have faces on. Filtering by Faces>Detected I get 850 images!

 

I selected all the photo's in my library and did a Photos>Detect Missing Faces search, but this didn't add any new unnamed faces, the activity runs for about 4 seconds.

 

I've gone through the Troubleshooting Basics, but it hasn't made any difference.

 

Running Aperture 3.2 on Lion.


iMac, Mac OS X (10.7.2), 3.4GHz i7, 16GB RAM, AMD 6970M 2GB
  • Kirby Krieger Level 6 Level 6 (12,470 points)

    A bit of voodoo, but try letting the machine run unmolested with Aperture open for a night.  I'm guessing -- truly -- that Faces is programmed to run on some kind of deep background.  I know it took a while (on the order of days) for face detection to process a couple of large Libraries I use.  It was very rough at first, gradually improved (not just recognition, but identification and performance as well), and now works, imho, surprisingly well (the surprise is that it actually is competent enough to use).

     

    I suspect that the 850 is, in fact, all the faces detected so far.  See if this changes after Aperture has some idle processing time to bulk up the Faces tables.

     

    I have never discerned a "logic" behind "the way in which Aperture present{s} faces for naming".  I can say that 3.2 is faster and better (seems more logical) than previous versions.

     

    The usual caveat: I'm just an equally blind user, slowly feeling my way 'round this elephant in our orchard.

  • Shuttleworth125 Level 2 Level 2 (415 points)

    Cheers Kirby. I've been playing with it for a couple of days now. The iMac gets left on all the time and has had Aperture running overnight and during the day when the machine was otherwise idle and there have been no new additions to the Unnamed Faces list.

     

    I have imported new photo's and so far new faces have been detected ok.

     

    I found a reference somewhere (Edit HERE) that mentioned going into the Aperture Library Package and deleting a section relating to faces, but I'm not going to play around with that, the wife would kill me if I broke it!!

  • Kirby Krieger Level 6 Level 6 (12,470 points)

    But you'll be a hero if you get it to work!  Choices, choices  .  The reason you're posting is that it's already broken.

     

    Before I got any further with adding names and Images to my Faces database, I'd make a Library backup, try the "delete faces.db" method, and if that didn't work, rebuild the Library overnight.

     

    Post back with what you do.

  • Shuttleworth125 Level 2 Level 2 (415 points)

    Broken isn't the same as not working, my car is testament to that

     

    Good suggestion, I'll give it a try.

  • Shuttleworth125 Level 2 Level 2 (415 points)

    Right, I've done that and still no joy.

     

    I removed Faces.db from the library package ad opened Aperture, behaviour is exactly the same, I've still got my found faces showing, but it can't find any unnamed faces.

     

    I closed Aperture and had another look in the library package, it hadn't grown a new Faces.db file, so I opened Aperture with a database repair. Still exactly the same behaviour and still no new Faces.db file.

     

    I put the old Faces.db file back in the library package and relaunched, again with a library repair, and still have the same behaviour.

     

    The only thing I've not done is remove Faces.db and rebuilt the library, but this seems like taking things to the extreme really.

     

    I wonder if 3.2 just can't find faces that weren't brought in from 3.1.3? I think I'll file a bug report.

  • Kirby Krieger Level 6 Level 6 (12,470 points)

    You might try "Photos→Reprocess Masters".

     

    Just a shot in the dark (I know it's not what the command is designed for).

  • Shuttleworth125 Level 2 Level 2 (415 points)

    I tried that, no better. I've also rebuilt the library database, no change.

     

    I've also noticed I can't see any of the faces I'd previously skipped, though this may be user error.

  • Krzysztof77 Level 1 Level 1 (0 points)

    Hi

     

    Try send feedback to Apple

    http://www.apple.com/feedback/aperture.html

     

    I dont have time to find the solution - keep waiting for answer or next update...

  • léonie Level 9 Level 9 (69,085 points)

    Aperture will not scan images again for faces, if you already rejected the images. I found the only way to force Aperture to rescan an image for faces was to export the image, delete the image from aperture, and then to reimport it.

    I did that with those images I really was interested in to get faces assigned; many of my images show crowds, and I am quite happy about the fact that Aperture does not scan those again.