Previous 1 2 3 4 Next 431 Replies Latest reply: Dec 21, 2015 7:48 PM by Triton7 Go to original post Branched to a new discussion.
  • succeed Level 1 (25 points)

    wifi is unfortunately easily affected by interference - that's actually extremely common. you could try taking your phone to an apple store.


    have you tried changing the channel at all? i agree you shouldn't have to change your channel daily.

  • mritacca Level 1 (5 points)

    Ya and it seems to be severely affected by only the iPhone 4S for a whole lot of people!


    I could believe you if I had this issue with iPhone, 3G, 3GS and 4.  I only have it with 4S.  Therefore, it's an issue with iOS 5 or faulty chip set in iPhone 4S.


    Either Apple needs to fix the bug or do a major recall.

  • DenverMojo Level 1 (0 points)

    Count me in with having the same exact problem.  I replaced 2 iphone 3GS at home with a new iphone 4s and a new iphone 4.  Both came preloaded with ios5.  Both new phones have been fine on my existing network (using a time capsule wifi base) since 10/14, not one glitch.  Then, last night, i first noticed my iphone 4s freezing up on it's network connection.  I have to turn wifi off then back on to get back on the network and it works fine for another 10-30 minutes.  I have not seen the iphone 4 exhibit any of this behavior.  What's strange is that the 4S had been working fine until yesterday, without any changes made on the network or phone.


    I've tried MANY different solutions, none of have worked:

    - tried assigning a manual ip address from the router

    - tried assigning a static ip address from the iphone

    - tried changing the security type on the router

    - tried no security on the router

    - confirmed latest firmware on my router

      - reset network settings on the iphone 4s

    - did a hard boot of the iphone 4s


    None of the above worked for me.


    I've also been watching my router log while waiting for the iphone to lose connectivity again.  I'm not seeing any events in the log that seem to match up with when the iphone loses connectivity.


    So, my network has not changed in a long time, i was previously running 2 iphone 3GS on my network without issues.  My iphone 4 and iphone 4s both were working fine on the existing network for almost 2 weeks when out of the blue, the iphone 4s has started showing this behavior.  All signs seem to point to something specific with the iphone 4s.


    I called Apple Support and talked to someone there.  They had me do the hard boot of the phone and we waited for a bit to see if the iphone would freeze it's wifi connection again.  while i had him on the phone, the wifi continued to work fine, so they said they could call me back in a few hours to see if that cleared things up.  unfortunately, about 20 minutes after i got off the phone, wifi froze again.  Waiting to hear back from Apple now so i can report back and see what they suggest next.


    I'm seeing lots of people report similar symptoms when searching for this issue.  So, I'm hoping this is just a bug (although a big one imho) that Apple has not yet identified and that can be resolved with a software or firmware update.  I also hope this isn't a larger hardware issue in the iphone 4s, like a problem with the wifi/bluetooth chipset being uesd...

  • DenverMojo Level 1 (0 points)

    Apple Support gave me a call back. They recommended a full factory restore next. I went through the full restore and got back up and running again.  About 20 minutes after completing the restore, the wifi froze up on me again. So, it'll back on the phone with Apple Support again in the morning.

  • gregomac Level 1 (10 points)

    Do you mind going into a little more detail about the freezing?


    For instance, are you on a webpage that just stops loading?

    In the upper-right hand corner, does the Wi-Fi logo disappear?

    Does the little "activity" spin logo continue to spin?


    And is this just in Safari or have you tried downloading in other apps as well?  I would try downloading a couple free apps in the app-store and see if the same symptoms show up there as well.


    It's definitely telling that other iphones seem to be working well on the same network (and being an apple router puts it even less likely as the culprit).


    Not ready to make a conclusion yet, but we can narrow it down best we can.

  • DenverMojo Level 1 (0 points)

    Sure.  Prior to the wifi "freezing" on me, everything works just fine.  I can surf the web on Safari, run (getting about 13MB down), check email, etc...


    I just did an "end-to-end" test and here's the exact behavior that I saw:


    I connected the iphone to my Time Capsule wifi network at 17:16:34.  This was noted in the Time Capsule log here:

    Oct 27 17:16:34 Severity:5      Associated with station 60:c5:47:6a:1b:77

    Oct 27 17:16:34 Severity:5      Installed unicast CCMP key for supplicant 60:c5:47:6a:1b:77


    The first line shows my MAC address being accepted by the router.  The second line shows the wifi security communication, authorizing my iphone on the network.


    I was able to surf the web and use network/internet connections during this time.  I also have installed the recently added Airport Utility app.  During this time, my Airport Utility screen was showing a green dot for Internet and a green dot for my Time Capsule router.


    At right around 17:36 (may have been exactly 20 minutes), i was on safari.  At that time, i tried to load a page and the circle just started to spin without coming back.  The wifi indicator was still showing full bars.  There was no corresponding entry in my Time Capsule log showing any activity from my iphone at this time.


    I then tried to pull up my app.  It never got past the "Looking for Locations" initial screen.  When I pulled up my Airport Utility app, it had an orange dot for Internet. If you tap on Internet, it shows "Disconnected".  My Time Capsule router still had a green dot next to it, but when i tapped on it, it didn't bring up any data on the router, implying it couldn't actually connect to it.  This whole time, the Wifi indicator on the top still shows full bars.  After a few minutes, my Safari browser finally came with an error saying "Cannot Open Page.  Safari could not open the page because the server stopped responding."


    Finally, I went into Settings->General->Wifi.  It still showed my iphone connected to my wifi network.  If i drill into the network connection, all of the DHCP items are filled in as expected.  Next, I selected "Renew Lease" and went back one screen.  At this point, I was no longer connected to wifi and it showed it was trying to reconnect to my wifi network, but the wheel just kept on spinning.  What's strange is that while it never completed a connection to my network at this point, if you go back into the network details, the DHCP info had a new ip address assigned,  However, my internal network is on the standard 192.168 subnet.  Not sure where this ip address is coming from, but like i said, it never actually completes the connection that it's attempting.  At this point, i turned off wifi and turned it back on.  After doing so, I'm back on my wifi network again.


    One last thing to note is that when I clicked "Renew Lease" on my network connection, it was approximately 17:40 and then a few seconds later is when i turned wifi off and on.  This is when the next entries for my iphone appear in my Time Capsule router log:

    Oct 27 17:40:20 Severity:5      Disassociated with station 60:c5:47:6a:1b:77

    Oct 27 17:40:20 Severity:5      Rotated CCMP group key.

    Oct 27 17:40:23 Severity:5      Associated with station 60:c5:47:6a:1b:77

    Oct 27 17:40:23 Severity:5      Installed unicast CCMP key for supplicant 60:c5:47:6a:1b:77


    The first line shows my iphone finally dropping off the network (when i clicked "Renew Lease").

    The second line is the router rotating it's security key because a member dropped off the network.

    The third and fourth lines show my iphone coming back on to the network after i turned the wifi off and then back on.


    That's all i got...

  • tekie99 Level 1 (0 points)

    I have 2 4S's and can also confirm this WIFI issue.  I am using a time capsule as my router, and tried using fixed ip's by MAC and it didnt help one bit.  Mind you my iPad 2, and even my HP laptop get 20Mbps on my iPhone's are getting under 1Mbps and sometime's wont even register a number (0.0Mbps).  Last shot I changed my time capsule from AUTOMATIC Radio channel selection to manual.. and set it to a random channel (3) and viola... both iphones are pulling down 10-12Mbps.. which is what my iPhone 4's always pulled. 


    Something is wrong with the 4S's for sure.. hopefully just a software tweak!

  • tekie99 Level 1 (0 points)

    I also had the same exact results for everything you went through, from launching app to opening the airport utility.. everything you experienced I did also.. the only thing that has worked for me and my 2 4S's is changing the automatic channel setting on my time capsule to manual and settings my channel to 3... everything has been running well again for 30 minutes..

  • DenverMojo Level 1 (0 points)

    I've had manual channels all along.  so, don't think that's my issue.  Right after i sent out my last post, i had another recurrence of the issue.  This time, i was only connected to my wifi network for 2 minutes before it froze on me.  At this point, I just have my wifi turned off. 

  • DenverMojo Level 1 (0 points)

    spoke to Apple Support again this morning.  They are sending me a replacement iphone 4s.  We'll see how that goes. I should get the replacement Monday/Tuesday.  I'll let folks know how that goes.

  • sparkbox Level 1 (15 points)

    Yeah my replacement didn't perform any better.  The funny thing is when I connect to my parents simul dual band airport extreme (latest model) the wifi problem goes away.  I just replaced my wrt54g running 2.4 tomato usb firmware with a Netgear WNDR3800 router (updated stock firmware and it has improved but not as good as my parents airport extreme.  My iPad 2 with iOS 5 has performed fine all the above mentioned devices.

  • steveburn Level 1 (0 points)

    I had the same problem, my 4s just decided to stop connecting to my home network. I upgraded everything, did a complete restore and reload, still didn't work. Then I tried resetting my router...hey presto it works again.

  • Jayson TO Level 1 (0 points)

    I posted my answer again here.


    You need to swtich to a different wireless router.


    I had the same issue with my new iPhone 4S. But I sloved it by swtiching to a different wireless router. With my older router which was Netgear, my iPhone 4S could connect my wifi, but can't go online. At the same time my iPhone 3G wifi works fine. I did some research and found some routers don't support iOS devices very well. Then I changed my wireless router to D-Links. Now my iPhone4 S wifi works perfectly.


    Another way to test wheather your iPhone 4S wifi works or not is to go to some public wifi, such as Apple store, or Starbucks. If you can connect your phone with their wifi, it means your phone is fine and there must be something wrong with your wirless router. Try to use different brand name wireless router, try to use WAP instead of WEP for your secuirty setting.


    Hope my experience will help you to slove the wifi problem.



  • gnaismith71 Level 1 (0 points)

    I've got the same issue and only bought the iphone 4s as my old 3g had the age old synching problem. Getting a great wifi signal but it just hangs and that thing at the top keeps going round and round but it does seem better if it is right next to the (netgear) router. We've currently got 2 of these and was keen on dishing them out to my entire company but I think it might be Samsung or, date I say it, back to Blackberry.

  • mritacca Level 1 (5 points)

    If you want a phone that looks good you go iPhone. If you want a phone that works as a phone, you go Android.   I am tired of my iPhone problems,... year after year.  It's time to switch! 


    iPhone 4S has WIFI and battery issues.  How many beta's did Apple release of iOS 5?   Exactly.  Are we still in beta mode? ALWAYS!


    Get with it APPLE!

Previous 1 2 3 4 Next