Previous 1 11 12 13 14 15 Next 430 Replies Latest reply: Jul 28, 2015 5:48 PM by ruelabr Go to original post Branched to a new discussion.
  • PCEL Level 1 Level 1 (0 points)



    At first everything worked as it should out of the box. I used my WiFi for Safari and E-mail and such. But then it seemed like “WiFi froze” as some people have described it on the forum. I then began to investigate the problem and many people on the web seems too have the same WiFi problem with Iphone 4S and also some with Ipad2. That made me somewhat unhappy because I like my new Iphone 4S and some people seems too think that the problem is with the new IOS5 or a faulty hardware.


    There might be, as with all products on the market, some Iphones with faulty hardware and for those my solution will not work and you probably have too get a new one. But for most of you I would recommend you too try my solution and it might work for you as well. Probably there are more than me with this solution but I have not seen it anywhere online so that’s why I post it too help out if I can.


    My WiFi problem was linked too me using Skype on my Iphone. And after a quick look at the log in my router I found that by some reason the Skype app somehow got my Iphone blocked when my router analysed my traffic. The symptom was that my router locked out my Iphone from the Internet for a period of time. If this have anything too do with just Skype or that in cooperation with IOS5 I don’t know.


    As some people tries too restart, reinstall and a lot else as described on this forum I would imagine that your routers in the meantime removes the ban it has imposed temporary for your Iphone. When you get back on WiFi you get blocked again.


    Now you might say “I do not use Skype nor have Skype app on my Iphone”. Too those people I would say “Lookat your traffic between your Iphone and your router as it might be another app causing a lockout on your router.”


    The solution part I (what I did):


    * Enter your router settings.


    * Allow your Iphone free access too the Internet on your router without router interference such as traffic analysing. Here you may need too have a look in your manual for your router how too make this possible. I put my Iphone in the DMZ (demilitarized zone) (using a D-Link router). The DMZ lets traffic flow without router interference.


    * Restart your Iphone.


    * Now you should be free of the WiFi problem.


    The solution part II (what I will do later on):


    * Try and isolate what causes the router block so you can set up the router too work with the Iphone without using the DMZ-setting as DMZ is viewed as a last resort when all else fails. If you for an example put a computer in the DMZ you will not get protection from the router as you go online.


    * Will try a couple of things, might be the SPI (stateful packet inspection) on my router that generates these lockouts. As DMZ traffic isn’t screened by SPI.


    Some thoughts:

    When I am in another room my signal drops too 18 – 25 % as for when at router it is more like 85%. So if you are away from the router check the signal strength, usually shown in router settings.


    Hope this helps you with your problem.

  • Janfromfortmyers Level 1 Level 1 (0 points)

    I am experiencing the same problems with my iphone 4s. Wifi connectn was seamless for a few days. But then something happened and now my wifi flickers on and off every few minutes.

    I had my first iphone 4s exchanged after experiencing this problem, and now, it is still happening. 


    I tried "forgetting" my wifi connection and then connecting to it again, but the problem started immediately after opening an app. I couldnt access my app because i apparaently had no network connection.  However, My connection is fine on all my other devices.


    Other times my wifi signal would not flicker on and off, but i can tell that it is still not working because pages are not being loaded and, when i go to my wifi settings, it can't even find other networks in my area.


    What should i do? I do not know how to fiddle with my DNS, router or IP settings. So, if i have to do anything like that, then please be patient with me and explain to me how i have to do that step by step in laymans terms.


    Thank you

  • PCEL Level 1 Level 1 (0 points)

    At present I am not sure of my "solution" anymore because the problem is back. And that is puzzeling because it was working before. :-(


    Things seems too be working with the wifi and the iPhone as long as I don't use Skype. I have seen other sites where people say that "Skype kills my wifi" and that is my real problem but might be connected with other wifi problem.


    Might be more than one thing making the symtom.


    Seems like people with Skype-wifi-iPhone problem put their iPhone on their routers "whitelist" to fix it. Not located my routers "whitelist" (if any) I thought my DMZ would do the trick and it did, but strangely not at present.


    Will get back on the forum if I fix it.

  • naja12168 Level 1 Level 1 (0 points)

    I've had my iPhone 4s since October and I never had a problem with it until two days ago. The wifi signal locates and connects but nothing is able to load. Despite being connected I get a message that says "Safari cannot open the page because it could not connect to the server." when at a relatives house I tried using their connection and a message popped up saying "the error was: the operation couldn't be completed. Cannot allocated memory. " I was able to use my university's wifi connection with little issue, but the one at my house and my sister's house lets me connect but not load the page nor search the web. It's very agitating. The same thing is happening to my second generation iPod touch. The other wifi devices, specifically two laptops in my house, are working just fine on the wifi. What can I do? I'm thinking of visiting the verizon store to see if they can help me.


    I've tried forgetting the network and resetting network settings. I've turned the products on and off. I've turned the wifi option on and off, all suggested by apple's trouble shooting page. I don't know what to do and I'm very frustrated.

  • naja12168 Level 1 Level 1 (0 points)

    I've also reset the phone and did what was suggest by soapbox or whatever the poster's name was and I'm still having the same problem. Nothing has worked. I don't have a clue what's wrong or how to fix it.

  • Kingswood Level 1 Level 1 (0 points)

    Personally, I think this is to do with ios 5.0.1 update.

    At first I thought this was a router problem, changed router and did not fix issue, so the router is ruled out. It did however, stop my wifi resetting itself automatically after trying to use FT, so partly fixed. All I get now is the picture n sound freezes for a few secs n then carries on (very much like a buffering prob that you get from time to time) Very annoying though that FT is not as smooth as previously on 4.2.

    Then I remembered I and my partner didn't have this problem with the iPhone 4. (4.2) My partner still has the iPhone 4 and so do my parents, all have recently updated to ios 5.0.1 and now they have the same issue as I do on my 4S.


    Please Apple, accept this is happening to many of your customers globally! since updating the IOS. And find a fix. For me personally, this is far more important than the battery drain issue which is the reason u are working on a new update. To fix both of these issues, would be the best Xmas present.

  • naja12168 Level 1 Level 1 (0 points)

    I think you're right. It has to do with the 5.0.1 iPhone 4s update. I hope it gets fixed.

  • charlesfromunderhill Level 1 Level 1 (0 points)

    WInter ***** in Vermont and this is only making it worse, LOL


    Bought an iPhone 4S about a month ago and after about the first week in starting have WiFi "freezing" issues, no matter what WiFi networks I was connected to. Only way to get WiFi to work again is to turn off WiFi on the phone turn it back on and then reconnect to the network, which MAY, give me another 4 or 5 minute of WiFi access before I have to do it again.


    Now my wife's 3Gs works flawlessly on all the same wireless networks that I have endless problems with. She has all of the apps (and more) that I do, so I can only deduce that this is a hardware or OS issue.

  • EverNot Level 1 Level 1 (0 points)

    I have experimented with a number of different access points and I get the same behavior. It is sad to see Apple in denial. They should acknowledge the problem and fix it. I hope this is not a sign of how the post-Jobs era will destroy a once awesome company.

  • whathefox Level 1 Level 1 (0 points)

    If you have an old iphone make sure the names of the phones are diffrent.  Wehn they had the same name this confused my router and caused it to lock up. I have a linksys e2000 with dd-wrt loaded up on it.



    Also switching security to TKIP instead of AES seemed to help.

  • Kingswood Level 1 Level 1 (0 points)

    I had the iPhone 4 before the 4S and created a new backup with a different name so it wouldn't be that for me.


    I've not tried the TKIP setting though, will give it a go!


    I do have to state that although I do appreciate all the feedbacks with some suggestions to try to resolve it, and I really do appreciate it so please don't see this reply as just another ungrateful Apple user, but this defeats the whole issue. I never had this problem until I got the 4S and changing my router settings is not really a good enough fix. I shouldn't really have to do this. Would I be expected to change everyone's router settings whenenever I want to connect to their wifi? No, so if this is only an iOS bug on 5.0.1, please resolve that instead. I don't mind waiting for a fix, but I would like some kind of reassurance that Apple are aware of this wifi problem and are working on it. (like they are doing for the battery drain bug).  If it is a hardware issue then as a paying customer, I also have a right to know this pretty sharpish too!


    Thanks for reading

  • bjh2000 Level 1 Level 1 (0 points)

    I upgraded from an iPhone 3GS 32 GB to a 4S 32GB in the last half of November. Everything was going OK until about December 6 or 7. Then I started getting random WiFi connections ... The signal was there but no connection to my nearby hotspot. I did a lot of setting changes, turned off notifications, location services and deleted a couple of Apps I had added. Also tried resetting to factory network. Tuning off the WiFi for a few minutes then restarting seemed to be the only way to get the WiFi to start up again, but that would last only about 10 minutes to at most an hour.


    One night, I was using Google for about an hour then switched over to YouTube for awhile. Tried the stock and weather app and they still worked fine. Checked into a couple news apps ... Still OK. Finally went to one of the social sites I have and after about 20 minutes I lost the connection. I deleted that app and have not had a problem for 2 days. YAY!!!


    I suspect this app is somehow corrupt and is causing some kind of interference for the WiFi signal. I have not re-installed this app and don't plan to for another couple of days. So, all I can recommend is that if you have a certain gaming app that has a social side to it (forums and chatrooms) consider deleting the app and rebooting your phone. If my problem does not recur until I re-install this problem child, I think I have pretty good idea where my problem came from. I did have a few problems with this app crashing on the 3GS but not like the problems I had with the 4S running 5.0.1. Hope this helps someone. Take care. :)

  • ARUN1997 Level 1 Level 1 (0 points)

    Hi I was having the exact same problem as you. I logged onto my wireless router settings (net gear) and i played around with the settings but it diddnt help solve the problem. Then I thought back to an article I had read previously about improving a wireless Internet connection. I then went back onto my router configuration and changed the channel to 5( instead of the default which is 6 for me). Maybe this problem was caused by interference with the wireless network by another household product or something. Anyway I thought that might help. It worked for me!!

  • java_4_me Level 1 Level 1 (0 points)

    Well....had same issue as many others with the spinning connection and getting nowhere.  Reset Network settings....nada.  Odd though.......wife's new 4s setup as new phone connected immediately after arriving at new 4s backed up from itunes had problems with home wifi.  Using ATT Uverse router and once I rebooted the router all fell into place and wifi reconnected at home.  Hope it turns out just as easy for some others. 

  • miguel221 Level 1 Level 1 (0 points)

    I have had problems with wifi since I bought the iPhone 4s... But then, I immediately updated it to 5.0.1 once I bought it... I am going to the Apple store where I bought it to change it... It's ridiculous... my Blackberry detects 60% signal strength, while the iPhone 4s detects no networks... After a while, it detects the network, but once connected, it quickly loses the connection or shows a minimum signal strength and seems to "die" even if connected...


    I have a friend of mine that did not experience any issues with its iPhone 4S. We would be side by side, and mine would show minimum signal strength or none, while his iPhone would be connected with maximum signal strength. And not only in one network... We have tried in different routers and networks...


    Some days ago he updated to 5.0.1 and started having wifi problems as well... So I think it might be an iOS issue... to solve battery draining, they have apparentlty messed up wifi... and it is very bad! I use wifi 90% of the time. If it keeps failing over and over, I do not get to use the phone as I wanted to.

Previous 1 11 12 13 14 15 Next