Previous 1 12 13 14 15 16 Next 430 Replies Latest reply: Jul 28, 2015 5:48 PM by ruelabr Go to original post Branched to a new discussion.
  • truelies Level 1 Level 1 (0 points)

    I also have this problem from 3 days ago. The wifi stop working, I need to shut down the phone then restart.

  • vivian_tn Level 1 Level 1 (0 points)

    The same here! We just launched 4s in Malaysia one week ago. my problem came yesterday morning and I did whatever has been suggested in this post. In the evening I went to service provider and ask their technician to check it out. They did test my 4s wifi by connecting to other people's handphone. In that case, my phone was working perfectly. the moment they switched back to public wifi or other wifi, it went freeze. So I double it is because of hardware. It was the first time bThey ended up formated my iphone. However, the problem comes back this morning. Nothing is working for me so far.

  • Shores Level 1 Level 1 (0 points)

    Both me and my fiancé's 4s just quit connecting to my airport. My Xbox, PS3, iMac, iPad all work and connect fine. Good thing Sprint has unlimited data. This is highly annoying, Apple needs to fix this ASAP. Not acceptable.

  • Boudoirwoody Level 1 Level 1 (0 points)

    Same fault here, on my 2nd 4s now as Vodafone swapped the original as they believed it was a hardware fault. My 3GS works great with no probs on 5.0.1, just the 4s. Apple uk suggested an upgrade to 5.0.1 (9a406) from 5.0.1 (9a405).  But this has made no difference also, then they just started ignoring me....great customer support.  This has all the signs of the 4 network signal farce !!!.  Apple hold your hands up, come out and admit their is a problem as I know of 4 people with the 4s and all of us have the same fault. Either admit there is a fault and work on whatever the fix maybe or give everyone there hard earned cash back for " the worlds greatest smartphone" that does not have a workable wifi interface, I'm sick to death of being told to restore/reconfigure/erase network settings etc.. Fix this problem ASAP and come out and admit there is a issue with the 4s

  • vivian_tn Level 1 Level 1 (0 points)

    Updates:

     

    I deleted all the apps I installed and I found my 4s managed to connect to WiFi after a while, Then I reinstalled all apps back. So far it works very well. Keep my fingers crossed.

     

    In my previous post, I forgot to mention that when my 4s can't connect to the office WiFi or public WiFi, the technician managed to connected to other peoples' smart phones and then go online. Not sure if this indicates anything?

  • stacyfrombronx Level 1 Level 1 (0 points)

    I have had the same problem and I called support yesterday and he told me after a long time on the phone that I should call my dslr company and have them send me out a new router/modem. This is after I told him that it had worked before and that the dslr/modem is not at fault because my imac and macbook are running from it just fine with no problems. This iPhone 4s is too expensive NOT to be working in its full capacity. I also noticed that there was a long cue when I called so I was not the only one with this issue. This is really frustrating.

  • stacyfrombronx Level 1 Level 1 (0 points)

    I did the same thing and the wifi problem reverted back to the same problem after a few days.

  • Janfromfortmyers Level 1 Level 1 (0 points)

    I haven't been back since I last posted my problem on my 4s, because it is now working perfectly. 

    I am ashamed to admit that all it took was resetting my modem and router.

     

    I called apple support and the first thing they told me was to reset my router. I said that my router didn't need to be reset because all my other devices are connected to it and their internet connection is working smoothly.  He then told me to to reset my phone's network connection and bring it back to its factory settings. 

     

    I did what he told me to do a couple of times and it still didn't work. With nothing else to do, i finally reset my router and modem by unplugging, waiting for a minute, then plugging it back in all the while thinking that this step is probably useless.  While doing that, i reset my phone's network settings for the 3rd time.

     

    When modem and router were plugged in again and internet was back on, my phone's wifi started to work seamlessly! and it has been that way since. 

    I did everything that I thought would trigger the problem, by connecting to a public wifi, to another resident's wifi, and it is still working perfectly.

     

    I'm sure most people out there have resetted their routers countless times and it still hasn't worked.  But this worked for me, and maybe that's all the other users have to do.

  • yih Level 1 Level 1 (0 points)

    Apple replaced my iphone 4s at the Genius bar after they ran some tests on it - it wouldn't connect to their Apple public wifi, but would connect to a MacBook at point blank range - so obviously a hardware fault with the wifi chipset.

     

    Since replacement on 3rd December, I have had no problems with wifi connections, have been testing wifi speeds using speedtest.net from all the rooms in my apartment and getting good speeds of > 12mbps, which is what I used to get on my 3GS anyway.

     

    Also no problems connecting to public wifi networks, so hopefully fingers and toes crossed this remains the case.

     

    I wonder if Apple have had a faulty batch of iphone 4s that have slipped through quality control?

     

    Just as an aside, when I was at the Apple store, I asked the tech "Genius" if he'd heard of any similar issues with wifi problems on the 4s, and he said mine was the first case he'd seen - there's obviously some corporate line that they've been told to tell consumers, as I honestly don't think Apple know what the problem is at the moment.

  • stupat Level 1 Level 1 (0 points)

    I have sent my to apple, they have sent it back saying they couldn't replicate the problem, so sent my original phone back. Within 20 minutes of wi-fi use the same issue has arisen! I am so frustrated with this!

  • dryron Level 1 Level 1 (0 points)

    I'm not sure if it will fix your problem but it fixes mine,

    During negotiation between the Iphone and router, the MAC address does not seem to be trasmitted to the rooter so the Iphone Mac Address does not apear in the accepted Mac address list. That's why the Iphone cant't communicate. I added the Mac Address manually to the accepted mac ad list on my router and Houra!!!!

    Iphone 4S

    Router Bell 2Wire 2701HG

    Hope it will help

  • dbpaudio Level 1 Level 1 (0 points)

    dryon - your solution was the only one that worked. Add the MAC address manually to the router. BTW do you have DSL?

  • veldom2 Level 1 Level 1 (0 points)

    I've had this problem and have had perfect connectivity to my home network since I switched the "ask to join networks" setting on the phone from ON (which it was set to by default) to OFF.

  • unicohijo86 Level 2 Level 2 (255 points)

    Hi guys,

     

    Well first of all, verifying iPhone 4S Wi-Fi connectivity to a free Public Wifi might not be a very good idea. You're dealing with multiple variables, most of which you don't have a direct control over (e.g., network congestion, your distance from the actual router, and what not). On the other hand, if you have set-up a wireless network at home, one of the things you could check is your router's security settings. Some routers could be set to specificially allow a limited number of mobile devices to connect to the network, some statically assigns IP/MAC address to devices and if youre iPhone 4S isn't in the list, even if you have the network passwod you won't get to connect to the Internet. Also make sure you're not connecting as a "guest" to your wireless network. Guest sign cuts your connection after a few minutes (or when your phone is idle).

     

    Here is a post of some wireless network troubleshooting tips to successfully set-up your iPhone 4S Wi-Fi connection. http://iphone-and-i.blogspot.com/2012/01/how-to-set-up-wi-fi-on-iphone-4s.html Let me know if you guys figure out a solution.

     

    Happy New Year's!

  • dbpaudio Level 1 Level 1 (0 points)

    unicohijo86 - I've read everything  can on this and clearly there are many things at play here. Commonality appears to be router configurations, but there are so many possible answers. My problem went away when I added my MAC address to my router.

Previous 1 12 13 14 15 16 Next