Previous 1 17 18 19 20 21 Next 431 Replies Latest reply: Dec 21, 2015 7:48 PM by Triton7 Go to original post Branched to a new discussion.
  • StevePNJ Level 1 (0 points)

    After calling Verizon Wireless and discussing the problem, they replaced the handset with a new iPhone 4S.  The new phone works perfectly. If you are having this problem, I suggest a call first to Apple support to see if the problem can be fixed.  They will have you change settings in the router including WEP to WEP2, SSID and password.  When this doesn't work, they will get you to a senior advisor.  Having told Verizon the failed steps I went to in order to get the wi-fi back, they replaced the phone.

  • McTK Level 1 (0 points)

    Fix: Changed my DHCP address range


    After struggling with this issues for several days at home - from having a 4S, a 4 and a iPod touch all working fine to them stopping working on wifi one by one I was getting very frustrated. I tried most of the suggestions in this thread, after hours the only thing that worked was setting a static IP working for the 4 & 4S.


    This morning the iPod stopped working and setting a static IP wouldn't work. To me it was a DHCP issue. Sometimes it could find the router (in network settings for the particular access point) but would still only have a self assigned IP address.


    I finally thought I'd try something random and changed the address range for the router from 192.168.0.x to 10.x.x.x (different subnet too). My brain does seem to recall something about the 192 range being fallible for some reason.


    The ipod started getting a proper IP address, but still had the old DNS for some reason so I had to "Forget" it and connect again - this time it worked.


    I went back to the phones and turned them back to DHCP from Static, forgot the network, reconnected and all seemed to work fine.


    Oh and in between I turned off my router and let it sit for a good 20 minutes.


    May not help everyone but it's another thing to try!



  • AudiRS Level 1 (0 points)

    Thanks to the service in Bulgaria my device was replaced again.New IPhone is produced 2 week 20012 and work great.My advice is to try to replace problem phones, for me problem is hardware.

    Thank you Germanos

  • Anoimus Level 1 (0 points)

    i got some problems with the wifi too, i am able to connect to the wifi but sometimes it is unable to access the internet or uses those apps which requires internet, i followed apple's provided solution and managed to solved the problems but sometimes later the problems appears again, please tell me whether its a bug or defective hardware issue, thanks

  • LaineYMCVlog Level 1 (0 points)

    Is there any update on this.

    I had a 3gs worked brilliant.. sold it .. bought a 4S and having the Intermittent wifi drop every couple of minutes

    tried WPA / WPA 2 / Fixed DNS Settings / Reset network settings ..  still no joy.

    It may be worth knowing that i work for a massive cable provider in the uk (Virgin Media) and i work in the Tech Support Department and have countless of these and now i have the issue myself!


    Phone worked fine for a few days now it just locks up as if its trying to load a page / youtube / connecting on email.. the WIFI keeps me connected but i lose all throughput. renew lease etc does nothing..


    Something really has to be done about this. Has apple recognised this as a fault yet.

  • jc paris Level 1 (5 points)



    I live in Paris, France . I experienced, too, issues with Wi-Fi connections with my new iPhone 4s bought a few days ago . I solved the "at home" problem by disabling mac in Airport Extreme .

    But if I put my MacBook next to my iPhone, the latter display 2 or 3 other nets instead of a good dozen in the vicinity with my MacBook .

    Anyway, I phoned Apple and they send me to one of Paris Apple Store . And the guy there told me that indeed my phone was not receiving a good signal from their own  public net and that the problem was known and happened with some of the phones. Since mine was new, he told me to ask for an exchange ....So it seems it's not an OS problem...

    I'll keep you informed,


    Jean-Claude , Paris

  • mob1977 Level 1 (0 points)

    Hey guys, I have my iphone 4s updated to ios 5.1 and there is no any problem with wifi connection. I had the same issues with wifi before update. So get your iphone update!!!


    Best regards,



  • trickstyx Level 1 (0 points)

    After getting irritated enough,I took my phone to the apple store were they determined that it was a defective phone and replaced it with a new one,now it works perfect .i would get it checked cuz I had updatd and it still didn't work .

  • topdow Level 1 (0 points)

    Similar problem that when on home wifi the 4s seems to sleep, and will not answer FaceTime or take I messages. If the phone called or makes FaceTime or I message it wakes. During this sleep time it will not be found on find my iPhone.


    The phone shows a good wifi signal and if is used for any net apps it appears to rejoin the network.


    Tried all resets and did notice that resetting network fixed the problem. However this also wipes your 3G mobile data setup. When I setup the 3G the problem returned.


    If I turn off mobile data when on wifi the problem is fixed.


    So what is making the 4s drop out with wifi and 3G mobile data both on? When I leave home I have to remember to turn 3G mobile data back on and turn it off when back home.


    Any ideas would be appreciated.

  • manojsn Level 1 (0 points)



    I had bought the iPhone 4s 2 months ago amd until y'day it did not have any problems connecting to the WiFi.

    From y'day the wifi connection drops every 2 minutes.

    I have the latest iOS 5.1 on the phone, so it is not about an upgrade.

    I have tried what you had mentioned about shutting of the 3G and mobile data, but having switched off both, still does not keep my wifi link live.


    The only way it works for me is to switch off and switch on the Wifi Network.


    I will take my phone to the Apple store and check it out.

  • topdow Level 1 (0 points)

    We have 2 iphone 4S and it is the same problem. If connected to Wifi you have to select mobile data off or it will drop the wifi until it is called or you use a wifi application. This means that it won't answer face time, get imessage or be 'found' with 'Find my iphone. OS upgrade to OS 5.1 did not fix.


    manojsn let me know what apple say.

  • manojsn Level 1 (0 points)

    Hi Topdow,

    Before leaving for the Apple store , there was another thing that came to my mind, and I reset(switched it off and On) the wifi router, and after that the wifi connectivity seems to be working for the last 45 minutes.


    I had kept the 3g and the mobile data off. Later I have set both of them ON and the wifi connectivity is working fine.

    Can you please check by resetting your router. Just wait for around 15 to 30 seconds before setting the router on.

    Hope it will help you, and hope, mine works, without any problem.

  • topdow Level 1 (0 points)

    I did try that and setting a specific IP adddress but unless I switch off the mobile data. the Iphone although showing Wifi is not connected unless it gets a call or an an APP is used that needs WIFI. This is OK but as before no imessage get recieved or face time.


    Glad yours is OK

  • DmncnGy Level 1 (0 points)

    Here's my situation, not sure if the same holds true for everyone else. I've reset the network (on the iphone), have forgotten the AP, restarted the device and none of this has ever worked. I had noticed that the issues started shortly after receiving a new Comcast gateway (Arris). But my iPad 2 connects, my MBP connects, my Windows computer connects, my evo 3d connects, my kindle fire connects. So the problem is with my two iphone 4s devices. Going back to the earlier point - the previous gateway, previous to the comcast model, had a particular SSID. I decided to keep the same SSID w/ the new gateway. I wonder if the reset network doesn't eliminate stored SSIDs or if it's somehow tied to this? I say this because when I reset my gateway to use the default SSID with the same password I had used previously (w/ the old gateway), the devices both connect and remain connected. I did change all protocols and even placed the iphone 4s as a dmz device on an open network and nothing worked. So I wonder if any of you are noticing this after switching out gateways and keeping the same SSID? Or if any of you are using the Comcast Arris Gateway?

  • coloursss Level 1 (0 points)

    Hi guys. I've gotten the same problem too. Rebooted my phone. Resetted network settings. Resetted all settings. Restored it too. Nothing happened. But I read from another post that you can try this...


    1. On Airplane Mode

    2. Switch off phone

    3. Switch it back on

    4. Off Airplane Mode

    5. On your wifi


    The person who wrote it didn't work for him, but it did for me! You can try it (:


    I finally can choose a network! Finally!!! (:

    Hope it works for you guys too!

Previous 1 17 18 19 20 21 Next