Previous 1 21 22 23 24 25 Next 431 Replies Latest reply: Dec 21, 2015 7:48 PM by Triton7 Go to original post Branched to a new discussion.
  • Doc_ Level 1 (10 points)

    Would you be able to leave the slider grey until you could get to a Genius Bar?  Maybe just go in and tell them it's been happening occasionally - they may take your word for it since it's a known issue.

  • Jan4AN Level 1 (0 points)

    I have no idea if the slider stay grey for a long time. About the Genius Bar, is there one in the Netherlands? Apple store in Amsterdam? I ordered my Iphone online at What about the garantee?


    After I had reset my Iphone with iTunes the problem was stil there. Now I reboot my Wifi Router and for one day I had no problem! second day the problem was back. Til now I have no grey slider but a bad connection is stil there. Turn on and off flight mode will help.


    Apple, its time to come with a sollution!

  • ISOLAR Level 1 (0 points)

    Hi all, I just went interstate with my phone (4s on 5.1) and started using cellular data instead of wifi like I usually do. No issues doing this. Upon return my phone would not load any data through the wifi in my home network. Very puzzling. Well maybe a slight burst for 2-3 seconds after I turn airplane mode on and off, but then error message saying 'cannot connect to server' kept popping up. My gf's phone/ipad works flawlessly. So I started reading around and playing with all of the ideas across the forum.


    Seems that I could connect to the access point, it asks for password, then DHCP from router assigns me an ip address. That all seemed sweet so I looked into DNS.



    For some reason my iphone4s does not like using DNS through my router anymore, even though ALL other connected devices are having no probs here.


    So I went Settings/General/Network//Wi-Fi and clicked the blue arrow button next to my connected network to bring up the stats.


    Then changed from DHCP to static and entered an IP address in valid range (not in use), subnet mask (, my router address, THEN in DNS I typed in the direct DNS server address that my router uses through my ISP.


    BANG!! Safari and all other apps started loading data!!


    Please try this if you are having issues and report back if this lets data through wifi again \m/

  • ISOLAR Level 1 (0 points)



    Seems that the 4s wifi (and possibly others) has a small bug from time to time when switching between networks when 3g and wifi are enabled in the phone at the same time.

    The iphone SHOULD automatically connect to 3G once wifi goes out of range.. and this is where the problem seems to stem from. I confirm this as I have only had the problem since coming back from interstate and using my phone as an AP there over 3G.

    So the flow is

    At home (wifi working) -> Travel interstate (wifi turned on + 3G turned on - works, wifi not tested so unsure) -> return home and disable Cell data/3G (Problem begins)


    I'm not sure exactly what records in the phone are having trouble being updated/overwritten when this changes... but I have a feeling it'll be a nice friendly .plist file somewhere that is .plisting me off!

    Most likely something to do with the DNS registration process of the iphone.

    I am convinced that it is not the router now. Other posts around have suggested changing the wifi channel in the router, which I changed from 11 to 6. Upon initially changing the channel the wifi still didnt work.


    So I then disabled uPnP in my router (which I use for port forwarding purposes), thinking that maybe the iphone is being blocked here..

    Could still connect to AP but no wifi access.

    With uPnP disabled I checked 'forget this network' in the iphone.

    Then loaded safari and reconnected to my network with DHCP enabled on the phone.

    Then turned uPnP back on in router.


    After about 10 seconds the iphone had an ip address over DHCP and the DNS entries reflected what was in the router. So basically whatever I did in the last few steps had fixed the issue.. seemingly.


    I started wondering if changing the wifi channel was actually the fix, but needed some time to reconfigure.. so I retested by changing the channel back to 'auto' which set it back to 11.

    Sure enough, everything is still working.. so using a different channel is NOT the solution here.. although possibly changing the channel then reconnecting your phone to the network MAY overwrite the problem area.


    Will research further... but for now I managed to get my iphone back on the wifi using DHCP rather than manual settings. Oh and realised that I could change the channel width to 40hz!! Now my home wifi network FLIES!!

  • Shrink wrap Level 1 (0 points)

    What are your security settings? I solved my problem with 4s (ios 6) connecting to my home wifi by changing the encryption protocol on my dual band router from WPA2-AES to WPA2-TKIP. This was after months of pulling my hair out & trying everything I could think of. Works great now, though had to accept my other devices are now also using g standard instead of n. Not noticeably slower though.

  • Jomaski Level 1 (0 points)

    Here it is January 2013, i have had my iphone 4s for one year and two weeks, NEVER had any problems with wi-fi, battery, echo, etc. Until yesterday, when BOOM, dropping of home wifi network, not finding network. Literally place the phone onto the wireless router before it would connect, then still only had one bar. Did all the suggested crap to my router, blah, blah,blah, didnt work. shut down and repowered the phone to discover that I could no longer turn my wifi on at all - greyed out. I then began the painfully long process of speaking with my carrier who told me oh well, we can give you a new crap *** phone for $30, your warranty is up. Call apple tech - at first they wanted to charge me but i called BS on what is apparently well known issue and told them to stand behind their product, and they sorta did. We went through the process of backing up and restoring the phone and setting up as new, but no luck, still grey. My smart phone is now no more than a cheap flip phone. Apple says they will replace it _ for a charge, but will not send me a replacement until they get the old one - YES, let me give you my business phone for two weeks, I'll just put my business and life on hold for you Apple. In all my frustration I am now looking at other options, as much as I have loved my iphone 4s and my 3 before it, I cannot continue to support a company who insists on making extremely expensive - apparently disposable - devices. I would think for 100's of $$ you could get a few years use out of it.


    While being frustrated at my now useless phone, I decided to throw this very fancy paperweight of mine into the freezer - a suggestion on one of the many threads pertaining to this issue, it spent about 5 minutes there, thinking about its unacceptable behavior. After I removed it, and after recovering its wits this sneaky little bugger has wifi again - spotty at times, totally still struggling, but I can at least turn the wifi on and off again.


    So first off WHY???? did that work?? Secondly just for the sake of an apple person actually reading this. IT IS STILL AN ISSUE, IT HAS NOT BEEN RESOLVED, FIX IT ALREADY.


    Jeez this fricken thread was started in Nov 2011 - OVER ONE YEAR AGO!!!!!!!!!!


    Totally just a vent.  I am done.

  • e5yvx Level 1 (0 points)

    Hi, Sorry to add more problems to this but I also have a solution that works for me. It's a very temporary solution bc I don't htink it's safe for my phone.


    I have to literally heat up my phone to get the wifi to work. Does this mean I have a hardware problem?


    Thanks for answering.

  • arif2kar Level 1 (5 points)

    this is iphone4s user gift from apple,

    we hope they have been solve in 6.1 but no use.

    problem still same.

  • Danielelel Level 1 (10 points)

    This is realy a DEAL BREAKER!


    I think about my next Smart Phone.... mmmm.... NOT APPLE!

  • Hofo2 Level 1 (0 points)
    • Ok. I have my iPhone 4S since September. I bought it in Brazil. In November it started with the Wi-Fi problems. It was really bad that the Wi-Fi was in and out every time until it really grayed out. I was at apple store in Montreal and they replaced for a new one. Believe you or not, today it started with the same problem. I upgrade to IOS 6.1 but it still has a very unstable Wi-Fi connection. This phone has only three weeks of use. I cannot believe it.
  • DylJamez420 Level 1 (0 points)

    It is a Software/Hardware issue, has been ever since 6 came out. I have been with apple from almost day 1 and not until OS 6 came out is when the problems started occuring with the iphones. After my contract is up I am never buying another iphone again, thinking of either checking out the S3 or by that time itll prolly be the S5 or something or maybe seeing if blackberry will be a stable phone. The unreliablity and inconsistancy is such BS.

  • AsliBi Level 1 (0 points)

    I had this "greying out" problem with the wi fi on my I phone 4S.

    I tried everything. Reset all settings, hard reset, etc.

    It was coming back from time to time but only for like half an hour.

    I took it to an Apple store and they erased all data and returned the phone to factory settings.

    Still no good.

    Then one day, I dropped honey on my I phone cover while having breakfast, I took it off, it was a thick hard plastic look alike casemate cover, and I cleaned the phone and didn't put back the cover


    I did a reset on the phone and the wifi was working.

    And it's been working well since ..

    Now I don't know if this has anything to do with the cover or not but this is definitely one of the weirdest stuff that has happened to me..

  • Topiltzin Level 1 (0 points)

    I upgraded the latest version of IOS and my iPhone 4S is not working anymore with the wi-fi. The switch on/off is gray or unavailable any more. I had my phone fix with a guy that works for IUSACELL company in Mexico that provides cell services, and he charged 75 dollars!! Wouldn't Apple be aware of that, wouldn't they give us some support?

  • Topiltzin Level 1 (0 points)

    I have the same problem and pretty sad because my warranty is finished 2 months ago. Some guy says he will fix it for 75 dollars, I live in Mexico. This is pretty bad!!

Previous 1 21 22 23 24 25 Next