Previous 1 2 Next 17 Replies Latest reply: Apr 2, 2012 8:44 PM by gfunkonthecheesetree
UncleRichard Level 1 Level 1 (0 points)

Here's what I have tried:

 

Adding account from preferences in Mail (BTW, the account works fine on my iPad). Used my full name, free iCloud (me.com) email address (which works fine on my iPad and on iCloud.com), and password. All checked and reentered multiple times for accuracy.

Result: "Logging in to the MobileMe IMAP server “mail.me.com” failed. Make sure the user name and password you entered are correct, then click Continue. If the information isn’t correct, you cannot receive messages."

 

Using my Apple ID instead of my full name, with the same email address and password.

Result: This allows me to set up the account. I get to the Account Summary page, having kept the default settings, entering passwords where necessary. I tick 'Take account online' and click 'Create'. Then, a dialog box comes up: Enter password for account "iCloud". The MobileMe IMAP server “mail.me.com” rejected the password for user “[myusername]”.  Enter your password again or cancel. Entering the password makes the dialog go away...for a minute or so, and then it comes back. Even though I have entered the password and ticked "Remember this password in my keychain", the password field is blank. Repeat until my brain melts... Even pressing cancel doesn't stop the dialog from reappearing. Eventually it stops. I change my 'Full Name' from my Apple ID to my real name and take the account online. The same behaviour ensues. I delete the account. Unbelievably, I still get the dialog once more.

 

Using my Apple Support username instead of my full name again allows me to set the account up, but with the same results as above. As far as I can tell, it will only accept my Apple ID or support username, or a blank. The blank gives no joy either. Except, wait, I just tried and this time it accepted my real name, but only after rejecting my support username.

 

I've tried moving out all three preference files beginning with com.apple.mail from ~/Library/Preferences. Doesn't work, although interestingly, when I launched Mail it had my iCloud/MobileMe account set up already under my login username, which is different again. But I just get that dialog box again.

 

Going to System Preferences and trying to sign in to MobileMe doesn't work (I don't have a full MobileMe account, just the free email address, so assume this is why).

 

I note that when I do have the account 'set up', the incoming and outgoing mail servers differ to what is shown here: http://support.apple.com/kb/HT4864 . I can only edit the outgoing server, which does not help anyway.

 

I haven't been able to find anyone who's posted the same problem, so it's really beyond my knowledge to know what is happening here.

 

I hope someone can help me, I'd be grateful if I felt I could get moving again! I've never felt like I resented my Mac so much – usually I love it, even when it has problems.


iMac, Mac OS X (10.6.8), SMCFanControl helps with faulty GPU
  • Ernie Stamper Level 8 Level 8 (37,555 points)

    By all that I read, iCloud is not meant to work without Lion.  I have not seen any info about whether the mail service alone can be made to work in Snow Leopard.

     

    If it were to work, it would only be after having first set up an iCloud account from, say, your iPad.  Then in Mail attempt to set up the account manually.  To do that, you can try to fill in the firs page of info for a new account, and then hold down the Option key until the Create button changes to read Continue.  Then click on Continue and proceed in a manually method to enter the proper server names.

     

    But I have not tried that, and it may not work at all, but that is how to bypass default setup of an email account.  I suspect it cannot be made to work with @mac.com addresses, but only @me.com ones.

     

    See:

     

    http://support.apple.com/kb/HT4864

     

    and

     

    http://support.apple.com/kb/HT4929?viewlocale=en_US

     

    Ernie

     

    Message was edited by: Ernie Stamper

  • UncleRichard Level 1 Level 1 (0 points)

    Thanks, that's a good tip about the option button.

     

    I have already set up the account on my iPad (in fact, I think it was set up automatically on iPad mail when I used the iPad to sign up for iCloud).

     

    Will try this tomorrow and report back.

  • UncleRichard Level 1 Level 1 (0 points)

    Ernie, I'd like to mark your answer as correct but don't think I can, since I already marked it as helpful.

     

    The way to set iCloud mail up appears to be manually, using the option button to change 'Create' to 'Continue', entering the new server details that Apple gives here:

    http://support.apple.com/kb/HT4864

     

    Also importantly, on Snow Leopard you must select IMAP as type of account, rather than MobileMe (which will name the servers incorrectly and not allow you to edit them). Perhaps Apple will update Mail on Snow Leopard and possibly earlier OSes to reflect the new server names. What is a nice touch, however, is that the account is given the special MobileMe icon (in the Mail Preferences) even though it was set up as just IMAP.

     

    Thanks again.

  • willingfoe Level 1 Level 1 (0 points)

    Following advice elsewhere here on discussions, I had this working for me from Mail.app on my MacBook Pro (OS X 10.6.8) fine. Until this morning. Now it's not recognising the password. Are Apple really actively removing compatibility???

     

    I don't need iCloud syncing of iTunes - there's plenty of functionality I don't need and can do without. It is really incredibly frustrating not to have basic Mail/Contacts/Calendar syncing though. For 3rd-party software reasons I cannot upgrade to Lion.

  • UncleRichard Level 1 Level 1 (0 points)

    It's still working for me.

     

    Check http://www.apple.com/support/icloud/systemstatus/ (although it says it's all fine now).

     

    Can't think that Apple would remove compatibility for an IMAP mail account. I think they have just forgotten to update Snow Leopard with the correct server details for adding a MobileMe account.

     

    First check that both the server names are correct (i.e. imap.mail.me.com and smtp.mail.me.com). If not, try editing them. If you can't do that, you could try deleting the account in preferences, and adding it again according to my post above, backing up mail messages first if necessary (this step might be very important, though I'd be surprised if the message files themselves are deleted from your hard drive when you delete the account).

  • Ernie Stamper Level 8 Level 8 (37,555 points)

    Mailboxes are deleted from the local drive when you remove an account.  But when IMAP, they actually reside on the server, and what is on the local computer is only a copy meant to be temporary.

     

    But be aware that if you remove a POP account, all the standard mailboxes kept in its account folder will be lost.

     

    Removing an account, does not impact On My Mac mailboxes.

     

    Ernie

  • willingfoe Level 1 Level 1 (0 points)

    First off, I appreciate the response - input from people like you is what makes discussions.apple.com so great.

     

    Now: part of the problem certainly seems to be the server names. Following a post elsewhere here on discussions, I had set them to p02-imap.mail.me.com (incoming) and smtp.me.com (outgoing). These worked as recently as last night.

     

    After 4 or 5 attempts, I eventually got it to work.

     

    I've followed the steps you outlined, always alt-selecting to get 'continue' as an option. However, even when the steps are completed, I see the account listed as being 'MobileMe IMAP' despite specifically selecting IMAP in the set-up procedure.

     

    In the end, I:

     

    1. Deleted the account in Mail Preferences
    2. Selected another account and used the pull-down menu for Outgoing Mail Server to go to 'Edit SMTP Server List...' and erase any legacy info there.
    3. Opened Keychain and erased any reference there to relevant items by filtering 'imap.', 'smtp.', 'me.com' etc.
    4. I quit Keychain and Mail, emptied the trash and re-started (these last 2 because it was attempt no. 4 and a reasonably thorough purge hadn't worked until then).

     

    It's now working. I'm a little unclear sometims how passwords and such are stored by Keychain so I went with a pretty thorough clean.

     

    Now I've to check if my iCal is still syncing with the p01-caldav.icloud.com Server address.

  • UncleRichard Level 1 Level 1 (0 points)

    willingfoe wrote:

    However, even when the steps are completed, I see the account listed as being 'MobileMe IMAP' despite specifically selecting IMAP in the set-up procedure.

    I also see this, but crucially, choosing IMAP rather than MobileMe when setting up allowed me to change the server names. Your step 2 is something I forgot to mention. As for steps 3 and 4, I didn't even think of that, but I did as a precaution reenter my password (which was already filled in with something) each time I readded the account in Mail.

     

    I note that the Mail server information page given by Apple and linked to above was modified on October 12th, so perhaps they just stopped using old names for the servers soon after that, but older versions of Mail weren't updated with the new names.

  • willingfoe Level 1 Level 1 (0 points)

    Nope. Gone again. I am completely at my wit's end here. I am receiving incoming emails on all devices but cannot send from Mail.app on the MacBook.

     

    May I ask:

     

    Have you filled anything in under Description for the Outgoing Mail Server? (I believe this shouldn't make a difference in any case).

    For Advanced Settings, have you selected 'Use Default Ports (25, 465, 587)' or have you specified 'Use Custom Port' and set that to 587?

    For 'Authentication', what have you used? (I have 'Password')

    For 'Username', have you put 'Username' or 'Username@me.com'?

     

    I'm repeatedly getting the same message as before: The SMTP server "smtp.mail.me.com" rejected the password for the user "my.username@me.com".

     

    I've tried removing the server from the list and adding it again. I've tried re-entering the password. I've tried setting the port specifically to 587 - having started with 'Used Default Ports (25, 465, 587)'.

     

    I note that the settings on the iPhone (granted, running iOS5) says:

     

    Host Name - iCloud SMTP Server

    User Name - Optional

    Password - Optional

    Use SSL - ON

    Authentication - Apple Token

    Server Port - 587

     

    What's 'Apple Token'? It's not an option in Mail running in OS X 10.6.8.

     

    Any guidance gratefully received.

     

    Edit: it's showing the AppleID piece as if it were an email address. Apologies, having difficult turning that off.

  • UncleRichard Level 1 Level 1 (0 points)

    Description: iCloud (I changed it from MobileMe but I think I did that after I first got it working)

    Advanced SMTP settings: Use default ports (25, 465, 587)

    SSL: On

    Authentication: Password

    Username: 'username'

    Password: 'Apple ID password'

     

    I had, and probably still have, a problem with gmail on IMAP for a very long time where Mail would keep asking for the password and go offline. It would sometimes not send messages for hours or days. I would get around it by using a different SMTP server. I think there must be some problem with Mail on Snow Leopard (I think I even had the problem on Leopard, too) that causes these sorts of problems.

     

    I don't think 'Apple Token' is important for this problem, as the fact that I can use IMAP iCloud Mail on 10.6.8 proves it is not necessary. I guess it's just a propietary authentication system developed for Lion (possibly) and iOS5.

  • willingfoe Level 1 Level 1 (0 points)

    ****%&** !!!

     

    Nothing. I've tried all the steps above. I've tried 2 configurations of Username (I ought to have been clearer in my question. My AppleID here on discussions is 'willingfoe'. My AppleID for iCloud is 'user.name@me.com'. I think it may be possible for someone to set up an account where the username doesn't include the '@me.com' portion - for iCloud, my username does include the @me.com). Does the 'username' you use above end in '@me.com'?

     

    Interestingly, Mail checks and receives incoming mail whether I have only put 'user.name' in or the full 'user.name@me.com'. The 'Trash' folder is functioning and deleted items disappear from the 'Inbox' and show up in the folder in all devices regardless of where they're deleted from.

     

    If I open the 'Account Info' window and select the account, the Quota Limits are displayed, including for the 'Sent' folder (hovering the mouse over this in the Mail sidebar says 'Contents stored on server. Name on server: Sent Messages'). Thus, lots of the queries and so on currently being handled without issue but I have a message stalled in my outbox.

     

    I ran Connection Doctor a few times (lots of deleting from SMTP lists and keychains in the meantime). The first time, from what I could see, it was trying Port 25. I deleted the old one and set it specifically to 587. Running Connection Doctor, here are the 2 relevant sections - this is way past my level of experience but I think it might be helping in at least diagnosing the problem.

     

    For the Incoming Server (I have substituted ••••••.•••••• for my Username, ********** is how the password is displayed to me in Connection Doctor):

     

    CONNECTED Oct 23 15:07:37.836 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x1162b8970

     

    READ Oct 23 15:07:38.199 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x1162b8970

    * OK iSCREAM ready to rumble (r1F3601+:14874)

     

    WROTE Oct 23 15:07:38.211 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x11625bbb0

    1.29 CAPABILITY

     

    READ Oct 23 15:07:38.331 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x11625bbb0

    * CAPABILITY st11p00mm-iscream004.me.com r1F3601+ XAPPLEPUSHSERVICE IMAP4 IMAP4rev1 SASL-IR AUTH=ATOKEN AUTH=PLAIN

     

    READ Oct 23 15:07:38.347 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x11625bbb0

    1.29 OK !!

     

    WROTE Oct 23 15:07:38.364 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x117313a60

    2.29 LOGIN ••••••.•••••• **********

     

    READ Oct 23 15:07:38.556 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x117313a60

    2.29 OK User ••••••.•••••• logged in 713339

     

    WROTE Oct 23 15:07:38.575 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x101311360

    3.29 CAPABILITY

     

    READ Oct 23 15:07:38.707 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x101311360

    * CAPABILITY XAPPLEPUSHSERVICE IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ NAMESPACE UIDPLUS CHILDREN BINARY UNSELECT SORT CATENATE URLAUTH LANGUAGE ESEARCH ESORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES CONDSTORE ENABLE CONTEXT=SEARCH CONTEXT=SORT WITHIN SASL-IR SEARCHRES XSENDER X-NETSCAPE XSERVERINFO X-SUN-SORT ANNOTATE-EXPERIMENT-1 X-UNAUTHENTICATE X-SUN-IMAP X-ANNOTATEMORE XUM1 ID IDLE

     

    READ Oct 23 15:07:38.746 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x101311360

     

    3.29 OK Completed

     

    WROTE Oct 23 15:07:38.783 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x101311360

    4.29 LIST "" ""

     

    READ Oct 23 15:07:38.914 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x101311360

    * LIST (\Noselect) "/" ""

    4.29 OK Completed

     

    WROTE Oct 23 15:07:38.928 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.mail.me.com -- port:993 -- socket:0x116269da0 -- thread:0x1162c18e0

    5.29 LOGOUT

     

    And for the Outgoing Server:

     

    CONNECTED Oct 23 15:07:38.828 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

     

    READ Oct 23 15:07:38.946 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    220 st11p00mm-asmtp003.mac.com -- Server ESMTP (Oracle Communications Messaging Server 7u4-23.01(7.0.4.23.0) 64bit (built Aug 10 2011))

     

    WROTE Oct 23 15:07:38.962 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    EHLO [192.168.1.16]

     

    READ Oct 23 15:07:39.075 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    250-st11p00mm-asmtp003.mac.com

    250-8BITMIME

    250-PIPELINING

    250-CHUNKING

    250-DSN

    250-ENHANCEDSTATUSCODES

    250-EXPN

    250-HELP

    250-XADR

    250-XSTA

    250-XCIR

    250-XGEN

    250-XLOOP 9C7468C76FA3C4329E36A16D156E8021

    250-STARTTLS

    250-AUTH PLAIN LOGIN

    250-AUTH=LOGIN PLAIN

    250-NO-SOLICITING

    250 SIZE 0

     

    WROTE Oct 23 15:07:39.096 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    STARTTLS

     

    READ Oct 23 15:07:39.211 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    220 2.5.0 Go ahead with TLS negotiation.

     

    WROTE Oct 23 15:07:39.850 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    EHLO [192.168.1.16]

     

    READ Oct 23 15:07:39.966 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    250-st11p00mm-asmtp003.mac.com

    250-8BITMIME

    250-PIPELINING

    250-CHUNKING

    250-DSN

    250-ENHANCEDSTATUSCODES

    250-EXPN

    250-HELP

    250-XADR

    250-XSTA

    250-XCIR

    250-XGEN

    250-XLOOP 9C7468C76FA3C4329E36A16D156E8021

    250-AUTH PLAIN LOGIN

    250-AUTH=LOGIN PLAIN

    250-NO-SOLICITING

    250 SIZE 0

     

    WROTE Oct 23 15:07:39.982 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    AUTH PLAIN  (*** 44 bytes hidden ***)

     

    READ Oct 23 15:07:40.166 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    535 5.7.8 Bad username or password (Authentication failed).

     

    WROTE Oct 23 15:07:40.183 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.mail.me.com -- port:587 -- socket:0x116207210 -- thread:0x115a54330

    QUIT

     

    The penultimate WROTE section here is where it looks like the Server is expecting login information and all that's being conveyed is 'AUTH PLAIN (*** 44 bytes hidden ***)', resulting in 'Bad Username or Password'. Could I ask you to run Connection Doctor and see how that query is handled for you? I will of course understand if this is too much effort. Thanks for all the attention/help thus far.

  • UncleRichard Level 1 Level 1 (0 points)

    Other than to say I use 'username' rather than 'username@me.com' I don't think I can help any further. You only have one Apple ID. Your Apple discussions username is just for these forums and will not have any bearing on this. Actually, I think you can have multiple Apple IDs, but only through cumulative accidents with signing up for different services at different times. If your Apple ID and password get you into iCloud.com, I can't understand why they aren't working in Mail, (minus the @me.com from the Apple ID.) The results you've posted mean nothing to me. Hopefully someone with greater knowledge will chip in.

  • OmegaNine Level 1 Level 1 (0 points)

    This just happened to me too! I set up my iCloud mail in the Mail.app on Snow Leopard, and it has been working flawlessly until this morning. It is giving me the "smtp.me.com" outgoing server password is wrong? This is simply not true, the password is right and I can still send mail from the iCloud account from my iPhone and within the web app just fine.

     

    Is Apple really pulling the plug on us here? I will (for the first time) feel like I'm being taken advantage of from Apple if this is true. I can see them pulling access to us 10.6 users as an incentive to upgrade to Lion - and that's just wrong. (These of course are speculations but it wouldn't surprise me.)

     

    The fact that I can access iCloud from my $300 Windows PC and NOT my $2400 MacBook Pro is mind boggling. I really really hope Apple releases an update for iCloud support within Snow Leopard. I'm just not ready to upgrade to Lion, there are features I simply do not want and Apple doesn't give you the choice.. (no more "save as" ??).

     

    Sorry for the rant, but if this is a recurring issue here in the next few days from other users we'll be able to see a clear pattern here and Apple's true motives.

  • UncleRichard Level 1 Level 1 (0 points)

    I really don't think Apple would ever even consider withdrawing me.com email access from their Snow Leopard users. After all, it's only IMAP mail. They do, of course, eventually stop supporting older OSes, but that won't happen to Snow Leopard for a long time. I have no idea what the fault with Mail or, perhaps the keychain, is, or whether it's a problem with something else altogether like Apple renaming Mail their mail servers but forgetting to tell people or update Mail, but as stated above I had a similar problem with gmail, so don't imagine Apple is out to get you. Why would they when so many people have Macs that can't run Lion or have software they use that don't run on it?

Previous 1 2 Next