Previous 1 2 3 Next 31 Replies Latest reply: May 18, 2014 3:40 PM by anolimit98 Go to original post
  • PaLnTsC Level 1 (10 points)

    That's not the error described in this threat.

  • twigsntrees Level 1 (0 points)

    same problem here... worked fine after update until i switched off the tv, appletv and network for a weekend trip and returned to the usb cable to itunes on the tv. Plus the restore with a micro USB cable has ended up with error 9 and i have tried it on 2 macbook air... one mac mini... i am in asia and i have a feeling i need to bring this back to apple in NY and it is going to be ugly! anyone has a solution to overrule the error 9 through itunes?

  • twigsntrees Level 1 (0 points)

    hi ethan,

    i am in KL too and i have the exact same problem with my apple tv 2... has ur machine been recovered or is it still erratic? have you found a way to resolve the issue?

  • bytor99999 Level 1 (0 points)

    Just adding to the Me Too part of this thread. Getting the same Error 9 when trying to restore with iTunes. I updated to 4.4.3 last night and had problems, thought restore from iTunes would fix it. Well in one way it did fix my first problem but led me to everyone else's problem.



  • Ethan Becker Level 1 (25 points)

    Hi Twigsntrees,


    nice to see someone else out in KL!  Im' sad to report bad news.  The second day of the death of my ATV, I was still in denial, and determined to fix it, but decided to go onto ebay and buy one anyway.  Search the Malaysian ebay site


    I have found that it's not really a malaysian ebay site, but it mostly displays peoplew who will ship to Malaysia.   So, I put that in motion.  It took about 2 weeks.  But, I figuted, this puppy was not going to come back to life.


    I went to 5 computer stores, including the Apple distributors.  Nobody could fix it.  I purchase 5 new micro USB cables.  None of them worked.  Same problem. 


    I have an IP Address I VPN into in the united states..  no luck.  I brought my ATV on a business trip with me to China, and tried it from there, woth with and with the VPN into my IP from Boston, and no luck. 


    So, at this point, my replacement came, and I'm back to normal.  But, I do have my dead one.


    Oh, Mine is under the hardware warrenty so, when I go home to the states (We are moving Dec 17)  I'll bring the dead one into an Apple store, and they can replace it for me. 


    Apple, WILL replace it now.  BUT, I'd need to mail it to a friend at home, have them take it to an Apple store, And then Apple will mail them a replacement, and then that person mails it back to me.  LAME APPLE!!  The cost of all the shipping would be more than the coast of a a new unit.


    Oh, I've been told that you can find new Apple TV's at Low Yat Plaza.  I could not however....  but you might find someone who is reselling them.  Also, check  which is kind of like the craigslist for Malaysia... 


    I hope this helps.


  • twigsntrees Level 1 (0 points)



    hi, i have tried 4 different brands of micro USB cables, did it on mac-s and pc-s.. and the same problem with the restore, error 9. I have to send it to new york because i bought it there... however, the cliche part of it is that i bought two units and only used one... so i have a spare to play for now... the existing unit however needs to be sent back and it is a huge kefuffle... i hope apple really up the game because this is indeed something that should never happen.


    thanks for the heads up ethan! appreciated!

  • twigsntrees Level 1 (0 points)



    i think u need to bring it to a genius bar or a genius if u have one located near u. Ethan and i both are in KL and conincidentally however, am going to new york on the 1st of december for work, hence i hope i can resolve this 99USD problem with a new machine or a restore by the geniuses... good luck and if u found a way that works for u, please tell us how u get over the error 9... it is really not worth my time to buy another micro usb cable...


    twigsntrees (Marc)

  • ATV2SUK Level 1 (0 points)

    Also the same thing here in the UK. ATV2 error 9!!

    ATV2 died when updating and gave the usb and itunes symbol

    Ive tried 3usb cables and three computer to restore from itunes. No Luck at all.

    Apple have to get this sorted.

  • dnoeller Level 1 (0 points)

    The Apple TV is frozen in the film look.

    I've started the new box and since it dependswhen you start in a loop.

    I Tried it on several computers to restore but iTunes always reports error (9)

    The cable I have also changed.

    The warranty has expired for two weeks.


    The only hopeful, I am not alone.

  • bytor99999 Level 1 (0 points)

    I brought mine into the Apple Store and the genius bar tried to restore and it didn't work for them either and then they replaced my AppleTV.



  • PJL500 Level 1 (0 points)

    How to fix a bricked ATV2



    The Oct 2012 update bricked my Apple TV-2, although the update went the same as previous updates and the unit worked for a few minutes. Then, next time I restarted it got stuck on "Whats New?" screen (the Continue button would not respond.) After about 7 minutes wait it went to the Home Screen but without response from the remote (I changed in a new battery too.) Then it went to the screensaver and stayed stuck on that. It refused to soft-reboot. I could not restore it either as iTunes (via Micro-USB cable) on my Macbook would not recognize the ATV2. (I tried all kinds of permutations and two Micro-USB cables.)



    So I tried putting the ATV2 in DFU (Device Firmware Update) mode using iTunes in Windows 7 (Pro) on Parallels (7). This worked.



    Here is How to Put the Apple TV into DFU Mode: (I had to try variations on this to get iTunes to see the ATV2 in Devices.)



    Note: You will need a Micro-USB cable to connect your AppleTV with iTunes-for-Windows running.



    Step 1: Connect the ATV2 via Micro-USB to computer.



    Step 2: Hold menu+down for 6 seconds to reboot. (As that did not work for me I had to disconnect/reconnect power instead.)



    Step 3: Then immediately hold Menu+Play (on the ATV2 remote) to go into DFU mode. (Rapid flashing followed by less rapid flashing.)



    It (eventually after restarting iTunes, Windows etc) showed up in Devices.


    Click Restore.


    I then had to babysit the update as there are a number of messages to be OK-ed, and, at one time, iTunes for Mac began starting up.)



    Back to normal (for now.)



    This process was tenuous and required patience. There's probably a hardware issue on some devices (different vendors?). Apple should exchange these defective units for refurbished ones. After all it's their software update that broke the units.

  • georgevilla Level 1 (0 points)

    Got it guys.

    Restore via itunes with the power cable attached.

    Worked for me.

  • ehamawy Level 1 (0 points)

    I have the same problem too! The itunes and Seas0n pass Just DON'T WORK!!!!! >:( >:( >:( >:( >:(


  • TylerInTheTub Level 1 (0 points)

    I screwed around for 3 hours trying different machines, different internet connections, and putting it into DFU mode.  And all it took was to leave the power cable plugged in and it worked for me.  If you ended up here save yourself some hassle and try this first.