14 Replies Latest reply: May 21, 2013 10:24 PM by SS1017
andres23 Level 1 Level 1 (0 points)

I have an ipad 2, updated to ios5. Apple TV, updated. Wi-fi working fine.

Already went through the troubleshooting list. No problem there.

But my ipad DOES NOT SHOW THE AIRPLAY ICON anywhere.

I slide the multitasking bar to the right and it only shows the itunes icon with controls to play music, that's all.

I stand in front of my appleTV, nothing.

Turn bluetooth off, nothing.

What else can I do?

  • Firebush Level 1 Level 1 (0 points)

    I, too, am having mirroring issues with my iPad2.  I do get an airplay icon (when I slide the multi-task bar) and both of my AppleTV units show up on the list.  But, it won't mirror.  Some things play audio only (like certain games), I pressed the play button and a random song from iTunes began to play, and sometimes nothing at all. Certainly not "mirroring" as I've seen demonstrated. 

  • Pat Schaefer Level 1 Level 1 (105 points)

    settings general about needs to say 4.4(xxxx)

    this is what fixed my setup

    but I have airport express and did not have router issues.

  • Dougie007 Level 1 Level 1 (0 points)

    Me 3, everything is working bar the mirroring icon and the tv icon in my itunes on my pc isn't there also. Everything else works fine and I have all the latest updates.

  • Dougie007 Level 1 Level 1 (0 points)

    ok, I have 4.3 and when I do an update, it says "Your Apple Tv is up to date" so now what?

  • Dougie007 Level 1 Level 1 (0 points)

    dont bother with the restore methos, it download the same update, need a micro usb or an Apple shop

  • KeithJ99 Level 1 Level 1 (0 points)

    I see this problem posted in forums everywhere but I never see a solution posted.  Does anyone at Apple have an idea why these things don't work?  All you guys that posted back in October: has anyone found a solution in the last 2 months?

     

    I have a new ipad2 and new ATV but I can't get the mirrorring icon to show up.  I see the little icon within apps like Photos, Music, youtube but I can't mirror anything else.

  • Pat Schaefer Level 1 Level 1 (105 points)

    can only offer hope.

     

    I have an ipad2, a ATV on a airport extreme wireless network.

     

    mirroring work ok for me

    use it to mirror Rockford Files tv show from Hulu plus.

    need to use the tv zoom to fill the screen.

     

    other than having everything on the latest versions

    the only other hang ups I have seen involve non apple networks

    and getting the ATV recognized.

  • Graham Mc Level 1 Level 1 (0 points)

    Hi,I have had the mirroring working fine, updated and then it stopped working every time, played around for a while and if you go to the apple tv when it stops working and do a restart from settings>general>restart then retry the mirror it starts to work fine again. This also does not change settings or accounts unless you do the reset which isn't required to get mirroring back

     

    This drove me nuts but I think it might be something to do with the cache on the ate not clearing as the restart seems to work

  • lexar_6 Level 1 Level 1 (0 points)

    I had the same problem. What I did was turn off only the Wi-Fi for about 5 minutes and then turned it on again. This solved the problem for me. I hope it solves it for you as well.

  • guo1987 Level 1 Level 1 (0 points)

    After close in restarting can try this out

  • azbeachbum Level 1 Level 1 (0 points)

    I have read through this and many other posts with similar issues.  

     

    ipad 2 at 5.1.1 and ATV2 with latest firmware

     

    Airplay mirroring works between ATV2 & iphone 4S and airplay works between ATV2 & iphone 3GS/iTouch.

     

    On ipad2, I can enable airplay & airplay mirroring and it works for several seconds.  Then the AppleTV option disappears mementarily from the Airplay list and then reappears with AppleTV deselected.

     

    I have done a hard reset of ipad2 and power cycled the ATV2 & router.   I have a strong wifi signal from the router at the point of test so I don't suspect that is the issue.

     

    When I bought the ATV2 around May, Air Play worked with the iPad2.   After reading other posts, I am starting to suspect that the update of the ipad2 to 5.1.1 may have been around the time Airplay stopped working.  Other posts seem to point to problems when this was loaded too.

     

    Any ideas on other things to try are welcome.   Otherwise hope this helps contribute to knowledge base for others having similar issues.  With many similar issues reported with iPad2 and 5.1.1 with Airplay, I am hoping this gets resolved with next update. 

     

    Other comments:

    Ipad 2 is a factory refurbished unit

    16GB of memory

    WIFI only model

    Linksys Router

  • azbeachbum Level 1 Level 1 (0 points)

    I started looking at the linksys website for clues and found a solution workaround to the problem.

     

    There is a router parameter WMM (Wifi Multi Media) that is enabled by default.    When I disabled WMM, I could use airplay and airplay mirroring without issue.

     

    From the Linksys control panel, WMM is at:

     

    Applications & Gaming -> QOS -> WMM support

     

    I selected "disabled" and airplay has worked like a charm since.

     

    I have a linksys E4200 and the fix is supposed to work on other Linksys routers.   It is interesting that all of the people that have seen problems have the ipad 2 with the issues arising around the time they upgraded to 5.1.1.   Not sure what that means but I'm a happy, streaming again, guy!!!!!

  • SS1017 Level 1 Level 1 (0 points)

    I know nothing about this unless I google other folks answers.... Found the solution for me... Hope it works for you.

     

    Make sure that Wi-Fi is already enabled on iPad settings. Get into the home screen and tap over ‘Settings’ icon. Go through the options listed on the left column and tap the ‘Wi-Fi’ option. After that, you need to check whether the switch next to ‘Wi-Fi’ label shows ‘ON’ label. If not, slide the switch until it displays the ‘ON’ label. You need to also check the AirPlay-enabled devices are connected to same Wi-Fi network. If you can’t still view the AirPlay icon, get into Settings->AirPlay from Apple TV and enable ‘AirPlay’ feature.