13 Replies Latest reply: Feb 4, 2013 9:40 AM by KIK365
martin from strongsville Level 1 Level 1 (0 points)

Is anyone else having problems connecting the 4S to wireless networks?


iPhone 4, iOS 5
  • 1. Re: Why will my  4S not connect to wireless networks
    Allan Sampson Level 10 Level 10 (123,340 points)

    Not sure, but something must be wrong with your iPhone if it is unable to connect to a single wi-fi network.

     

    How many wi-fi networks have you tried to join? If more than one, you haven't been able to connect your iPhone to a single network?

     

    Did you transfer the backup for another iPhone or iPod Touch to your new iPhone?

  • 2. Re: Why will my  4S not connect to wireless networks
    martin from strongsville Level 1 Level 1 (0 points)

    Yes, I can't connect to any wireless networks.

  • 3. Re: Why will my  4S not connect to wireless networks
    martin from strongsville Level 1 Level 1 (0 points)

    I have only been able to connect to one network. My home and business network will not work. I restored the 4S from my 4.

  • 4. Re: Why will my  4S not connect to wireless networks
    Allan Sampson Level 10 Level 10 (123,340 points)

    On the iPhone, go to Settings > General > Reset and select Reset Network Settings. This will erase all saved wi-fi networks and settings from the iPhone.

     

    If no change after this, restore the iPhone with iTunes as a new iPhone or not from the backup.

     

    No change after this, the iPhone has a hardware problem and needs to be exchanged under warranty.

  • 5. Re: Why will my  4S not connect to wireless networks
    mat27777777 Level 1 Level 1 (0 points)

    Hi, my Iphone 4S was exibiting the exact same problem. Initially the phone connected to my home network with no issues, however it did not last more than a day or 2.  After searching long and hard and trying all these suggestions over and over, i came across a forum with the same problem in the Iphone 4.

    The solution for that was to change the router channel to the highest channel possible, which in Australia is channel 13.  My router was previously set on channel 11 but as soon as it was changed to channel 13, bingo, connected straight away and no issues since.

    Now even though i'm happy it is fixed I would love to hear an explanation as to why this has fixed the issue.  Nice if Apple gave some input as to what might be the reason. Maybe they have their wi-fi band set in the higher range of channels instead of giving the ability to use a broad spectrum of frequencies.

    So give it a try, if your router is on auto or a channel lower than 13, log on to your router and change the channel to 13.  Just make sure your devices that connect to the router are set on auto or you'll have to change the channel on them too.

  • 6. Re: Why will my  4S not connect to wireless networks
    yih Level 1 Level 1 (0 points)

    There are plenty of people with similar issues with the 4s including myself. Look up threads "iphone 4s wifi problem", "iphone 4s wifi slow", "cannot connect to wifi with iphone 4s".

     

    My wifi shows full bars on the phone but it cannot pick up or join networks unless I am physically next to the router.

     

    Interestingly it was working fine the first 2 days I had the phone, then it just suddenly stopped. The only way to connect now is to toggle airplane mode on and off then it connects, but only temporarily before disconnecting on its own after 30minutes, or if I walk away from the router.

     

    Several things to try, some may work - for me these worked but only as a temporary measure:

    - resettting network settings and adding your home network manually

    - reset all settings (you will lose all your settings preferences)

    - restoring ios5 from iTunes as new phone, not as backup (you will have to reinstall each app manually)

    - Assigning a static IP address to your iphone, do not use DHCP

    - Assigning an open DNS address on your iphone

    - reset your router and update your firmware

    - change the channel band on your router to only b/g - 4s appears not to work with N band

    - enable MAC filtering address on your router and allow your iphone 4s on your router (you'll find your wifi number on your iphone 4s under Settings > About)

     

    Numerous other suggestions on these fora, sadly I have not found one that sorts out the problem.

     

    Likely software or hardware problem. One option is to pop into an Apple store and try to connect to their open wifi network - if you can't (like me) then I suggest gettting a replacement phone and trying again.

     

    Good luck.

  • 7. Re: Why will my  4S not connect to wireless networks
    madhavs Level 1 Level 1 (0 points)

    i also have the same problem ...i  have an iphone 4s bt in settings there is no wifi option only ....i don knw how can connect to wifi when there is no option as such ..i even tried restoring and resetting my network settings but it doesnt work ...i also have an iphone 4 and wifi works properly on that ..the problem is only with 4s ...waiting for 5.0.2 update may be it can solve the problem ...

  • 8. Re: Why will my  4S not connect to wireless networks
    enrique91fr Level 1 Level 1 (0 points)

    me too!! I've just bought an iPhone 4S and I can't connect to my home wi-fi

  • 9. Re: Why will my  4S not connect to wireless networks
    Harris1997 Level 1 Level 1 (0 points)

    I am having the same problem, my Iphone 4s connects to the wi-fi randomly but only for a short period of time, I looked all these suggestions and went to settings and reset my network settings, and now I cant turn the wi-fi button on and off at all, the turn on/off button for the wi-fi is just faded and unable to switch.. furious!.. Help?

  • 10. Re: Why will my  4S not connect to wireless networks
    Harris1997 Level 1 Level 1 (0 points)

    Nevermind i got the button to work again but no change in the connection.. help?

  • 11. Re: Why will my  4S not connect to wireless networks
    drdeb622 Level 1 Level 1 (0 points)

    How did you get the wifi button to work again? Mine is still faded. I have done the latest update thru my computer hoping that would fix it, but no such luck. GRRRRR

  • 12. Re: Why will my  4S not connect to wireless networks
    KIK365 Level 1 Level 1 (0 points)

    You need the new update, 6.1, something like that. Iphone 5 users have taken the brunt of the bug, which doesnt even allow them to update wirelessly, for the first time in a while, I now have to plug in my iphone to get an update. I would think that Iphone 4s may be having the same problem, if you are running 6.0.1, (i think) then the problem will persist. If you want, try backing up a few updates, connect to the wirless, then update straight to 6.1. Hope this helps.

     

    <Edited By Host>

  • 13. Re: Why will my  4S not connect to wireless networks
    KIK365 Level 1 Level 1 (0 points)

    I can also tell you, it is now a hardware problem. Just try going back a couple of updates, there are 3rd party companies who have past updates, Its called a google search lol I also had problemss with my iphone 5, all i did was reset the wifi at first, that did not work, I then restarted the iphone and x out of all apps in multi bar, I then reconnected and checked my proxy manually, there was no proxy, so i found my exact wifi proxy and inserted it in and used port 80, port 80 for my wifi is described as a universal port. I then restarted the iphone and it worked. maybe you can try this for your iphone.