7 Replies Latest reply: Aug 3, 2013 2:30 PM by MarkofZorro
UgoBlu Level 1 Level 1 (0 points)

Since I upgraded to Lion 10.7.2 I have been unable to mount dmg files as each time I try I get a warning “no mountable file system”.

How do I overcome this?

Thanks.


iMac, Mac OS X (10.7), Intel i3 8GB memory
  • bettyfrommonticello Level 1 Level 1 (5 points)

    I am having the same problem in Lion 10.7.2. MacBook Pro 2.8 Ghz Intel Core i7 8 GB Ram.

     

    My install was a clean install of Lion and migrated from a clone of previous Snow Leopard HD.  Prior to installing Lion, I had removed all PPC programs. I have 3 other Mac with an upgrade in place to Lion. They are not having this issue. Need help resolving issue

  • bettyfrommonticello Level 1 Level 1 (5 points)

    Called vendor regarding their DMG which would not mount. They told me it was an Apple OS problem not a problem with their file. Told me to call Apple. Told me this error indicated internal database damage on my system. Stranglely it did not happen with all DMG files.

     

    Apple told me I needed to do a restore of Lion. One starts up the Mac holding down the (left) Command key and [R] key. It took 2 hours and now all is working properly.

     

    Here is a link that gives more details on Lion's Recovery features: http://www.apple.com/macosx/recovery/

  • dannyscott63 Level 1 Level 1 (0 points)

    hi, i am having this problem also. does the restore delete all my programmes and files?

  • bettyfrommonticello Level 1 Level 1 (5 points)

    No, it did not delete any of my programs and files. But to be safe I had everything backed up: a recent bootable clone of my drive when I was running Snow Leopard. So I knew I could migrate again if necessary. Plus I backed up my calendar, address, and bookmark files. I copied all mail stored on iCloud to my hard drive and turned off iCloud until after the restore so there was no way to overwrite my data on iCloud.

     

    I use Superduper to clone my drives. The trial version will let you do a fully functional clone of your hard drive.

  • Neil from Oz Level 2 Level 2 (170 points)

    The only time I have encountered this is with corrucy downloads, often when interupted during the download process, or else, by deing swapped to many times from disk to disk (external or flash). Usually when downloaded again they open fine. Is your Installer set as default for opening .dmgs?

     

    Cheers

  • applecore_eater Level 1 Level 1 (0 points)

    This might fix it.

     

    http://superuser.com/questions/19426/im-unable-to-mount-a-dmg-getting-a-no-mount able-filesystems-error

     

    Here is what I did to solve my problem. I see that in this post some suggested that we should convert name.dmg to writable file. I used the command from Terminal to convert but was not successful. INSTEAD alternatively, I used Disk Utility, attached the Volume (yes I got the same message again, ''no mountable system files'' however, Disk Utility nevertheless attached the image, which I was able to do before anyways. This time, I selected it and then clicked New image, and then selected image format read/write, not the compressed option. I created a new image. This time this image was writable however, it still would not mount using Simonair's solution. However, this time I was able to scan it with Disk Drill with exact file locations and folder hierarchy as I had. Recovering all from thereon was a breeze. Just remember: when you create new image of an attached volume and chose not compressed but read/write, you need to have a disk with exact amount of space that totals the total space allocated within that name.dmg file (not the amount of space the data takes). Mine was huge, and luckily I had an external disk with enough space to do that and it took about 5 hours for about 400GB of disk allocation. Good luck.

     

    The only thing I did differently was I made a new image of the VOLUME (which was grayed out) and not of the disk image.

  • MarkofZorro Level 1 Level 1 (0 points)

    Bizarre tha Apple hasn't solved this. My OSX 10.8.4 installation was able to read dmg files, even yesterday, but now gives the dreaded error you alluded to.

     

    This worked for me:

     

    1. open the file with Disk Utility

    2.   Drag the file into the right side.

    3. Choose restore. Select Read/write.

    4. Click the Restore button.

     

    The resulting inage worked.