1 Reply Latest reply: Oct 23, 2011 8:54 PM by Jon Baumgartner
Jon Baumgartner Level 2 (205 points)

The full error message is "The requested URL was not found on this server."


This started happening yesterday. I went to take a picture, and got that message. If I go into the Camera Roll, I see black thumbnails for about half of the items in the roll. The only URL I can possibly think of would be related to the Photo Stream.


Strangely, the Camera app says there are 33 items in the Camera Roll, but the Photos app says there are 15. When I look at the Camera Roll in Photos, it shows a light gray box with "JPG" in the middle for about half of the pictures, and the rest are solid black. In the Camera app, the first 9 images are the "JPG" ones, then I get 4 with actual images, and then the rest are all black.


I've tried all of these, with no change at all.


1. Quitting and restarting the app.

2. Rebooting the phone.

3. Restoring the phone from backup.


I'll probably take it in to the Apple store, but I thought I'd see if anyone had any ideas first.

iPhone 4, iOS 5, 8 GB, AT&T
  • Jon Baumgartner Level 2 (205 points)

    I took it in. The Genius had no idea what was wrong. They had never seen this particular error message before. He decided I probably had a corrupted file somewhere, and had me restore the device as new, and then have iCloud bring over my stuff.


    This worked, in that the error message went away, but I didn't get my stuff back. None of my apps came back. I reinstalled them, but didn't have any data. They were also spread out across 10 pages of apps. None of the folders were retained.


    To sum it up, it was a mess.


    So I ended up restoring via iCloud (NOT as new, but from the iCloud backup.) This brought everything back, but I still had the error message. Then I found this discussion:




    And followed alijm23's advice. Worked like a charm.