Previous 1 2 3 Next 91 Replies Latest reply: Dec 12, 2013 12:40 PM by GoddyJ
S. G. Level 1 (45 points)

The built-in Movies widget from Apple (that shows movie posters as a slide show on one side and theaters/times on the other side) has suddenly stopped working. I tried to quit and reopen from Dashboard, move the widget out of the main library's widget folder, reinstalling by double clicking on it, removing preferences, deleting system cache, history, repairing permissions, copying the widget from another computer: nothing worked.


The rounded rectangular window simply shows "No movie data available" and clicking on it does not make it flip as it normally should. Therefore, it is just sitting there on the dashboard, not showing anything other than the sentence above, and cannot be customized. I can open several of these Movies widgets simultaneously and none works nor flips.


I cannot think of anything that might have made it stop working (my internet is OK, not a firewall issue). Any suggestion would be appreciated.



MacBook Air + iMac, Mac OS X (10.6.8)
  • S. G. Level 1 (45 points)

    Another clue: I ran the "Movies.html" via Safari from the Package Content of the widget. It gives me the following errors:




    Bad request: =performancesbycitystatesearch&city=Cupertino&state=CA


    The requested URL was not found on this server:



    Any idea why?



  • X423424X Level 6 (14,215 points)

    FWIW, I also get "No movie data available" displayed too if that is any comfort.  I suspect that whatever site that is supplying the data is down or has a new address or the data layout has been changed confusing the javascript.  Things like that happen.


    Note, at the time I am posting this I am having a problem finding the problematic url in the bundle (I would think it would be burried in Movies.html but it isn't obvious -- maybe

  • EMSmac Level 1 (0 points)

    Same issue here. Installed Lion and Movie widget shows no data. Have tried every fix I could fing so far, to no avail. Any ideas would be appreciated.

  • Gabriel_305 Level 1 (0 points)

    The exact same thing is happening to my Movies widget on dashboard. I think I remember seeing it work properly even after installing Lion; therefore, I don't think it's a Lion issue. My issue started a few days ago, around October 21st, same day as your original post.

  • boseis Level 1 (10 points)

    Mine suddenly stopped working too, arround the 21st as well. I would like to make it flip at least to see if I can change my city but there is no way to make it work. I'm on Lion and have been for a few months, it has always worked.

  • Pixiegirlie Level 1 (30 points)

    Mine is no longer working, either.  Same time frame - about the 21st or so.  I am almost positive it was working since upgrading to Lion, but I am not 100% positive.  Have tried the above fixes.  Anyone know why it isn't working and what can be done to fix it?

  • wenwon Level 1 (0 points)

    same issue here.  i loved that widget. i hope it comes back. 

  • kyle.from.peoria Level 1 (0 points)

    same issuse. i didn't even use it 'til Lion and about the 21st, boom.

  • iMattPro Level 1 (0 points)

    It is broken in both lion and snow leopard. Boo!

  • pmontlary Level 1 (0 points)

    I also have the same problem.  I spoke with Apple Support a little while ago and they are not sure what the problem is.  Hopefully they will escalate the issue to find a resolution.  Like some of the other commenters, I installed Lion the same day it was released, and the movie widget worked fine until the 21st.

  • Marcin R Level 1 (0 points)

    i also have been using movie widget since day 1 on Lion and it been working it stopped working around 20th-21st "no data" thing too i really hope apple will fix it asap

  • moovyphreak Level 1 (5 points)

    Yep, same problem here. I noticed it around October 21st as well. I finally ran a Google search yesterday morning and found this article. I have a mid-2010 Mac Mini with the latest build of LIon. My sister is also a Mac user and contacted me via email complaining about this issue, but she has a refurbished Mac she bought in 2008 or 2009 that has either Leopard or Snow Leopard on it and when I called Apple Support yesterday afternoon, I informed the tech of this article and also that it wasn't isolated to my machine. He still walked me through deleting some files within Library/Preferences and rebooting, but that made no difference. He then wanted me to do a full OS restore to replace any possibly corrupt system files, but I never proceeded since this thread pretty much confirms my computer is not the culprit.

  • JML54 Level 1 (0 points)

    It's probably has nothing to do with Apple (Snow Leopard or Lion), but is sourced in the Fandango page from which the widget pulls data:  If you do a search about the issue, it's happened before, and that's likely because Fandango changed the coding for their movie data, and the widget can't find what it's looking for. See


    Either Apple will have to update the widget or Fandango will have to have a redirect on their website.

  • moovyphreak Level 1 (5 points)

    I just emailed explaining the issue and providing a link to this support thread. I also asked that they please pass my message on to the proper team if they were emailed in error. Shortly afterward, I went into my dashboard and the widget was suddenly working again, but now it doesn't recognize any zip codes. This could mean that the right development is on the case and working towards a resolution. I guess we'll see!

Previous 1 2 3 Next