Previous 1 2 3 4 Next 49 Replies Latest reply: Feb 8, 2015 6:21 AM by CareInTheCity Go to original post
  • mvb2717 Level 1 Level 1 (0 points)

    Okay.  I deleted all voice memos, closed all running apps on no longer is stuck on "waiting for changes to be applied", now it has been stuck on "waiting for items to copy" for 10 minutes!  I'm getting really tired of this, I just want to finish a **** sync on my phone, something I've never had a problem with.... I'm also waiting for all of my ringtones to come back on my phone, since half of them are missing, even though they are all there on itunes....  Any more suggestions with this new message??

  • mvb2717 Level 1 Level 1 (0 points)

    LOL, spoke too soon, tried syncing again and it's now back to "waiting for changes to be applied".....

  • pardthemonster Level 4 Level 4 (1,140 points)

    I just started getting this message on my iPhone 4S immediatelly after upgrading to 5.0.1.

  • Enabler1 Level 1 Level 1 (0 points)

    I was unable to sync using the cable. I had to disconnect and goto iTunes summary for the phone and check allow to sync with wifi. Then I went to the settings on the phone and selected wifi sync and started sync. I hope this helps.

  • David Bourne Level 2 Level 2 (345 points)

    My problem has been with my wife's iPad. All relevant software updated. I was able to sync all except photos (well apps, some music). While reading these messages I was 'waiting for changes to be applied', iTunes showed 'not responding...' at which point I've been force quitting. Following a comment about open apps on the iphone/ipad I decided to quit all the ipad apps. iTunes became 'responsive' again and indicated it was copying photos. It has stopped now but no photos on the iPad... I thought it was starting to work...

  • staubinr Level 1 Level 1 (0 points)

    I just has this same issue with my iP 4.  All I did was shutdown all open apps, ejected my iphone, plugged it backin then selected transfer purchases when I received the message "waiting for changes to be applied" I clicked apply and voilà it finally started to transfer.  BTW I did not have to delete my voice recordings.

  • elvis4prez Level 1 Level 1 (0 points)

    I got the "waiting for items to copy" error then the "waiting for changes to be applied" with the big "other" all in yellow.  I could not uncheck each subitem (contacts, music, podcasts,...) without it restarting the sync then going nowhere and hanging.  I deleted voice memos including the ones under Music, still nothing.  I retried syncing several times after restarting iPhone but still the same endless loop.  Despite all this info seemed to go back and forth like a regular sync.  I think it somehow got a corrupted file; I had a duplicate copy of a ringtone in my phone not seen on the iTunes Library that I think may have been the problem (it had the ! before it when I clicked on it).


    With my phone connected, I made another backup (right click on the connected device i.e. iPhone).  Then in Settings / General / Reset option hit Erase All Content and Settings.  I called this the "Nuclear Option" and prayed it would not take too long to recover.  I then started phone and restored from backup and most everything came up right except a few setting changes (default ringtone, no passcode lock) that didn't take too long.  Big hurrah: it went through the normal sync cycle okay without hanging on either message.


    Hope that helps.  I wasted a lot of time like a lot of the rest of you including a trip to the Apple Store Genius that was limited by the rarity of this (his words) though he did find the Voice Memo "fix" that helped a lot of people (not me!) and suggested the above pathway.  It may be related to the phone coming off midsync with a in-process writing of a file that left it corrupted (per the Genius).

  • FazalAhmad Level 1 Level 1 (0 points)

    i went to file then sync_____.

    hope it works

  • BoyterJim Level 1 Level 1 (0 points)

    I had the problem of iTunes never copying the sync to my iPod Touch. ITunes would go through step 5 then quit. After trying a lot of possible solutions, I uninstalled Mcafee Total Protection and the sync worked fine. I am going. To reinstall Mcafee but I am not sure that the sync will work afterwardsl. I am not sure that I want to try.

  • BoyterJim Level 1 Level 1 (0 points)

    I take that partially back. My photoes were not synced to the iPod as rewuested. I am still working on tat problem.  My Aps and songs were synced as requested after removal of security software,

  • chiny3r3 Level 1 Level 1 (0 points)

    Well, I did a backup as soon as I connected my ipad to the new computer, it got stuck on step 3 for hours. So, I restored from backup then right clicked on the device on iTunes and selected transfer purchases and for some reasons, it started copying.


    Hope this helps

  • Patricia W Level 3 Level 3 (685 points)

    I just restored my iPhone to iOS6 and I have progressed from my iPhone not finding my iMac to getting hung "waiting for changes to be applied" ... however, as I was composing this I noticed that the progress bar on iPhone was moving and also on iTunes and it looks like the sync was successful.

  • sbojja Level 1 Level 1 (0 points)

    I ran into same issue. I unchecked the Tones from Sync. My Tones folder was missing and i guess it is looking for tones files. After the tones is unchecked, the sync is complete.

  • mr jimmy Level 1 Level 1 (0 points)

    shutting down the apps running in the background solved the waiting for changes to be applied



  • Ronaldfrommt Level 1 Level 1 (0 points)

    I figured it out I just reset the device by going to gen.erace all settings and just reloaded the devive from my pc