4 Replies Latest reply: Jan 26, 2012 12:49 AM by UserNameX
Topher Kessler Level 6 (9,865 points)

2009 MacBook Pro 5,2 (2.66GHz Core2 Duo), recently upgraded to 8GB RAM, 320GB HDD with an OWC SSD drive replacement for the optical drive.

 

The system ran great, and was really fast given the recent 8GB upgrade and SSD as the main boot drive. I decided to set a firmware password for added security...worked no problem. The system rebooted fine, and requested the firmware password as expected when attempting to boot to alternate drives.

 

I then enabled FileVault 2 in Lion (10.7.2), and it worked as expected and seemingly encrypted the drive just fine; however, in Disk Utility the main boot drive was greyed out. Figuring it might just be a temporary issue I decided to reboot. Upon restarting, I get the boot chimes and nothing else...dead!

 

Now when the power button is pressed, the system's fans and HDD start up as expected and the boot chimes sound, but then it sits there. The screen does not turn on, and the system does not boot. The caps lock light activates, but it does not get past this point. Pressing the power button again results in an immediate shutdown, suggesing the SMC is not activating properly since it usually requires a ~5 second press for a hard shutdown.

 

I am able to reset the SMC, but doing this does not show any difference in behavior. I am not able to reset the PRAM at all--the system just sits in this dead state and then shuts off immediately when the power is pressed. I suspect the firmware password setting is preventing the PRAM from resetting, so I swap out RAM to clear the password (from 8GB to the old 4GB set), but this has no effect and the system behaves the same...dead.

 

I've tried booting without RAM and the system issues warning beep sounds as expected, and I've tried disconnecting the battery for a while and unplugging the hard drives, but no change.

 

My only conclusion is a completely corrupt/fried firmware that if only I could force to reset would work properly, so it seems beyond somehow doing this the only options are to replace the logic board (unless anyone has any other ideas).

 

Anyone else experience this kind of complete firmware/hardware failure?

  • Topher Kessler Level 6 (9,865 points)

    ...forgot to mention that when the power button is pressed and the system immediately turns off, the system makes a small, high-pitched "pip" sound right as the power cuts out.

  • UserNameX Level 1 (0 points)

    I just had a related experience. Mine also had to do with enabling FireVault under Lion

     

    I went to reinstall after wiping the internal SSD of the FireVault partition, and then could no longer boot from anywhere (not even USB external disks). Booting from the Lion instal disk and proceeding with the reinstallation ended with an error dialogue: There was a problem installing "Mac OS X" Try reinstalling.

     

    Web research pointed me to do a PRAM reset by holding the command+option(alt)+P+R keys at boot (cf. http://support.apple.com/kb/HT1533). Repeated attempts with both wired and wireless keyboards failed. The computer chimed just once and would boot into the Lion Installation (and then fail giving the message above).

     

    I found an archived discussion that mentiond disabling the Firmware Password security (cf. https://discussions.apple.com/thread/2739715). This was the trick. After disabling the Firmware Password, the PRAM reset worked and I am now able to reinstall.  Whew....

     

    So the solution for you case Topher, if you haven't already done/found it, is to disable the Firmware password and do the PRAM reset as advertised...

     

    May the Forth be with you...

  • wjosten Level 10 (94,210 points)

    What happens when you boot holding down Command-R?

  • UserNameX Level 1 (0 points)

    In my case, nothing since I had already wiped/reformated the internal SSD of the Lion test installation (and it's recovery partition). I presume you are refering to the Lion Recovery feature in http://support.apple.com/kb/HT1533:

     

    Press Command-R during startup

    Start from Lion Recovery1