6 Replies Latest reply: Sep 30, 2012 11:33 AM by TonyynoT
mostwanted06 Level 1 Level 1 (0 points)

anyone can answer my problem ??

 

 

I'm using official carrier here(Globe Telecom-PH)

 

IMG_0066.PNG

 

and the problem is, iMessage is not Activating

 

here's the story

 

after i Installed iOS5..my SIM (Globe)(official carrier) is inserted to my iPhone 3GS and everything works(iMessage)..then I changed my SIM for a while(Sun)(unofficial carrier of iPhone here in PH),then still everything works(iMessage).,then.,I put back my Globe SIM to my iPhone 3GS,iMessage displays the number of my Sun SIM,not my Globe SIM,.

 

here's my number on Globe

 

IMG_0067.PNG

 

but iMessage displays my Sun's number

IMG_0068.PNG

 

iMessage is not activating,.always "Waiting for activation"

 

i tried :

Resetting all settings

Rebooting my iPhone

syncing thru iTunes

 

but still,cannot activate,

 

anyone has a solution ?? thanks


iPhone 3GS, iOS 5
  • alifromdowners grove Level 1 Level 1 (0 points)

    Bump!

     

    Please some help us out,

  • Khurram1192 Level 1 Level 1 (0 points)

    I've got a similar problem with my iPhone 4. I also changed SIM cards, but on the same carrier. Also stuck on the waiting for activation screen and my number is displayed incorrectly.

  • pietje63 Level 1 Level 1 (0 points)

    I've got a similar problem.

     

    I changed sim cards (same phone number, different carrier). After changing sim cards iMessage (and Facetime) do not activate (the phone number, works via e-mail).

     

    I see many people around the forums have problem with activation.

    - sometimes changing wifi dns to 8.8.8.8,8.8.4.4 works

    - sometimes Facetime is restricted

    - sometimes it has something to do with automated time settings

     

    none of these worked for me.

     

    Really hoping to find a solution!

  • pietje63 Level 1 Level 1 (0 points)

    The following solution sounds plausible, but did not work for me

     

    1. To change the defult phone number in iMessage, you need to:
    2. Insert the new sim.
    3. Go to Settings > Messages>Turn off iMessage.
    4. Go to General > Reset > Reset Network Settings.
    5. Once the iPhone is open.Go to Settings > Messages>Turn ON iMessage.T
    6. This will recognize the new sim and have it verified.I hope this helps.
  • Bono11 Level 1 Level 1 (0 points)

    Hey...  after having the SAME problem activating my iMessage (i had it working and having an factory unlocked iPhone 4S, i swapped SIM's once and then i couldn't get my number to activate again) a wonderful MAC GENIUS from my local store told me a solution that worked for another when all else fails (the DNS, auto-time, resetting, etc).

     

    Call your carrier to see if they are blocking premium texts or third party texts.. some carriers have an auto-block to protect you from random charges or sometimes (like me) we put the block on ourselves.

     

    I had my carrier remove this block and PRESTO... after they sent a network reset to my phone and i reset my network settings.. i turned on iMessage and FaceTime and they finally activated again!!! 

     

    I was able to put the premium block back on after and it still works just fine!!

     

    Hope that works for those that couldn't get it to activate!

  • TonyynoT Level 1 Level 1 (0 points)

    go to settings, message, and turn off iMessage.

    text somebody.

    turn iMessage back on,

    then text them again.

    then settings, message, and the correct number should be showing.