8 Replies Latest reply: Feb 12, 2012 3:33 AM by leon mols
bazfromlondonuk Level 1 Level 1 (0 points)

My ATV is on the same WIFI network as my laptop, has my iTunes account signed in but cannot connect to my library since the last ATV upgrade.

Homeshare is on in iTunes. can anyone help?


Apple TV, iOS 5
  • Rich in St Catharines Level 1 Level 1 (5 points)

    Same issue with me.  I believe it's a firewall issue.  I'm using Windows 7 (unfortunately) and third party firewall software.  The windows firewall is off.  I found that when i turned off the 3rd party firewall that i was able to connect. Windows computers are not at all intuititve.  It's not enough to change your settings in Itunes and the Apple Tv and have it work.  you have to tell the third party software that it's okay for an outside application/server to get access to your Itunes library.  So open up the third party software and browse through the applications section and then choose your Itunes program and then allow traffic in/out.  I think it's resolved at that point...but with windows, you never know.

     

    Message was edited by: Rich in St Catharines

  • bazfromlondonuk Level 1 Level 1 (0 points)

    Hi Rich

     

    i have disabled all laptop firewall settings and still not connectivity!  It usd to work ok before I upgraded the ATV..any other ideas? Thanks

  • Rich in St Catharines Level 1 Level 1 (5 points)

    after you've disabled the firewall settings, put the apple tv to sleep, restart itunes on the laptop and then turn the apple tv on again.

  • leon mols Level 1 Level 1 (0 points)

    Another problem connecting to one of my computers. I have 2 Apple TV's (2nd gen) and 3 computers to connect to (Mac mini server (Lion), Macbook Pro (Lion), old Mac mini (Snow Leopard)). There is a problem with connecting to the Mac Mini (Snow Leopard) from ONE of the Apple TV's ... It just times out after 2 mintues. The same ATV connects to all other libraries but not to this one. All computers connect fine to the library (home sharing) this one Apple TV does not connect to, the other Apple TV connects fine to that library.

     

    All ATV's and computers have the lastest software (Apple TV 4.4.4., iTunes 10.5.3), no firewall(s), MacBook pro and new Mac mini Lion 10.7.3, the old Mac mini Snow Leopard 10.6.8

     

     

    So all computers connect to each others library just fine, but one of the 2 ATV's does not connect to 1 iTunes library .... ??????

  • thadd47 Level 1 Level 1 (0 points)

    In Itunes go to:

     

    Edit - Preferences - Sharing

     

    make sure you have selected to share information (even with homeshare on)

     

    thadd

  • leon mols Level 1 Level 1 (0 points)

    Yep, that was already switched on .... And also tried it Off (because my other libraries have the setting switched Off) ....

     

    Leon

  • Mistylake Level 1 Level 1 (0 points)

    After fiddling with my firewall settings, windows setup etc. found my fix in leavin the ATV on (don't go to sleep) and changing my billion router channel to 11.  Was a bit of trial and error to see which channel wa stable but this was the solution for me.  I had been reluctant to change channels as I had had previous problems with my iPad and found channel 8 worked for that, but since changing it, my iPad and iPhone have been stable too.  Wish I'd tried it sooner.  I haven't been game to switch the ATV2 to sleep cos and see if it was just the channel adjustment - took me to long to get it stable don't want to fiddle (and waste any more time) now.  Good luck.

  • leon mols Level 1 Level 1 (0 points)

    For some reason I don't understand, it suddenly works now .... But I changed so many settings (and changed them back after it didn't seem to help or change anything) I truly don't understand what happened and why it is working now ... But it is