10 Replies Latest reply: Jul 26, 2013 6:10 AM by JMZ-NYC
calamityjane34 Level 1 (0 points)

All of my other apple devices connect to my home wifi except my new 4S


iOS 5
  • napereirajr Level 1 (15 points)

    By any chance are you using a wireless N 5GHZ network?  iPhone can only connect to wireless B, G and N (2.4 Ghz)

  • comatose1978 Level 1 (0 points)

    Try restarting your router.

  • calamityjane34 Level 1 (0 points)

    ok, thanks, all of my other apple devices are connecting no problem, just the new 4S won't?

  • calamityjane34 Level 1 (0 points)

    not sure, but all of my other apple devices are connecting no problem (including my 3GS iphone)?

  • jerry mendelsberg Level 1 (0 points)

    You might be physically too clo.se to your router. I had a similar problem, walked to another room, and tha problem disappeared.

  • sandun Level 1 (0 points)

    I had similar issues where one 4S was not able to join the network while other devices were able to. Have you tried any of the following:

     

    - Check if you have MAC filtering enabled - if so disable it or add your iPhone MAC address to 'allowed' list in your router.

    - Rebooting the router.

    - Change the router channel from "auto" to 11.

    - On the iPhone: "Forget this network" and attempt to rejoin.

    - Reset the iPhone Network configuration (General -> reset -> reset network).

    - Rebooted the iPhone 4S. (Also hard reset).

    - Connect to an unprotected network to see if your phone connects to a different router.

    - Factory restore iOS5. (don't forget to create a backup first).

     

    None of above worked for me, but may work for you.  See my related thread: https://discussions.apple.com/message/16502121.

  • BigMikeDawg Level 1 (0 points)

    "Forget this network" worked for me.  Thanks.

  • Olly 22 Level 1 (0 points)

    I also had this problem. For some reason the router wifi password has become "case sensitive" where as im sure it hadn't been before (been using iphone 3gs) the problem is that it just says "unable to join network".If it specified it was due to incorrect password that might have given me a clue.

     

    O

  • Sk8Dreams Level 3 (855 points)

    WEP passwords are not case sensitive, but WPA passwords are. 

     

     

    I tried to get a clue from the error message also:

    I had a bizarre problem connecting my iPad to my router.  Initially, it connected fine, then I switched it to a range extender since I got a better signal from it where I use the iPad most of the time.  I discovered much later that I could no longer join the network through the router.  I did everything one can do, and finally, hoping to get a different error message from "unable to join network", I tried a garbage password.  The next time I tried the correct password, it joined and has had no problems switching back and forth since.  Flakey!

  • JMZ-NYC Level 1 (0 points)

    I had this same problem.

     

    This is how I solved the problem (very easily).

     

    Log online to view the router settings (if you use verizon Fios the webaddress should your IP address)

    On the main page go to wireless settings

    Look for the WEP KEY (also WEP 64 -bit) and type that as your password on the iphone.

     

    This is how I finally connected my iphone to my home Wifi.  I hope it works for everyone.