Previous 1 43 44 45 46 47 Next 724 Replies Latest reply: Jul 25, 2015 7:14 PM by Hannah1Rose Go to original post Branched to a new discussion.
  • sbailey4 Level 1 Level 1 (25 points)

    So what exactly did they replace? Main Board? Antenna? Sim?

  • moztug Level 1 Level 1 (0 points)

    In my case, it was not the sim or antenna for sure. The tech guy has changed the antenna with a new one in front of me but it did not help. I also replaced my sim card, even tried 128 k sim card it did not help either.


    Just for the reminder, my problem was; The phone was losing signal and was switching to no service when 3G is off. When 3G is on I was getting signal only if there is a strong signal (maybe a basestation nearby) and if I dont move. But when I was mobile (on my car) , I was facing the searching, no service, signal, searching again, no service again and then the signal.. Rebooting, restoring, updating.. 2 months Nightmare..


    The tech guy told me that it was either antenna or main board problem. I wish it was the antenna, because it would cost much less but unfortunately it was the main board. He repaired the main board and it took him 5 days to give the phone back to me. Usually they do the small repairs such as antenna change in one day here. Whatever he has done, it worked, now its working perfectly fine. It has been two weeks so far and no problem at all. Not even one drop.


    I hope it helps..

  • superunknown98 Level 1 Level 1 (0 points)

    I tried to switch off the 3G,and I found the failure notification is reduce significantly.


    I tried to turn off the data, and let's see what is happen within this week.


    somebody have to find what is wrong with this beautiful device. If apple don't want to do this, let us do.

  • sbailey4 Level 1 Level 1 (25 points)

    Interesting I have not had the issue on my device now just over a year old. Wife got the 4s this past Sept and a week or so ago when we were traveling in a low signal area she started randomly getting the no service issue and invalid SIM error when toggling Airplane mode to recover from the issue. Airplane mode toggle would recover it but it started doing it at home as well. Finally I took out the SIM and cleaned it put back in and no issues since. Been a little over a week now. We are on Verizon (CDMA) and typically are in a 5 bar signal area.  Strange hers has been fine all this time until we were struggling for signal (mine was as well but never went to no service condition) then kept doing it.


    Anyway may want to give that a try as it seems to have corrected hers.

  • Thomson Level 1 Level 1 (0 points)

    Got my iPhone 4S last week working fine then this week keep losing the signal the phone works fine over wi-fi but when I am out I lose signal all the time, think I am going to hand this phone back unless apple comes up with a FIX! 

  • Joel Bruner1 Level 1 Level 1 (40 points)

    Since my issue started after a phone drop but persisted AFTER I got a replacement phone, the SIM seemed like the only constant in the equation so in addition to "reseating" it, I also took a pencil eraser and rubbed off the haze/oxidation layer and then wiped with alcohol wipe, let dry and reseated.


    Also, another possibility for those who have this happen while mobile and going between cel towers and carriers, is to update your "Preferred Roaming List" (PRL). You can Dial *228 (except AT&T) and apparently restarting a phone does this as well.


    The other is to Reset Network Settings in Settings (which for AT&T downloads a new PRL), I believe I tried that to no avail, however every issue is unique, so you should try all steps to resolve!


    There's a some more troubleshooting tips here:

    Apple - Support - iPhone - Calls Troubleshooting Assistant

  • burcexer Level 1 Level 1 (0 points)

    I bought my 4s a week ago from the States. My carrier (service) is Turkcell - Turkey. I have the same problem as many of others."no service, searching, turkcell and in a short while no service again". I talked with a technical guy from Turkcell. He told me that that device was an antenna problem. And he had faced with that kind of problem a couple of times before the devices which bought from abroad. Nonsense.


    I think I have a similar problem with you. Could you please write on my e-mail directly your solutions and advices? Waiting your response. Thanks in advance.


    <Email Edited by Host>

  • khandelwal9nakul Level 1 Level 1 (0 points)

    I tried that, but it ain't working in my case..please help,,,amd in big trouble..!

  • FNannoyed Level 1 Level 1 (0 points)

    I had a similar problem recently. I contacted my service provider and they suggested that I turn my phone onto "Airplane mode" (in general settings) for about 30 seconds then turn "Airplane mode" off. It resets your IP, DNS and everything else related to connections.
    Hope this helps.

  • khandelwal9nakul Level 1 Level 1 (0 points)

    I tried that also..but this also didnt worked for me.!

  • Elalti Level 1 Level 1 (0 points)

    Hello every one!


    This is shame for Apple. I've tested every thing suggested to solve thei "No service" issue on my iPhone 4 but nothing works. I contacted the network provider and got a new simcard the same thing happened when I restarted the iPhone. I got fed up of trying to solve this and ordered a new iPhone 4S hopping that Apple has solved the problem. After a month the same thing happened to me now. I am so tired of this company now. I will tell this to every one I kow. This is sick. I've spent a lots of time and money to this. They just say it is the network company problem when it is their own. I'll never buy any of their products any more. Is there any one who could buy my **** iPhones and iPads? Instead of throwing it away for nothing... I'm so angry on their products now.



  • pgtt Level 1 Level 1 (0 points)

    I traveled from UK to India with an unlocked iphone 4 on ios 6.0.1. Had this no service /Invalid sim issue.

    No combinations of changing settings / tweaks / reboots worked. I had to erase the phone completely and restore for it to pick up the network.


    If any one sees this issue and doesn't seem to get anywhere in a few hours and a trip to your friendly neighbourhood  network carrier outlet or a call to customer services etc  , don't waste time - just start from scratch.

  • Paul Hesketh Level 1 Level 1 (0 points)

    Many MANY thanks, this worked for me too. your a legend!!

  • salamounNZ Level 1 Level 1 (0 points)



    it is their problem and should listen to consumers rather than just hide their head in the sand.


    We need a solution guys, otherwise it is a snowball would run out of hand.

  • lupe911 Level 1 Level 1 (0 points)

    I had the same issue on my 4S it turned out that my case was to tight causing service drop off. This is the site i found it also had more solutions who would of guessed i silly thing like that!

Previous 1 43 44 45 46 47 Next