Skip navigation

iPhone 4S "no service" problem

742212 Views 723 Replies Latest reply: Apr 5, 2014 4:59 PM by liam1989 RSS Branched to a new discussion.
  • Kerm1t Calculating status...
    Currently Being Moderated
    Mar 1, 2013 3:33 AM (in response to sbailey4)

    I just had this, this morning

    Only just realised @ 11:25 that phone's not rung all morning, and it was saying 'no service'

    We're in a good reception area at work, so no idea why it's not connecting

    Tried a text, didn't go.

    Rang the phone, straight to voicemail

    Flight mode on/off made no difference

    Turned phone off and back on and vwallaaahh, full signal strength

     

    We have a lousy signal at home, so I wonderif it brought the 'no service' with it from home?

  • Occhiodiprua Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 2, 2013 10:17 AM (in response to AriBz)

    Hi, may I point out that trhed interested in the followinghttps://discussions.apple.com/thread/4616503?start=0&tstart=0

  • BillH1184 Calculating status...
    Currently Being Moderated
    Mar 17, 2013 9:35 AM (in response to abds2000)

    Here's my situation with screen shots showing how I can't connect to any network without rebooting, once the No Service bug hits. I am scheduled to speak with an O2 Guru locally next Saturday to see what they can make of it.

     

    Details: http://hodgtography.wordpress.com/2013/03/15/no-service/

     

    Actions taken which have no effect:

    1. Switch to Aeroplane mode
    2. Reload the firmware
    3. Reset the network settings
    4. Take out the SIM and put it back in
  • lianefromauckland Calculating status...
    Currently Being Moderated
    Mar 21, 2013 3:29 AM (in response to RunsWithSissors)

    I spent two+ hours on the phone with Apple Support over my 'no service' issue with my iphone 5 after returning to NZ yesterday from a trip to the States.  Had no previous issues travelling to Aussie and Canada.

     

    Apple Support finally admitted defeat and sent me a new phone from Sydney which arrived today.  Backed up from previous  and set it up and still same issue!  Was pulling my hair out and decided to do one last google search and found your post.

     

    Sorted in 1 minute flat!

     

    Am passing this on to Apple Support as they obviously are not aware of this easy fix!

     

    Thank you thank you thank you 

  • BillH1184 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 21, 2013 3:40 AM (in response to lianefromauckland)

    Liane: What easy fix do you mean, too many posts for me to work out which you mean.

  • lianefromauckland Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2013 3:47 AM (in response to BillH1184)

    Hey Bill

    CUt and pasted as below.  Once I had done this I toggled flight mode on and then off and BOOM!   back in business.  My relief knows no bounds!

     

      Oct 7, 2012 5:42 PM (in response to abds2000)

     

    This is what I did, after the phone came back from overseas.

     

     

    The Sim Card needed to be set to the Phone Provider.

     

    Go into Settings > Phone > Sim Applications > Roaming Menu > Manual

     

    Now choose your ISP provider (in my case it was TNZ, Telecom New Zealand)

     

    Now back out of that and the phone will start searching for the provider.

     

    I hope this helps.

  • BillH1184 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 21, 2013 3:57 AM (in response to lianefromauckland)

    I can get to Settings -> Phone

     

    The choices I have are:

    • My Number
    • Calls
      • Reply with message
      • Call forwarding
      • Call waiting
      • Show my caller Id
    • Change voicemail password
    • Dial assist (on/off)
    • SIM PIN
    • O2 Home (my phone company)

     

    So I'm lost, can't find "SIM Applications". I've been googling but not found any explanation, perhaps my phone is locked to O2?

  • lianefromauckland Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2013 4:08 AM (in response to BillH1184)

    So sorry Bill ... directions worked brilliantly on my unlocked '5'

     

    My menu looks like this

     

    • My Number
    • Calls
      • Reply with message
      • Call forwarding
      • Call waiting
      • Show my caller Id

     

    • SIM PIN
    • SIM Applications
    • Telecom NZ Services (my provider)

     

    From what I can gather trawling the net over the past 24 hours, 'SIM Applications' is only available on the menu of unlocked phones.  Doh.  I did find lots of talk about how O2 are keeping iphone 5 locked until customers are several months into contract?  But I am just repeating what I read ... no personal experience.

     

  • BillH1184 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 24, 2013 1:42 PM (in response to lianefromauckland)

    SOLVED: A replacement SIM card has made this problem go away.

     

    http://hodgtography.wordpress.com/2013/03/15/no-service/

  • Akiradjiev Calculating status...
    Currently Being Moderated
    Mar 26, 2013 4:19 AM (in response to abds2000)

    I have iphone 4s 6.1.2, and iphone 4 6.1.3 with this problem.
    I fixed my problem by deleting the APP "find friends" and everything works perfectly on both,

    try to do and say if it will work. I hope I've helped.

  • Pere1609 Calculating status...
    Currently Being Moderated
    Apr 3, 2013 3:58 AM (in response to Fedupalready)

    Hello, In spain with Movistar all the same problems. the only good solution so far is the one from Fedupalready.

    What is incredible is the solutions that works monday it does not work tuesday.

  • Tmoore1 Calculating status...
    Currently Being Moderated
    Apr 9, 2013 6:07 PM (in response to Akiradjiev)

    I just got it to reproduce the issue exactly.. Go into Settings, General, then Date & Time and turn off "Set Automatically".  Apparently when I had this turned on the signal drops to 1 bar, the location icon shows up, then it goes to "Searching".  Once I turned this off all the bars came back on.  I can flip it back on, wait about 10 secs, and watch the bars drop to nothing.

     

    This definately started with IOS6 on my iPhone 4s.. and I'm pretty sure that's a software bug.

     

    No other method worked and I tried them all including a sim card replacement.  Hopefully Apple will investigate this.

  • ixash Calculating status...
    Currently Being Moderated
    Apr 11, 2013 10:41 PM (in response to Tmoore1)

    Here's what worked for me on multiple iPhones:

     

    Each iPhone was originally locked to AT&T and subsequently network unlocked. However, after the network unlock, the iPhone was never restored.

     

    If I tried inserting a non-AT&T SIM, I would get "No Service". Tried with multiple SIMs from multiple providers (Airtel, Vodafone) on all phones.

     

    On these same phones, if I used my AT&T SIM while roaming in India, it would immediately connect to a roaming network (TATA, Vodafone, etc.).

     

    After trying all options that didn't require restoring the phone (wanted to preserve OS version), I went ahead and restored to the latest iOS version (6.1.3) using iTunes.

     

    When the restore is complete, the phone will display a message to the effect "Please insert active SIM to activate iPhone". With the SIM card in the phone (it doesn't matter if you keep the SIM in the phone during restore or if you insert it after restore is complete), follow on-screen instructions. Once the phone is activated (as long as the phone has been unlocked it should successfully activate), it should display "searching..." and then connect to the appropriate network. This did not happen prior to the OS restore.

  • RudeLlama Calculating status...
    Currently Being Moderated
    Apr 15, 2013 9:12 AM (in response to abds2000)

    Hi,

     

    Seems this issue is not uncommon.

     

    I had the same problem with my i4s. EE Network (Orange, T Mobile).

     

    It kept showing "No Service" or "searching.....".

     

    I tried, as the forum threads advised: Reset Network setting, a full Restore, Airplane mode toggled on & off,

    etc, etc, etc, etc...... Still no joy.

     

    The sim card worked in other phones, so I was told the Phone was duff & to take an 80 mile round trip

    to see my nearest Apple "Genius".

     

    I took it to a friendly Non-Apple repair shop, and was told that it was actually the Sim Card that was faulty.

    It appears that static electricity from overhead rail cables had got to it when I parked at my local Train Station.

     

    The upshot is, I went back to Orange & had a Sim Swap done. 2 hours later & back up & running!

    I would advise, before you part with a penny, try this option if the Restores etc do not work.

     

    Incidentally, this has made me think about the contracts we are signing in our chase for the next Apple product... Why sign up to a 2 year contract when the phone is only guaranteed for one? You pay for that phone in your monthly phone bill, so it should be covered during that period WITHOUT having to pay extra insurance.

    Vote with your wallets people, and things will change.

     

    Peace!

  • Tmoore1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 10:28 AM (in response to RudeLlama)

    Unfortunately I swapped out my SIM too and it worked for a little while, then eventually back to the same thing.  It comes and goes randomly, and stays on searching for hours on end randomly too.  It's almost like there's a heat issue or something.,.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.