4 Replies Latest reply: Jan 14, 2012 11:55 PM by Geraldo Palomo
Vinnipeg Level 1 (0 points)

The danish 8-digit phone numbers are showing in US-formats with parenthesis on my iPad: (###) ###-##. But I want to see them: ## ## ## ##. Does anyone know how to set it? All my contacts are made on my MacBook Pro and sync'ed via MobileMe and they show perfect on my iPhone.


iPad 2, iOS 5
  • King_Penguin Level 10 (120,171 points)

    The format of phone numbers, dates, and times are controlled via Settings > General > International > Region Format

  • Vinnipeg Level 1 (0 points)

    Thanks King_Penguin, the settings are set to Danish, but it still shows in American format

  • Geraldo Palomo Level 1 (5 points)

    I have this same problem, the contacts are now in icloud, using my iphone 4s, they appear fine here ####-####, which is the international format here in El Salvador. But on my iPad, the same contacts appear in this format (###) ###-##. They both share the same Settings: General, International, Language-English, Keyboards-3, Region Format-El Salvador, Calendar-Gregorian.

    On my iMac it also displays correctly.

     

    The Key is the Region Format, but why on the iPhone does it appear correctly and on the iPhone its not the same.

  • Geraldo Palomo Level 1 (5 points)

    I solved it.

    Remove the simm card that came with your US purchased ipad, mine was AT&T and this is what fooled it.

    I inserted the simm card that came with my iPhone, Carriers appeared and I selected my local carrier, and then the format I wanted for my local contacts appeared ####-####, my US contacts were also in the correct US format. Just like in my iPhone and Mac.

    I then removed the card from the iPad and did not insert the old US based simm card, and so far it maintains the local Region Format I have chosen.