10 Replies Latest reply: Jul 12, 2015 11:55 AM by xrakv
eikebw Level 1 Level 1 (0 points)

Hey

I am quite desperate and hope someone can help me here.

My Macbook acts as if the ctrl key is constantly pressed.

This happened a day after I spilled a tiny bit of tea on the keyboard (first everything seemed to be fine).

Now the keyboard is strange: Letters dont work but some of the other keys do.

External Keyboard works perfectly fine.

When using the Keyboard viewer I can see that when I press of the Letter Keys the key turns grey. So basically they should work.

P103043411.jpg

By pressing the shift key on the internal keyboard or the enter key on the external following happens:

P10304313.jpg

sorry I cant use screenshots because we wont be able to see it right then.

 

I already took the ctrl key out and checked it. Everything looks clean and right. It really just was a tiny bit of non sweeted tea.

 

I have googled this and spend already hours and reading and trying to find a solution to this problem but failed so far.

Really hope someone can help me.

It is a late 2009 macbook with OSX 10.7.2

Thank you in advance


MacBook, Mac OS X (10.7.2)
  • manzhikov Level 1 Level 1 (0 points)

    I have same problem

  • cvoelker Level 1 Level 1 (0 points)

    Hello,

     

    my father has the same problem. Same machine. He pretends that nothing was spilled over. He has a tiny place where uses his laptop that has not even space to place a cup of beverage beside the computer.

     

    A little more details: I tried to log out and log in as the admin user but cant give the password. Some keys provoke a chime while typing, others dont.

     

    While rebooting, Command-Alternate-P-R doesnt seem to work. Pressing Alternate to get into the boot volume chooser does not work. Pressing Command-S to boot into single user mode works, however I cant type any command while in the shell, now fsck, no reboot, nothing. Pressing "R" makes the prompt change to something like "search backwards `´" for a very short moment. I cant reproduce this behaviour in Terminal on my own machine pressing Control-R, so I am not sure what it is.

     

    The way I came to the conclusion that the machine behaves like the Control key being pressed all time was within Apple Mail typing Command-N to open a new Mail opened a new notice instead. I was not able to close the Window Typing Command-W. I opened the trash can using the mouse and tried to resize the window because there was so much in the trash can but I got a context menu instead when grabbing the title bar. Scrolling with two fingers zoomed the whole Screen instead.

     

    My father allow my small nephew to install games while in vacation. He even gave him the admin password although I told him not to do so. So my first idea was that he had changed something with the input methods. But then, the strange behaviour would be gone during the boot sequence at least I guess. And I should be able to log in as another user (I always create a separate user for everyday use that has no admin rights).

     

    I have no firewire cable at hand to reinstall in target mode and -gosh- the MacBook 2009 does not even support this essential function because it has not firewire port, it is a crippled machine. I dont have any idea who to analyze the problem further.

     

    Please throw some wisdom from heaven.

     

    Bye, Christian

  • eikebw Level 1 Level 1 (0 points)

    Hey there,

     

    only thing that evetually helped was to let the Apple guys give me a new hardcase.
    That was 113€ or 92 pounds I think.

    Annoying but at least it helped.
    Cheers

    Eike

  • cvoelker Level 1 Level 1 (0 points)

    Thanks for your advice,

     

    I am not yet at this point. Though I know it is a last resort and I wonder about the relatively affordable price.

     

    Id like to add even more details. I still dont have an external keyboard to tinker with, but my father managed to find the two DVDs acommpanying the unit. I tried to boot from the install disc using the C key as well as the Apple Hardware Test using the D key. Both did not work. I also found the advice on the net to hit Alternate-C instead or Alternate-D respectively. However this tip was ment for somebody whose computer was stuck with the command key always on, not the control key as is the case here. No matter what, this did not work either.

     

    I also tried a SMC reset to no avail. The combination Shift-Control-Power was not understood and the MacBook booted immediately when releasing the keys. Normally it should go off and need another pressing the Power Button to start again. Because the Control key is stuck I also tried with only Shift and Power which did not have any effect as well. Until I get a keyboard from the neighbourhood, I am off duty I guess.

     

    Thanks for further suggestions what to try. I will contact my preferred AASP tomorrow but then I am not at my fathers place any longer and it will become a tedious task to check other things by calling my father and explaining him what to do exactly.

     

    Bye, Christian

  • cvoelker Level 1 Level 1 (0 points)

    One more thing: OS ist 10.6.8

  • dale Sherbourne Level 1 Level 1 (0 points)

    Try making and efi restore cd on another computer and resetting your efi firmware.

    I can't find one for my macbook4,1 if anyone can tell me which  one to use that would be peachy keen.

  • cvoelker Level 1 Level 1 (0 points)

    Thanks for your suggestion. I hope it will help somebody else. However my father has had his topcase replace weeks ago at an AASP. This AASP should have checked the EFI Software before replacement Id expect. However, the report did not contain any hint to this direction.

     

    While reading the thread again, I am astonished by the load of typos and plain wrong words in my own message. That is not they way I write, I am sorry for this, but I dont feel guilty. There has probably been a spelling corrector in place. I hate this kind of software. They always make things worse and I have deactived it everywhere I know of. Apple should remove this disfunctional piece of software as long as they cant provide anything that is at least on par with human beings.

  • Morkoshenen Level 1 Level 1 (0 points)

    I have the same problem, did any of u found a solution for his problem since the post is quite old? Thanks a lot

  • Morkoshenen Level 1 Level 1 (0 points)

    Got the same problem, did any of u guys get a solution for this??

  • xrakv Level 1 Level 1 (0 points)

    I found a work-around that I've transformed into a wikiHow article: http://www.wikihow.com/index.php?title=Fix-Macbook-Sticky-Control-Key