Previous 1 2 3 4 Next 47 Replies Latest reply: Nov 17, 2015 6:19 AM by babyru1798 Go to original post
  • isaleej Level 1 Level 1

    Thanks so much  - it worked for me

  • R_Bee Level 1 Level 1

    Perfection... Thank you!!  Who knew how annoying selecting your network everytime you opened up your macbook could be?

     

     

     

    Re: Wi-fi not automatically connecting to home network upon waking from sleep?

     

    Apr 16, 2012 6:30 PM (in response to surf1der)

     

    It may be a problem with the connection information stored in your network profile.

    1. Go to System Preferences > Network.
    2. Click the Wi-Fi connection.
    3. Click the Advanced... button on the bottom right.
    4. Click the Wi-Fi tab.
    5. Under Preferred Networks, select your wireless network.
    6. Click the - (delete) button.
    7. Turn off your Wi-Fi connection.
    8. Turn it back on.
    9. Select and login to your wireless network. This will re-save your connection under Preferred Networks.
    10. Close your laptop and reopen it to test whether it worked.
  • Ramesh Srinivas Level 1 Level 1

    joshua's solution worked for me. Dont need to install any patch. Just follow the steps listed in the post. Hit "Apply" before you exit the system preferences. And then reboot. Works fine after that.

  • Johnnyv93 Level 1 Level 1

    This did the trick-Thanks! I think the problem lay in the fact that I changed routers and passwords, but kept the same network name.

  • Madd4MTL Level 1 Level 1

    I also found that once you delete the network from your preferred list, you can re-add it manually with the + button without having to turn your wifi off and then back on.

     

    The problem for me was that my home network was saved to my preferred list before I made it secure, so it was not able to connect automatically because it had the wrong security settings saved. Once I added it back on manually, which required me selecting the correct security settings, everything was perfect again.

     

    Best of luck to everyone!

  • mlsmsw Level 1 Level 1

    Thank you, Joshua. This is such a simple and, in retrospect, obvious solution to an annoying problem. No one at Apple or my ISP could advise me properly. Your fix worked like a charm.

  • prognone Level 1 Level 1

    After installing Mavericks in my MBPro, and in my MBAir, I got wifi reconection problem in both of them. Just reseting the PRAM was the solution for me too!

     

    Thanks!

  • BDeSutter Level 1 Level 1

    Resetting the SMC worked for me also, silly how easy that was after 2/3 months of the wireless not reconnecting. I had to turn it off then on to connect most times.

     

    Works great now.

     

    FYI - I held down the shift-control-option and power for 3/4 seconds. Then restart, there is no obvious indication you did anything so do not expect feedback. It just works that easy.

  • 豚に真珠 Level 1 Level 1

    None of that worked for me, but what did work was deleting the network and then also deleting the stored network password in the Keychain (using the Keychain Application.. delete them in both the iCloud and System areas), before re-establishing the network again (which will then put the same passwords back in the Keychain).  Don't know why this should make such a difference, but it seems deleting a network does not delete all traces of it in the Keychain, or at least, not in the right way.

  • mauricefromsainte-louise Level 1 Level 1

    Work for me :-)

  • HappyCactus Level 1 Level 1

    I may have found the explanation for this issue, at least on my box.

    I upgraded from an up-to-date 10.8 to Mavericks, the auto connection never worked for me (MBP Retina 15" Early 2013).

    Tried reset the PRAM and SMC, didn't work.

     

    But I noticed that the preferred networks list (under Network Preferences, Advanced, Wifi tab) was empty. it shouldn't be, I had a lot of network configured.

    Deleting the wifi authentication entry in the keychain and recreating the wifi connection made the job. I guess that clicking on "+", and then in "Select network" would have done it as well.

    Hope this helps

  • shop-wizard Level 1 Level 1

    I tried everything and nothing worked until...

     

    I turned off bluetooth.

     

    Works perfect now.

  • EM255 Level 1 Level 1

    This worked for me as well.  Reset both the PRAM and SMC.  Thanks!!

  • kaizo.nakao Level 1 Level 1

    Great!

    It's seems to work well for my case.

     

    Mac OSX 10.9.3

    Mac Book Air "13 2012mid

  • BDeSutter Level 1 Level 1

    I found the reset worked, for a few days and then I had to do this again.

     

    Turning off bluetooth is 100% on my machine. No issues, unless I use my mouse and forget to turn off bluetooth and then wonder what happened again.

     

    Seems like Apple has an easy fix there! Get to it APPLE!