Previous 1 2 3 4 Next 47 Replies Latest reply: Nov 17, 2015 6:19 AM by babyru1798
surf1der Level 1 (0 points)

Since upgrading to Lion 10.7.2, my 2007 MBP will not automatically connect to my home network upon waking from sleep.  I must manually select my wifi network to establish a connection. In my network settings I have the box that says "Ask to join new networks" checkmarked (it also says "Known networks will be joined automatically.").  My home network is listed at the top of my preferred network list. Is there a fix for this? 


Macbook pro, Mac OS X (10.7.2), 2007 17" Macbook Pro
  • larix Level 1 (0 points)

    I am having the exact same problem on the late 2008 MBP

  • John Scott1 Level 2 (310 points)

    My late 2010 Macbook Air does reconnect but it takes about 30 seconds to do so. Not sure what is going on other then I think maybe the LAN address is being lost and the computer must re established.

  • salome.sierra Level 1 (0 points)

    I'm having the same problem!

  • surf1der Level 1 (0 points)

    bump.  Still have not heard whether this is a known bug or not or if there is a fix.  Anyone have any advice?

  • surf1der Level 1 (0 points)

    I think the latest Java update from Apple has fixed this issue.  For others with the same problem, try doing a software update of osx and see if it fixes your problem.

  • nceruti Level 1 (0 points)

    Hi! I have the latest OS X (10.7.2) and it is also behaving like that. Moreover, it does not even connect when I restart it. I have to do it manually each time

  • nceruti Level 1 (0 points)

    Found a solution!!!!

     

    Solution offered by AVRAHQEDIVRA on another post solved the problem:

     

    Macbook Pro Unibody. After upgrading to Lion, my problem concerning WIFI was that I had no more autoconnection to my home netwoork.

     

    To fix the problem was simply to delete the plist file corresponding to aiport i.e

     

    /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

     

    1/ disable airport

    2/ delete the plist file

    3/ enable airport and select your favorite network again

     

    Bear in mind that this will erase ALL connections in your list. Be sure you remember the passwords to reconnect for the first time afterwards...

  • Mizan-_97 Level 1 (0 points)

    earn gift card codes

  • surf1der Level 1 (0 points)

    The new lion release resolves this issue (10.7.3).  At least for me.  Here are the patch release notes.  Note the 6th bullet point.

     

    http://support.apple.com/kb/HT5048

     

    Hopefully this new update won't **** something else up that is important.

  • knutklim Level 1 (0 points)

    Found this post today and have to report that 10.7.3 hasn't fixed it for me.

    Have tried all of the above with no joy.

    Any other suggestions anyone?

  • Tgara Level 4 (3,545 points)

    knutklim wrote:

     

    Found this post today and have to report that 10.7.3 hasn't fixed it for me.

    Have tried all of the above with no joy.

    Any other suggestions anyone?

     

    The two fixes I've used are (1) set the Energy Saver so that the drive Never sleeps, and (2) go back to using an Ethernet cable and turn the wifi off.  The Apple engineers are working on a fix to be included in 10.7.4, which will be out soon (hopefully!).

  • knutklim Level 1 (0 points)

    Hi Tgara, thanks for the advice.

    Yes, have reverted to ethernet option. This has the added benfit of allowing me to connect to other computers and printers on the network which the wifi connection does not. Here's hoping that Apple can fix this also while there at it.

  • joshuafromauburn Level 1 (0 points)

    It may be a problem with the connection information stored in your network profile.

    1. Go to System Preferences > Network.
    2. Click the Wi-Fi connection.
    3. Click the Advanced... button on the bottom right.
    4. Click the Wi-Fi tab.
    5. Under Preferred Networks, select your wireless network.
    6. Click the - (delete) button.
    7. Turn off your Wi-Fi connection.
    8. Turn it back on.
    9. Select and login to your wireless network. This will re-save your connection under Preferred Networks.
    10. Close your laptop and reopen it to test whether it worked.
  • DavidGriff Level 1 (0 points)

    This worked perfectly for me - spot on!

Previous 1 2 3 4 Next