2 Replies Latest reply: Apr 3, 2012 7:54 AM by Mayahkai
lucyfromhouston Level 1 Level 1 (0 points)



2 days ago my kids were skyping and everything was fine, then I turned off my iMac and the next day Skype wouldn't use my iSight Camera. In the settings it shows that it is using the iSight Camera but not picture! I made an update from skype but it didnt help. I restarted my computer, reinstalled skype nothing.

I am not a big pro with computers, so if you have an explanation, PLEASE be detailed in your explanation.





iMac, Mac OS X (10.7.2)
  • EZ Jim Level 7 Level 7 (21,865 points)



    If your iSight does not work in any app, the SMC reset suggested

    in Apple's iSight Troubleshooting suggestions may restore proper function.


    Otherwise, use Disk Utility to repair permissions and then

    download and apply the 10.7.2 Combo Update:



    Repair permissions again immediately following the system restart

    that completes the Combo update. The Combo version of updates

    can sometimes correct problems that appear after an OS X update.


    If your only problem continues to be in Skype, be sure you are

    using the latest Skype: http://www.skype.com/go/downloading


    Message was edited by: EZ Jim

  • Mayahkai Level 1 Level 1 (0 points)

    I know this is an older thread BUT I've been dealing with this issue for the past four days and this is what I found... (perhaps if it helps another person....)



    Assuming you've already checked while on a Skype video call that your camera isn't turned off...




    Open Skype Preferences to verify your settings.

    (prob in your downloads, applications folder or on your desktop)

    Screen shot 2012-04-03 at 9.25.40 AM.png



    Then at the top your screen, next to the Apple Icon you should see Skype:

    Screen shot 2012-04-03 at 9.08.02 AM.png


    Select Skype, then scroll down to Preferences.  Verify settings.

    (Mine, for example, under the "Calls" Tab was set to autoanswer so I can check on

    my dogs while away and tell them to get off the couch!)



    Make sure another apple app isn't hijacking your camera.

    Open Finder, Devices, Applications, then look for IChat


    Once open, Select iChat and scroll down to preferences.


    (For my settings, I don't use IChat SO I changed the "default IM application" to Skype,

    under General settings tab.)

    Screen shot 2012-04-03 at 9.22.47 AM.png



    Select the green Audio/Video Tab

    and uncheck "Open IChat when external camera is on"

    Screen shot 2012-04-03 at 9.21.01 AM.png




    I verified that all other Apps using the camera weren't open.  My insight camera worked

    when I opened Photobooth,  IChat, Facetime and ICamSource (a monitoring program)

    - just didn't work with Skype!


    From Desktop, go to Apple Icon, select "Force Quit Finder", then scroll down and

    close everything that uses the camera. 

    Screen shot 2012-04-03 at 9.32.16 AM.png




    From Desktop, go to Apple Icon and select Restart (pic same as above).

    Upon restarting, once the screen blanks out hold down the following keys all at once:

    Option, Command and P and R keys.


    For me, I heard the computer "restart song" chime twice before letting go.

    (PRAM and NVRAM settings)




    I tried a Skype video call from an Iphone to Mac Desktop and it went through just fine!