1 Reply Latest reply: Oct 25, 2011 3:22 PM by Kohlab
Kohlab Level 1 Level 1 (0 points)

I used Migration Assistant to move my data from one MacBook Pro to another.  On the new MacBook Pro, I got the prompt asking if I'd like to inherit the old backup.  Maybe because I'd renamed the new laptop to the name the old one had or because there was an interrupted backup, it failed.  Now I'd like to still use the old backup but am having problems doing so manually.  I've tried this:

 

Moe:~ dylan$ sudo tmutil inheritbackup /Volumes/Data/Moe.sparsebundle Password:

Attaching disk image...

** /dev/rdisk1s2 (NO WRITE)

   Executing fsck_hfs (version diskdev_cmds-540.1~25).

QUICKCHECK ONLY; FILESYSTEM CLEAN

/Volumes/Time Machine Backups/Backups.backupdb/Che: Failed to claim machine directory: Read-only file system

Failed to claim machine directory within backup disk image.

Failed to eject volume /Volumes/Time Machine Backups (FSVolumeRefNum: -112; status: -47; dissenting pid: 0)

 

I've tried to mount the Time Capsule filesystem readwrite, but haven't had any luck yet.  Any ideas?


MacBook Pro, Mac OS X (10.7), 2.4 GHz Intel Core 2 Duo, 4 GB RAM
  • 1. Re: Issues inheriting old backup
    Kohlab Level 1 Level 1 (0 points)

    Turns out I had the same Time Capsule filesystem mounted on another computer, and apparently only one can be read-write at a time.  When I unmounted it from the other computer, I was able to run the "inheritbackup" command just fine.