14 Replies Latest reply: Feb 12, 2015 10:09 AM by Clinton Chau
mweldridge Level 1 Level 1 (10 points)

My cell phone caller id is blocked. I have my contact phone numbers stored starting with *82 to unblock my caller id for that call so my contact can see I am calling. However, Siri can't dial a number starting with *82. If you say "Siri call <name>" the response is "Sorry, I cannot call <name's> mobile number".  The Apple Siri designers need to know that a contact phone number can start with *82. I had no problem voice dialing these same numbers with the Verizon Motorola phone I had before upgrading to the 4S, (I can call these numbers from the phone app by touching the contact and then the number entry. But that kind of defeats the purpose of Siri.)


iPhone 4, iOS 5
  • Seriousbrain Level 1 Level 1 (0 points)

    Same problem here , in oman, changed the number to 11 digits, removed and added the country code, restated my phone..  No use !

  • Wakajumba Level 1 Level 1 (0 points)

    I have the same issue. I too, have a blocked number. SIRI will find my contact but cannot dial the number. As usual, Apple is tight lipped and in-store reps hold the party line by not even acknowledging that this is an issue.   I can't believe that this is isolated to just a handful of users.  The 4S is supposed to be the 'International' phone and many users are having issues with International number sequences. Nice job!  Who tested this? C'mon Apple, get your act together and fix this!  How hard can it be to transmit a sequence of known values?!?! 

     

    As the NIKE slogan says, JUST DO IT

  • wwwe Level 1 Level 1 (0 points)

    Same issue down here on the equator in Singapore.

    Starhub, my mobile provider has a cheap international phone service that requires me to dial 018 before the country code (instead of +, or 001 etc).  Siri doesn't like it.

     

    Can you fix it for me please!

  • Bevelmon Level 1 Level 1 (25 points)

    I've been working with Apple support on this very problem for the last couple of weeks since I hadn't made the correlation to non-numeric charicters as the problem.  Apple needs to fix this soon,  voice calling is un-usable as currently designed.  However the actual fix needs to be a caling prefix and suffix field in contacts.  This will also fix having to store the number only twice once for incoming and outgoing calls.  As caller ID won't match incomeing calls to numbers with *82 prefixes making it necessary to store each number twice one with *82 for outgoing calls and one without for incoming ID matching. 

     

    The matching problem has been an issue forever but now with Siri not dialing these numbers now, this can no longer be left unresolved.

     

    Apple, how about makeing Siri work for all of us?  Soon!

  • Bevelmon Level 1 Level 1 (25 points)

    Everyone with this issue needs post feedback on the phone page (http://www.apple.com/feedback/iphone.html) in order to get Apple to see that there are enough customers to warrent them fixing this issue.  The link above will get you to the right place. 

     

    Bevelmon

  • rasina Level 1 Level 1 (0 points)

    Have you tried turning Internation Assist off in Settings>Phone?

  • mweldridge Level 1 Level 1 (10 points)

    Changed setting. Same issue.

  • ngraja Level 1 Level 1 (0 points)

    Dear Seriousbrain,

            We have tested siri dialing today to South africa, Qatar and India. Its working. But local Oman numbers not working. The trick behing this is, do not use your existing saved contact. Insteed you delete the contact you want Siri to dial, then open phone dialer and type '+' then type numbers. The dialer will define the format based on country code. Then save as new contact or add to old contact. Now ask siri to dial the contact. You may not suceed for all contries, at least you can feel the siri's performance.

  • paryag Level 1 Level 1 (0 points)

    Dear All

     

    I have the same problem in Peru with one contact mobile number , I get " Sorry David, I can't dial ZZZ mobile number" , However when I manually select the contact and press call, I can get through normally.

     

    I have tried making a new contact and entering the number again, then adding "+51" and "00 51"  before the number but it still doesn't work.  The mobile number is 9 digits and starts with 963 763 XXX

     

    Any suggestions welcomed.

     

    thanks

    Dave

  • new2this_248 Level 1 Level 1 (0 points)

    Pleaes fix the *82 prefix dialing Apple,

     

    I as others on this post I'm having problems with the non dialing of a prefixed NPX-NXX number originally blocked by carrier then unblocked with the *82 prefix.  This is a serious oversight by Apple that can be remeidied with a software update.  I cerntainly hope that Apple is monitoring this thread. My Samsung Galaxy II S does not have this problem.  Please Apple address this *82 issue soon or I will consider sending my business else where.

     

    Regards,

     

    Norm

  • Dossam1y Level 1 Level 1 (0 points)

    I just added additional dummy digit at the end of the phone # and finally it worked

  • Mathivanan murugeshan Level 1 Level 1 (0 points)

    hi

    i got the same problem for the past two weeks

    even i got it replaced with a new handset this monday but even this says the same message"SORRY I COULDNT MAKE YOUR PHONE CALL"

    let me know if you find some solution for it..........

    rgds

  • alwaysawn Level 1 Level 1 (0 points)

    My phone wasn't working either but the tech for my phone carrier suggested using *31# before the number instead of *82 and it will work as an alternative.

  • Clinton Chau Level 1 Level 1 (0 points)

    I use *31# as a prefix to unblock my caller ID information. For example, *31# +1 (NPA) NXX-XXXX. However, I still couldn't get it to work until I removed the '+' sign. Then Siri was able to dial properly.

     

    This is still problematic though, as the '+' is very useful for getting the phone and provider to automatically use the proper exit codes, e.g. 011, no matter where you're dialling from.