Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Feb 3, 2015 9:32 AM by bluelotus1618 Go to original post
  • sgiglia Level 1 Level 1

    Finally got all of this down afterediting that info.plist 10 times... however, i'd like to only install this on a PARTITIION on my external hard drive. Will this reformatt the eniter hard drive or just the Partition?


    I also have ejected all of the other partitions except for the one I want, however when it 'finds the drive' it is showing the root name of the drive so it appears it will reformatt my entire drive, which i DONT want it to do.




  • philberndt Level 1 Level 1

    thanks for this!

  • philberndt Level 1 Level 1

    thank YOU! sir

  • ssn637 Level 1 Level 1

    Thanks to this tip I was able to create a Windows 7 installation disk (USB Flash drive) from a Windows ISO image in Boot Camp Assistant.  My MacBook Pro 2010 13" has the same Boot ROM version (MBP71) as yours.  But when I attempted to restart the system and boot from the USB drive it wasn't recognized.  Has anyone with a similar model been able to actually boot from the USB flash drive created with Boot Camp Assistant?  I ended up having to use an external Super Drive with a Windows 7 installation DVD (my MacBook Pro has an SSD installed via an OptiBay interface with the internal DVD drive removed).

  • ier1c Level 1 Level 1

    You're suggestion worked for me, spent the whole night sorting this out.


    Late 2011 Macbook Pro 15" with SSD upgrade and Optibay for the stock 750GB HDD.


    Hope people can use their serach engine and find this place.



  • i_Tim_ Level 1 Level 1

    I managed to get the USB alternative work for Bootcamp, but I get the "No bootable device--insert boot disk and press any key" error. Tried with three different USB keys. Has anyone found a solution to this, why is some USB keys working?


    Also, does this mean that my Lion recovery USB wont work if I ever have to use it?


  • Charles Smith16 Level 1 Level 1

    Again not to knock free bootcamp but I received Fusion's VMWare 4 in the mail and installed Windows in a virtual machine on the desktop of my MBP 13" and it runs interchangeable while in OS X Lion. It's THE way to do this

  • i_Tim_ Level 1 Level 1

    I´ve done this too, with Paralells 7. But for gaming I really need bootcamp to work.

  • kyleharry Level 1 Level 1

    Has anybody had any more success with booting from USB?


    I have a late 2011 MBP, and edited the Boot Camp app plist to include my model. I successfully created the USB disk with the Win 8 ISO and whatnot, created the partition and rebooted.


    Except that's where it ends. I get the no bootable device message and just have to restart. I can't seem to get the USB drive or empty bootcamp partition to appear when holding Option on boot.


    I know I could switch back my boot order and eventually get a DVD to burn, but I'm at home now, and rather not buy DVDs that I'm never going to use.


    Is there any work around for this?


    Thanks in advance.

  • nayan007 Level 1 Level 1

    I also tried to boot from USB,but suddenly my computer just crashed down,so did not tried again to boot /___sbsstatic___/migration-images/177/17735244-1.gif

  • cebyrne Level 1 Level 1

    Thank you so much! I am not sure why Apple would not allow this option on all platforms that are supported by default ... but I am glad there are folks like you that know what makes this tick.


    Working like a champ on 10.7.3

  • dbartul Level 1 Level 1

    I had the same problem as nayan007, did manage to get to the create usb installation disk part and made the boot camp partition but unfortunately it wouldn't boot after that, kept getting the no bootable device message.

    What I did though one I've managed to create the boot camp partition is to install rEFIt and it allowed me to boot from the usb and ultimately install windows.

  • SKieller17 Level 1 Level 1



    How excatctly did you install rEFit and where from? I've tried to install it and then tried install windows, but i still get the same message "no boot-able device found" I've tried a lot of ways how to boot, but this is the only way where i have come so far, so i won't give up now!


    So i would be more than happy if you could give some links, and a description of how to install the rEFit and afterwards how to boot the system.





  • dbartul Level 1 Level 1

    Hey! Sorry for the late reply...

    I first edited the info.plist as described in this topic (although for me it only worked when I added the string at the top of the list) then I created the USB installation disk and made the partition but didn't choose to install windows.

    After that I've installed rEFIt from and booted my mac from the USB in the rEFIt menu. If that doesn't work you can also try to make a bootable disk on a PC or a virtual pc machine using microsoft's windows usb tool.

    Hope that risolves your issue.


  • SKieller17 Level 1 Level 1



    Before you answered a friend of mine suggested me to burn the ISO file on a windows computer to a DVD and it would work as an installation DVD. I did it, and it worked perfect!


    But anyways, thanks for your reply, i may try booting a second time with Linux using your method