13 Replies Latest reply: Mar 27, 2014 7:45 PM by drobi
wesfromlanghorne Level 1 Level 1 (0 points)

On both my wife's Macbook Pro (Fall 2007) and mine (Fall 2008), when we updated recently to Lion, our Mac Mail is acting funky.  We type an email, we hit send, then the spell check box comes up.  If we then try to type in the actual email body to correct or add, as soon as we start typing, it sends the email.  So we are sending emails that are partially editted.

 

As well, when we send an email where we have not tried to type in the main body as above, fter finishing spell check and closing the spell check box, the email does not send.  We need to hit the send button again.

 

Can someone point us to a solution?


MacBook Pro, Mac OS X (10.7.2)
  • UGS at UU Level 1 Level 1 (0 points)

    Happening to me on 10.8.
    Frustrating.  Very frustrating, and not the quality I expect from Apple.

  • mril007 Level 1 Level 1 (0 points)

    This is also a huge problem for me. Everything was fine in OS 10.6 and I did not upgrade to 10.7. However, I did upgrade to Mountain Lion and it is a "major" problem that a key stroke in the message, while the spell check box is open, will automatically send it.

     

    Apple:  Fix it or I will have to find another email program to use. This is not worthy of your claims of high quality software.

  • craftanne Level 1 Level 1 (0 points)

    I am having the same issue, just got a new MBP and the email makes no sense when it does this! I don't mind hitting the Send button twice but sending when I edit during spell check? No! That capability of editing during spell check used to work in Snow Leopard, so losing it now for this inferior behavior of sending an email before spell check completes is terrible User Experience.

     

    Apple - can you help please? I have checked for any settings that could be causing/contributing and cannot find any.

  • kuntal15 Level 1 Level 1 (0 points)

    I have the exact same issue also. It happens when I quit spell check and begin editing the email body some more. The mail goes out whilst I am still typing! This is bad...

     

    I have already confused many of my email recepients with half complete sentences! We need a fix from Apple.

  • drobi Level 1 Level 1 (0 points)

    Recently upgraded to 10.8.5 on an iMac and am experiencing this EXACT issue in my mail account. I am using a gmail account. Is everyone else with this problem using gmail?

     

    If I move the curser into the body of the email to manually correct something, WHILE spellcheck is running, the email just FLIES out and gets sent prematurely! I do not hit "send," because the spell check is NOT FINISHED conducting its check. It sends prematurely.

     

    This is a bizarre development. Since i have used the Mail program on this same imac for years, I have never experienced anyting like this. Only started seeing this regularly with the OS upgrade to 10.8.5.

    Needless to say, far too many of my emails are being sent without proper editing!  Please HELP! I do not want to be forced to use web-based email, but that's where I am headed!

     

    Thanks in advance !

  • worldgooner Level 1 Level 1 (0 points)

    Having absolutely the same problem. It has caused some embarrasment already because I send emails with legal implications and often have a lot of detail that requires me to read through a few times as well as spell check.

     

    I also use 4 or 5 email addresses for different businesses so using web based mail isnt an option.Please apple find a fix.

    Is there anyway we can accelerate bringing this to their attention?

     

    Its been happening for me for the last week, since the upgrade and currently using 10.9.

  • coolhands2000 Level 1 Level 1 (0 points)

    Me too!

    DO SOMETHING APPLE

  • Nancy Jayne Level 1 Level 1 (0 points)

    This is a very frustrating item with Apple Mail.   I am still a newbie, but my work around was this: 

     

    Mail > Preferences > Composing

     

    Under Check Spelling, because I KNOW I make mistakes, I selected "as I type".  Selecting "Never" is another option, however you'd have to review everything BEFORE hitting 'Send'.

  • drobi Level 1 Level 1 (0 points)

    I have used a similar work around, Nancy, but it seems that something in Apple Mail is corrupted, or else this would not be happening. if ANYONE has a solution, PLEASE share it here.

    Thanks

  • dianeoforegon Level 5 Level 5 (4,375 points)

    Upgrade to Mavericks. It's a free upgrade. Apple is no longer updating Lion and Mountain Lion.

  • rilmrk007 Level 1 Level 1 (0 points)

    Regarding upgrade to Mavericks. I tried this on one of my Macs hoping it would solve the problems. Unfortunately, Apple continues to ignore this critical bug so this ridiculous situation continuous in Mavericks. APPLE: PLEASE DO SOMETHING!!!!!! It is embarassing that this have not been resolved.

  • dianeoforegon Level 5 Level 5 (4,375 points)

    If you want Apple to know, send Apple feedback:

     

    http://www.apple.com/feedback/macosx.html

     

    This is a community discussion and list and not the best option to let Apple know about issues.

  • drobi Level 1 Level 1 (0 points)

    Hi there,

    I have real reservations about upgrading to Mavericks due to the age of my iMac. (2007 iMac7,1)

     

    I worry about it becoming unstable.

     

    in addition, i just discovered a glitch in TIME MACHINE, which seems to be no longer backing up the user-specific files. I have made no changes to t.m. and was pretty bummed to discover that my personal files are not backing up, despite the fact that I have FileVault disabled.

    trying to resolve that matter in another thread right now.