Previous 1 2 3 4 Next 353 Replies Latest reply: Dec 12, 2013 11:05 AM by Yachinghou Go to original post Branched to a new discussion.
  • phonebrkr Level 1 Level 1

    your not alone.  my wife and i have the same issue.  i've talked with a number of friends who are having the same problem.  most of the data issues started in the past few days.  switching the airplane mode on and off  works only for a short time on one phone, it didn't work on the other. wifi works fine.  phones show 3g and 5 bars but can't open any web pages.  i also feel that it sounds like and issue with the operating system.    all i know's getting old real quick.   i have had a few apps that would not work at all at first.  i had to delete the app and then download it again.  i'm wondering if maybe an app or 2 is not working properly and causing the issue.  like skymatt i have a large number of apps.  i will take the time to check them all out and if i find something i'll gladly post about it.   if i hear of anything that helps i'll post it and i'll keep checking back to see if anyone else has come up with some type of fix.   sounds like we are all in the same boat. 

  • anestech* Level 1 Level 1

    Having the same problem here, on both the Sprint network and wifi.  I have called Sprint a couple times, and we have tried the ##873283# cell network update, and also a reset of all network settings.  It looked like the reset of network settings worked, but after a couple of days it dropped on wifi again overnight last night.  The airplane mode toggle or a reboot both have always worked for me, but that should not be needed.  My girlfriend's Verizon iPhone 4 (on iOS 5) isn't having any issues at all, so I'm convinced it is device related.  Also the fact that it is happening on both cell and wifi and across several carriers makes me think it is hardward related to the 4S.  I'm heading to the Sprint store for a replacement today...

  • SkyMatt Level 1 Level 1

    anestech* wrote:


    ...My girlfriend's Verizon iPhone 4 (on iOS 5) isn't having any issues at all, so I'm convinced it is device related.  Also the fact that it is happening on both cell and wifi and across several carriers makes me think it is hardward related to the 4S....

    Like I said, it transcended phones for me as it started happening to me on the iPhone 4 as well (iOS 4 & 5) a few months back. I very eagerly await how it works out for you presuming you will restore the new device from backup. Please report back your results after a couple of days please.

  • SkyMatt Level 1 Level 1

    Possible Culprit: CommCenter App?

    Over in a different thread (, therealikt may have come up with the true culprit...the CommCenter app. From what I understand it's a background process that network/data communication utilizes (for both 3G and WiFi) to work.


    Proposed Solution

    He/she suggests what I think we all know would work, and that is to restore the phone as a new iPhone. If the CommCenter app is the problem, I really believe there's gotta be a simpler way to repair/replace the CommCenter app than to have to start over. Specifically, how did this happen, and how can it be prevented in the future? That being said, kudos to therealikt.


    therealikt wrote:


    It's supposed to be a bug in the comm center app, so doing anything that resets that app, sim pin, airplane mode, etc, should reset it.


    If you do a restore of the phone, make sure you tell itunes to setup as a new iphone, so it doesn't restore the bad comm center file


  • Paul Bradley Level 1 Level 1

    Similar experience in my end: at ransoms times, signal indicator goes from 3G to Edge to 'o'. Most times a reboot, network settings reset, or toggling plane mode will fix it. I have restored my iPhone as a "new" phone twice and the problem returns. One note, however... I only notice this behavior at home. Wondering if perhaps it's an AT&T issue in the area.


    I have run the iPhone config utility and watched the console log for anything out of the ordinary, but I really don't know what I'm looking for. I do notice that an entry stating "network mode changed" (or something to that effect) just before losing 3G (or even Edge) connectivity.


    Same issues observed on my wife's iPhone 4S. Interestingly, I've noticed it on my other iPhone 4 (running iOS 5). Leads me to think perhaps it's either carrier or software related.

  • sfgfkhome Level 1 Level 1

    I have been having this issue over the last few days.  It does not matter where I am even if it shows complete wifi or full 3g I cannot connect to any web pages. The phone works fine but internet and data get nothing.  This was not a problem when i first got it but it is way more than just a pain it is getting critical now.  What is the use of a device such as Iphone 4s if you can't connect.  I have tried all of the different things listed above bot to no avail.  Nothing seems to work in any combination.

  • tpero Level 1 Level 1

    Apparently I had spoken too soon before when I thought the problem had fixed itself. I resisted for a while, but finally performed a full restore and set up as a new phone (NOT FROM BACKUP). I am now on day 5 since the full restore, and have yet to experience the "hanging connection." For those that are actually losing bars of service and going to "O" or "no service," I think you may have a different, hardware-related issue with your antenna. For me, and I think others on here, my phone showed a strong signal and the 3G icon, but would just "hang" when trying to connect on email, safari, apps, etc.


    Setting up as a new phone will force you to lose your old text messages, high scores on games, etc. I was irritated at first, but I'm over it; there are worse things in life. Assuming you have your contacts/calendars synced through an exchange server or icloud, I think there shouldn't be any problems there.

  • SkyMatt Level 1 Level 1

    To me, this is not a solution. I think it was a given that restoring as a new phone would do the trick, but what we need to figure out is why this happens to begin with. Otherwise, it may pop up again. Once we figure out what it is (CommCenter??), and how to fix it, then we'll have our true solution that everyone can be happy with.

    tpero wrote:


    ... finally performed a full restore and set up as a new phone (NOT FROM BACKUP). I am now on day 5 since the full restore, and have yet to experience the "hanging connection." ...

  • Paul Bradley Level 1 Level 1

    I'm leaning toward a software/carrier issue. As stated in my post above, I'm noticing lost signal behavior on all three phones (2 are 4S, 1 is a 4... all running iOS 5). I have not noticed the issue when I have my phone with me while in a different geographical area.

  • SilverDollars Level 1 Level 1

    I just recently purchased TWO 4S models (one for my wife, and then one for myself about a week later).


    Interestingly enough, my wife does not experience this issue with her phone. I, however, experience it once per day (give or take). It seems to happen with 3G and with Wi-Fi. In each case, I see a strong 3G signal, but nothing will load.


    Switching to airplane mode and back does not help, but a hard reboot of the device seems to work every time.


    My phone is a 32GB model, hers is a 16GB, other than that they are both black 4S devices. Both are running latest iOS. We do have different apps on our devices, and some of mine are a little more network intensive.


    I'm not sure if this is hardware, software, or OS related. Hoping it's just an iOS issue and a patch will resolve it. Rebooting the device to check my email is annoying.

  • jeffgtx Level 1 Level 1

    I'm leaning towards software and I'm also getting the feeling this has to do with the phone finding a new base station.


    For me the problem only happens when I travel. When I am just going back n forth between home and work, no issues.


    But when I land somewhere new, it takes the phone forever to find AT&T. And then sometimes it just won't do anything data wise.

    Leave the hotel wifi and foot 3G and it hangs again.


    It's almost as if it just can't finalize that handoff and gets stuck.

  • SteManz Level 1 Level 1

    I've been experiencing the same symptoms for a few days now (I didn't notice anything strange during the first days after purchasing my new iPhone 4S). @SkyMatt: your post makes me think - can this be only one app's fault?


    I don't need to reboot the device to get 3G working though, I just turn off/on the airplane mode (and this solves the problem temporarily). Also, I usually leave wifi off, and turning it on restores data connection to the device, but after turning it OFF the data connection is lost again.

    I want to believe the "software" theory, just like many of you said.


    There is no mention about this bug in the latest iOS upgrade (5.0.1, which is about battery problems I never experienced), and I was wondering whether there is an "official" way to report this to Apple. Do any of you know how to do it the right way?

  • SilverDollars Level 1 Level 1

    Not sure how to report it. Apple is notorious for keeping bugs secret anyway, and only when tens or thousands of people are screaming about a bug will they quietly release a patch for it (such as the battery problem). At first they denied there was any problem.


    I just installed 5.0.1 last night, hoping that they may have slipped in a fix for this as well (without mentioning it in the release notes). So far so good, but the day is young.


    As for apps causing it, that very well may be the culprit. I also don't remember this problem for the first couple of days. I will list out some of the less common apps I have on my iPhone that could be related:



    New Gmail App (not the older one)

    AT&T U-Verse VoiceMail Viewer

    AT&T U-Verse Mobile

    AIO Free (plays nature sounds)







    There are others, but these are some that aren't as common and/or they may toy with the network. Anyone see any matches?

  • rlhmass Level 1 Level 1

    I have the same problem. Upgraded with the patch yesterday, hoping for the best, but still lost the connection once today.   And this problem is a huge battery drain, as the Exchange "push" email keeps searching for a connection.  As someone else said, Apple did not address this issue in the specs for the patch, so I wasn't surprised there was no change.  By the way, I have none of the apps above. Well, I have Pandora, but don't use it.  My phone is a company phone, and our IT guy is going to trouble shoot it on Monday.  I'll let everyone know if he comes up with something.

  • SteManz Level 1 Level 1

    So let's just hope someone at Apple will notice this discussion. -_-'


    For the moment, I will NOT update to 5.0.1, because of this alarming article I've read on Ars Technica:

    iOS 5.0.1 update causing contact, WiFi headaches for some users (Updated)


    Here's an bridged reason of what keeps me from updating:


    users are also reporting a rash of new problems that were apparently introduced by the 5.0.1 update. [...] some users aren't getting a proper contact name displayed when receiving a call [...], (other) users are complaining of microphone problems, WiFi signal issues, and difficulty connecting to cell networks.


    I have begun thinking about another possible reason for this issue. Has anyone noticed whether this happens everywhere, or in a rather specific place?

    That's because I often notice that my iPhone loses the ability to fetch 3G data (even if the signal is OK) when I'm at work, but not when I'm home or anywhere else.


    Anyway, here's a list of my installed apps: (I can't judge about issue-related or unrelated apps, so that's the whole list)


    Qdialer free

    Ubuntu1 music

    Zombie booth liote


    Nighjt Stand

    119 Self







    TuneIN Radio







    Ars Technica

    T's Hardware



    Opera Mobile




    Google Earth

    PS Express



    Just in case, here's the list of the apps with notifications enabled:








    Did anyone benefit from the update? Or speak with some Apple guy (rlhmass?).

Previous 1 2 3 4 Next