Previous 1 2 3 4 5 Next 353 Replies Latest reply: Dec 12, 2013 11:05 AM by Yachinghou Go to original post Branched to a new discussion.
  • rlhmass Level 1 (0 points)

    I've lost email connection at work, at home, and in the car. 


    By the way, I also had problems with losing the wifi connection -- before the upgrade, with the original 5.0.  There's another thread on that somewhere in these forums.  There was a suggestion to completely reset all the network connections.  I did that, and haven't had any trouble connecting to my home wifi since.  Fingers crossed. 


    Honestly I think this phone is just very buggy.   The battery issue was the big headline, and they sent out a patch for that, although I think they'll find the lost data connection problem is one of the things causing the drain, not just the location software.  When I pick up my phone and it's warm to the touch, sure enough no data connection and I've lost half the power on the battery. 


    To clarify, I'll be talking with my company IT guy on Monday, not an Apple guy.  We are a Apple shop, and he supports all our equipment. He may say turn off this and turn off that, and my response will be, sure, but shouldn't this thing just work right?

  • dirt630 Level 1 (0 points)

    I'm having the exact same problem. I can't get 3G data at various times during the day but only at my workplace. Weird thing is I had an iPhone 4 that started doing the exact same thing about a month or two ago. I thought it was the phone so it made my decision to upgrade to the 4s a bit easier. But this one is doing the same thing. Only thing that seems to help for an hour or two is reseting the network settings. Updating to 5.0.1 did not help at all.

  • SteManz Level 1 (0 points)

    Guys I have both good and bad news. Good news is I've solved the issue, bad news is it won't - supposedly - work for most of you.


    If you bear with me, I'm going into some details and maybe this could ring some bells anyway.


    I started rejecting the hypothesis "it is an iPhone issue", placed the microSIM into an adapter and used it with a PC into my 3G USB modem (which I am using at home).

    While usually the connection is smooth and stable, with my iPhone's SIM the internet connection was always dropped by the remote server after 30 minutes. I did several tries, and it always ended up like this - dropped connection and no way to bring it back up. I had to eject the USB 3G modem and plug it back in to get it working again.

    I noticed that the APN that was set as default was a WAP-type APN (specifically, my carrier is TIM - Italy), but I know iPhone prefers using another APN with this carrier (

    After setting this new APN, I was able to get uninterrupted data with the 3G USB modem.

    After placing the microSIM back into my iPhone and setting the nex APN, I have never experienced the issue again (it's about two days now).


    I hope this will help at least someone troubleshooting this issue, good luck!

  • SilverDollars Level 1 (0 points)

    SteManz, I have to admit, I have no idea what you are talking about. I appreciate the info nonetheless.

  • rawkey Level 1 (0 points)

    Same... the phone will show 3G, but data will not be present.  I've had it occur a few times on my 64gb-4s but am unsure what triggers it.


    Running on the Rogers Network.

  • rottnmutt Level 1 (0 points)

    I took my 4S to Apple on Saturday only to have them tell me to go back home and try a complete Restore.


    After doing that, things are different but the same:

    • Prior to doing the restore, my 3G connection would drop but my wifi connection would be fine when at home
    • After doing the restore, my 3G connection seems more stable but my wifi connection failed last night while at home
  • rlhmass Level 1 (0 points)

    My company IT guy came and took a look, and had no solutions other than to say it was a bug and that Apple would release a patch eventually, and that the other 7 people in my company who had upgraded to 4S had the same trouble.


    When I had lost my Wifi at home recently, I did a reset of the network connections, which fixed the problem.  I never bothered to re-enter my work wifi.  During this consult with my IT guy, he re-entered the work wifi....I immediately lost the data connection, and had to reboot.  Could this be some sort of conflict with wifi?  I got rid of the work wifi,and so far so good.

  • tpero Level 1 (0 points)

    New revelation:


    So after doing a full restore on my iPhone 4s a few weeks ago, I thought I had this problem fully kicked. I went for about two weeks with no drops in 3G connectivity. But today I lost it again, and it was immediately after I changed something.


    When I did the restore, I had immediately set up two of my email accounts, one an IMAP account, and the other a Microsoft exchange account for G-Mail. Today, I finally got around to setting up my work email exchange account. It synced perfectly and my work emails and calendars showed up...then it happened: my 3G connection began to hang again, even though my status bar showed full reception and the 3G icon. So it looks like there is something about my company's exchange server that is making this happen, though it was never a problem on my iphone 3Gs, which was still on iOS 4.xx.... So maybe there is a compatibility issue between iOS 5 and my company's exchange server?


    So are other people who are experiencing problems using an exchange account?


    I'm simultaneously happy and frustrated. Happy that I know what has been causing the issue on my phone...frustrated that this means until it is resolved, I can't put my work email account on my phone.

  • rawkey Level 1 (0 points)

    tpero wrote:


    So are other people who are experiencing problems using an exchange account?




    YES!  I am having the "I have 3G, but no data" issue.  I am connected to the Exchange Server at the office, and am using Exchange for GMAIL.

  • rlhmass Level 1 (0 points)

    When it goes down, none of my 3  emails connect-- Gmail, Comcast or and work which is exchange.  Could be that Exchange is the culprit that knocks the others out, but not sure it works like that.....

  • SilverDollars Level 1 (0 points)

    This is all good stuff.


    I do not actually have any accounts linked to Exchange, my account is a GMail account (not using the Exchange approach, just the standard iPhone GMail setup).


    I did notice today that I heard the new mail sound, and then immediately after that my 3G connection stalled out. It was showing 4 bars, and the 3G logo was there, but nothing would load. I have been able to reset this by going to network and disabling 3G data and then re-enabling.


    I have also seen this issue a few times when making the transition to and from my WiFi network at home.


    But just wanted to say, I have seen this issue a number of times and DO NOT have an exchange account setup. I do have multiple Gmail accounts setup, however.

  • rottnmutt Level 1 (0 points)

    Neither I, nor my wife who is having the same problem, have Exchange set up.


    My gut tells me this is an issue between IOS5 and device drivers related to the comm chipset, or just a comm chipset from a particular vendor or batch.

  • SkyMatt Level 1 (0 points)

    rottnmutt wrote:


    My gut tells me this is an issue between IOS5 and device drivers related to the comm chipset, or just a comm chipset from a particular vendor or batch.


    This is not new to iOS5. I had experienced the problem with 4.3.5 as well.

  • anestech* Level 1 (0 points)

    Well, after striking out with Sprint tech support (tried their ## update for the cell network, a network settings reset, and a full restore of the phone and setting it up a new phone) I called Apple Tech Support.  They said those are the same things they would have suggested, and they sent me a replacement iPhone (for free as I bought the AppleCare Plus coverage).  It is waiting for me at home, I will update after I give it a few days of use.  I had been having the problem mostly on wifi, moreso than on the cell network, but did have it on both.  Both before, and after the 5.0.1 update.  My girlfriend has a Verizon iPhone 4, updated to 5.0.1 (also did 5.0 the day it was released) and has not had any data drop issues on cell or wifi (thus eliminating my wifi router as the culprit). 

  • rottnmutt Level 1 (0 points)

    Out of curiosity, is anyone else having this happen:


    I just lost data connection again on 3G and forced a restart. While establishing the 3G connection, the bars and the #G indicator briefly flash to have the bars then 310-410 3G before displaying AT&T or the carrier?

Previous 1 2 3 4 5 Next