Previous 1 2 3 Next 75 Replies Latest reply: Dec 18, 2014 7:43 AM by Patrick Apple
ATC_MAC Level 1 (0 points)

I've recently purchased a new Macbook Air and I love it except for a minor issue.


I have migrated from a PC to Mac and everything has gone smoothly so far when setting up iTunes. I had my music library on an external hard drive that was originally hoooked up to my desktop PC. However, this hard drive is not very practical when it comes to portability. So, I purchased a new WD My Passport for Mac. I hooked them both up and transferred all my media from the old drive to the new one. I then imported all the media into my iTunes and chose the new external drive as my download location for new purchases.


However, I have noticed that a couple songs (I haven't listened to all 1100+ songs yet) are cut off. And not just a couple seconds at the end of the song. It's anywhere from 50s - 1 min at the end of the song that is cut off. The song continues to play, but with "dead air". This happens when playing the song from iTunes or my iPod/iPhone.


Today I deleted the songs from the new external hard drive, then hooked up the old one and re-copied them to their directories. I still have the same issue. The interesting thing is that if I play the songs in QuickTime I have no problems. They play through entirely without cutting off. No "dead air".


I'm at a loss as to what this issue could be. I am running iTunes 10.5 (the latest one) and iOS 5 for both my iPod Touch and iPhone. Mac OS X (10.7.2), 13 inch i5 Macbook Air. Any help is appreciated in advance. Thank you for your time and efforts.

  • ATC_MAC Level 1 (0 points)

    Shameless bump.

  • FundRopher Level 1 (0 points)

    Have the exact same issue with 2 songs just downloaded from the iTunes store - they cut off after just over a minute of the song (despite the fact that the songs are 4 and 3 minutes long and there is no stop time set in the "Get Info" section.  Even worse, when I delete them and try to redownload, the album doesn't even show up in my Purchased section on the site.   

  • kinojabber Level 1 (0 points)

    I'm having a similar issue, but with almost all my music.  When I play from my external drive, the songs cut off about half way through.  I copied some of them to my harddrive and they work fine, but not from the external drive.  Anyone have any thoughts on how to solve this?  I'm running Windows 7 and iTunes 10.5 - the latest one.

  • OldRod_KS Level 1 (0 points)

    I am having a similar problem.


    I downloaded an album Friday and had one song that would only play the first 5 seconds, then skip to the next track.  I contacted support, they let me re-download it, same problem.  They finally credited back the purchase price and said they'd look into it.


    Thinking it was an isolated problem, I downloaded several more albums over the weekend and every single one of them has at least one song that cuts off anywhere from 10 seconds to half-way through and will not play.  One album has 9 songs and 6 of them are this way!! 


    I got no errors during download and the song cuts off the same way on my iPod, my iPad and in iTunes itself. 


    The downloaded file size looks right for the length of the song, it's just not all there.


    I have never had a problem like this before iTunes 10.5.  Wonder if something went wrong in that update?


    Just noticed this was in a Mac thread... I am having this problem with Windows 7 - so it's not OS specific I guess.

  • Zolacs Level 1 (0 points)

    I have the same problem. iTunes cut off all song approx after 2 mins. I've listened these songs without any problem before. I can't imagine what coud be wrong, what happened with iTunes.

  • robbimcmillen Level 1 (0 points)

    I have the same problem. The song stops after two minutes, and I just bought it form iTunes today. Can anyone help? I'm on a Macbook Pro (10.7.2) using iTunes 5.


    This only happens with 3 of the 11 album tracks. I checked the file size, and I'm pretty sure the whole song is there.


    NB: Try converting to MP3, this doesn't seem to work either, error comes up.

  • akyrala Level 1 (0 points)

    Same problem here.  Some of my songs get the last bit cut off on the new version of itunes.  My old computer had an older version and they played fine, but the newest version on my new macbook pro has this problem.  All I can find are old forum posts about changing file formats or something called LAME (yeah, seriously lame), however, since these songs were actually purchased from the itunes store I believe itunes should be able to play them without downloading sketchy files from the internet to translate them.  And since I'm talking about a lot of music, that would take a long time anyway.  Hey Apple!  Pay attention, we'd like a solution please!

  • robbimcmillen Level 1 (0 points)

    Hi all, I think I've found a way around this, iTunes' store is smarter than I gave credit for!


    If you delete the problem songs in iTunes and move to trash, then go to the iTunes store.


    On the iTunes store homepage, click on 'Purchased', you can re-download there. Hope this helps!!

  • andrewfromantwerp Level 1 (0 points)

    Hi Rob, the problem is not just osolated to purchased content from itunes in my case, it is random and effects imported CD's, some purchased, some whole albums. Whilst some songs cut out half way though, some dont even get that far. My libriary is over 40gb and never had this problem until the last itunes update. Apple what can you do and fast... This is a serious problem.

  • Rin187 Level 1 (0 points)

    I fixed the problem!


    Maybe this won't work for everybody, but I changed the import setting on iTunes to mp3 (I had it set as AIFF before). You do this by going to the iTunes menu, select preferences, and then click on import settings. I then highlighted the defective songs and converted them to mp3 (which is under Advanced). They all work fine now and play all the way through.


    I hope that helps and works for other people. Hopefully iTunes will fix the problem soon.

  • Super Dave A Level 1 (0 points)

    I am having the same problem, but after reading the proceding post I think there is more to the problem and it is probably due to the newest update of Itunes 10.5.

    Just purchased new computer and now running Windows 7 w/new Itunes 10.5. 

    (1) First problem after setting everything up I imported all of my purchased music which a very large library of music.  I tried to authorize my new computer and got the message I could not because I already had 5 computer authorized.  I signed in under my current email which i had problems with Itunes changing.  When i tried to start playing music.  I would get message to sign under a different email.  I have moved 4 times in the last 8 years and had to have a new email with a new provider.  This has not been a problem in the past until now. 

    (2) I deauthorized my laptop and was able to sign in under the email I have been using for the past 3 years and was able to play my music with no problem, but now having the issue we are currently discussing.  I saw Rin187 fix he posted, but to go thru every song I have and figure out which one is having the problem and changing it would take me more time than I have to fix the problem and not knowing that is the for sure fix.  Itunes Please help.  I have spent tons of money on music and now here we are again with another (major) problem.  Will it ever end?

  • akyrala Level 1 (0 points)

    UPDATE:  Boy, do I feel stoopid.  So based on other posts, I experimented a little and was able to solve the problem with my music library.  When I had originally moved the music over to my new laptop, I had done so over my wifi network.  It seemed so convenient at the time.  But then there was this issue with cutting off hte music.  Someone mentioned somewhere that the problem is caused by corrupted files.  So, I deleted everything and then moved them over using a USB connection.  And guess what?  It worked!  The conclusion I come to is that it was transferring them over WIFI that corrupted the files. 

  • baris13 Level 1 (0 points)

    I have transfered everything via fire wire cable, still teh problem persists!!


    I have the same problem and I see that a lot of people do have similar issues with this cutting off... If someone can clarify this for us, it will be deeple appreciated...


    For example I have a 45 minute Nike+Drive set, that I have purchased fro iTunes and it gets cut off at 5 minutes... I can probably find out 50 plus songs act the same way. Get Info command and start-stop playback times all look normal... They do play the same way in my iPhone as well.


    The only way I can listen to them fully is that when I locate the files in my computer and do a quick preview mode by hitting the space bar... ??? This is really tricky. I've never seen a hick-up like this from apple before...


    Please help!

  • mdloomis Level 1 (0 points)

    I'll repost here since I'm having the same problem...

    I’ve read reports from many other iTunes users who are having the same issue I am.  Please read on...


    When listening to songs that I purchased from iTunes (as opposed to those I imported from CD), several, but not all, of them stop playing prematurely several seconds (or even minutes) before the end of the tune.  Playback jumps immediately to the beginning of the next tune. 


    I noticed this, I believe, shortly after moving my iTunes library to a new iMac (3.1 GHz Intel Core i5, 12 GB memory) running iTunes 10.5.3 (3) on Mac OS 10.7.3.  Everything was fine before the move.


    Of the 283 purchased songs in my iTunes library, about 100 of them exhibit this behavior.  The song playback times at which this happens range from 2:14 to 5:19.


    What is interesting, is that tunes from the same album all end at the same playback time!  For example, I purchased the whole album “River - The Joni Letters” (Herbie Hancock’s album covering a number of Joni Mitchell tunes).  Every song from that album now stops playing at 3:39.  The same happens with other tunes that happen to be from the same album, too.  I have no idea why this would be the case, but it certainly seems significant.


    Another interesting finding, is that if I copy one of tunes exhibiting this issue to the desktop and play it from there, the song plays all the way through to the end without a problem.  This would, I think, rule out a corrupt file and tend to point to iTunes itself as the source of the problem.


    The problem certainly is annoying, and it would be great if we could find some resolution and get back to enjoying our music without the mind-jarring bump that too often now happens without warning.




    Michael Loomis

Previous 1 2 3 Next