Previous 1 2 3 4 Next 101 Replies Latest reply: Aug 19, 2015 3:51 AM by SteinarBraa Go to original post
  • Amlumnah Level 1 Level 1

    This worked for me as well, but now I have the same problem in iCal.  I set the original color, but if I want to change the color it gives me an error.  Easy to work around, just resubscribe and choose the new color, but I shouldn't have to do that.  I wonder what it is about subscribed calendars that won't let you change the color. Also, even though you are syncing them through iCloud, they do not show up on

  • stmalia Level 1 Level 1

    I tried this approach as well & it absolutely works perfectly in terms of having the calendar color that you want - however, this now limits your subscribed calendars to update only when you have iCal open on your Mac.


    Unless you use your mac regularly (and presumably have iCal open when you do), the subscribed calendar content on your iOS device won't be very current.


    Hey Apple - something included in iOS6 to fix this, I hope?

  • Trpfeifer Level 1 Level 1

    How is it possible apple that we are to IOS 6 and this simple problem is not fixed!?

  • northaholic Level 1 Level 1

    i've been struggling with the same problem and i was afraid that the suggested workaround would affect the calendar updates on the iphone... so thanks stamalia for your post.


    please apple fix this issue!

  • lemonizer Level 1 Level 1

    For those who use Google Calendar, this option worked for me:


  • AmyOnline56 Level 1 Level 1

    My previous reply disappeared so it might show up incomplete. I wanted to thank you for confirming my growing suspicion that by making my calendars more efficient (subscribing on all devices instead of just on the Mac and pushing them to my iPad and iPhone) I ruined an essential feature. The subscription color auto-change on iPad is irritating but subscribing on the Mac lets me customize the color and push it intact to my other devices. A fairly nice workaround for a ridiculous bug.

  • webweasel Level 1 Level 1

    There is a relatively simple work-around that I read elsewhere.  Just subscribe to a load of calendars for example at  Switch off all subscribed calendars in Settings > Mail, Contacts, Calendars > Subscribed Calendars, then switch them on one by one, checking the colour of each one in the calendar app.  By checking the colour and changing the order you switch them on in, you sould be able to control which colour each calendar is.  You can then turn off the calendars you don't want IN THE CALENDAR APP.  This last bit is important because if you just switch them off in Settings, ther colour will go haywire and you'll be back at square one.


    Annoying that this bug still hasn't been squashed.

    Also annoying is that the above works for me for all the standard colours except yellow!

  • flips01 Level 1 Level 1

    On Google Calendars I have stable colors, but for my subscribed calendar feeds (webcal:...something.ics) I am unable to change the color from whatever iOS 6.0.1/ assigned to it.

    I can change it, then it switches back some seconds later ...


    Is any iOS developers paying attention to this at all? Or could some Apple employees please notify the developers? Annoying bug ...

  • relliksmom Level 1 Level 1

    This solution worked beautifully.

    Here's the order the colors turned on for me:







  • kingofthedock Level 1 Level 1

    Thank you webweasel. This is the solution/workaround.

  • huff95 Level 1 Level 1

    I have discovered another potential work around that might work for some.


    Create a new "local calendar" (i.e. non-iCloud calendar) in every color except for the color(s) that you want your subscribed calendar to be in.  This will prevent the automatic switching of the subscribed calendar to another color because apparently it now recognizes that another local calendar exists in that color and allows you to retain the color you've wanted all along...because it now sees no other options!


    Hope this works for you.

  • Deanoeac Level 1 Level 1

    Yes about time this was sorted. Anyway. My work around.


    Completely remove the subscribed cal in settings. When subscribing to a cal the I device auto assigns the next available colour. Even though you can manually change it it changes itself back when the cal syncs. As I use a number of cals I change the colours of my existing calendars leaving only the colour I want available for the subscribed Calender. Then subscribe to the Calender and the the colour remaining is picked as default for the subscribed cal. Then change your other cal colours back. This sorted it for me.


    Come on Apple. It should just work. Simple.

  • Atwixtor Level 1 Level 1

    webweasel's workaround is perfect, though it does require at least 8 calendars depending on what color you want your target subscriptions to be, and a bit of trial and error.


    However, in this workaround, hiding the subscriptions in the Calendar app does not hide items from the "dummy" or "filler" subscriptions in the Notification Center.


    To also hide them in the Notification center without completely disabling them in Settings, I've found that if you used dummy subscriptions from, just go into Settings > Mail, Contacts, Calendars > Subscribed Calendars and enable (turn on) the following for each dummy subscription:


    • Remove Alarms

    • Use SSL


    This essentially "breaks" the connection with these subscriptions by forcing incorrect validation. You then want to say "Yes I know this won't work" or "Cancel" when it asks you to try connecting without SSL. Then hit Done and Save after the blue pop-ups are done.


    Go back to the Calendar app, go to edit calendars, wait for the spinner in the iPhone's activity bar to stop spinning (trying to connect to those dummy subscriptions), and then hide those dummy calendars again (the above process with SSL makes them visible again).


    Voila. Completely hiding the dummy calendars from both the Calendar app, Badges, and Notification center, while continuing this workaround to get proper colors.

  • Default User Level 1 Level 1

    Bumping this up. I cannot believe Apple still has not fixed this yet.

  • zefrey Level 1 Level 1

    Apple, you out there?? FIX THIS!

Previous 1 2 3 4 Next