4 Replies Latest reply: Dec 17, 2011 3:24 AM by meuser
cbosel Level 1 Level 1 (0 points)

hi folks,

 

when i upgraded my iphone 4 to ios5 i noticed that opening settings > general > usage makes the settings app crash after a few seconds of loading. after switching to an iphone 4s and "restoring" the iphone 4 data into the new device, the bug was gone.

 

now i made the mistake and opened that usage tab while i was installing software (yes, *** hoc ergo propter hoc, but i don't have any better guess what could have caused it) and the settings app crashed and kept crashing ever since. i tried to deinstall the software i was loading at the time of the first 4s-crash. i tried restarting the iphone. nothing works so far.

 

this really annoys me because i'm using that tab a lot to check for data usage. is there anything known on that issue?

 

greets,

Christoph


iPhone 4S, iOS 5
  • cbosel Level 1 Level 1 (0 points)

    me again, answering my own question.

     

    it seems that the settings app has problems calculating the size of audiobooks not bought from itunes. i had some podcasts labeled as "audiobooks" in my library and after removing these from the phone, the usage tab works without crashing. other people had similar experiences, so it seems that removing audiobooks from your library seems to be a workaround (or at least some good starting point) to avoid this bug.

  • Sean Hoyt Level 1 Level 1 (5 points)

    I just wanted to say that was a tremendous find! I was having the same probablem. Hopefully they'll get it figured out in a future update.

  • iMJiM Level 1 Level 1 (0 points)

    Also having problem with Settings crashing shortly after I open it, usually on my way to check Usage, but often crashes before I get to that point.  Usually crashes on first try after not opening Settings for a period of time, good on second try.  More annoying than anything.  Started after upgrade to iOS 5, and continues with 5.0.1 on iPad2 w/3G.

  • meuser Level 1 Level 1 (0 points)

    The audiobook is the trouble maker.

    But how do you make it work?

     

    I had the same problem with a self-ripped audio book (from CD).

    I got one audio book to work, if I add a second one it still crashes,

    but maybe this is a start:

     

     

    Here is what I did to make it work:

    Step 1. Convert all the AAC files to "Spoken Content"

     

    Step 2. Renamed all the ".m4a" files to ".m4b"

    (Finder or in Terminal you use: for FILE in *.m4a;do mv "${FILE}" "${FILE%.m4a}.m4b";done)

     

    Step 3. Ensure that in iTunes, the Audio Book shows up in the "Book/Audio Books" section, and under "File/Get Info (Apple-I)", "Options", "Media Type" is set to "Audio Book".

     


    Now it works with one audio book on my iPhone.

    If I add a second with the same method, it still crashes. Any ideas?