11 Replies Latest reply: Oct 29, 2011 10:50 PM by The_Claff
The_Claff Level 1 Level 1 (5 points)

I have Apple TV 2.0 and have shared my home library, but this week it stopped playing movies and TV shows.  When i select one from the Computers section and then my home library, I just get the spinning wait icon and the movie never plays.  Music from the same library/computer as well as photos work fine.


Windows PC, Windows XP Pro
  • 1. Re: movies won't play from library
    askhollib Level 1 Level 1 (0 points)

    I have the EXACT same issue and this just started happening to me. I was playing my Apple TV2 yesterday with no problem, but this evening I was unable to play any videos. I thought I needed to update my Apple TV, so I did. Then it updated and reset itself a second time. After that, I could play my music from my library but not the videos. I'll check this thread to see if you get a response.

     

    Best of luck.

  • 2. Re: movies won't play from library
    drjkoo Level 1 Level 1 (0 points)

    I'm having a similar issue.  I have the spinning circle too, but literally 5 minutes later, it then gives me the option to play the movie.  At least there are several of us having the same issue and I am wondering if it is something more global to Apple TV2.

  • 3. Re: movies won't play from library
    Brian in long Valley Level 1 Level 1 (10 points)

    I'm having the same problem after my Apple TV completed a firmware update this evening.  All I see is the spining circle, when I try and load content from iTunes.

  • 4. Re: movies won't play from library
    Thaddeusf Level 1 Level 1 (0 points)

    So I just have to ask - did all of us download a certain 'part 2' movie when this started?  This was exactly when it happened to me.

  • 5. Re: movies won't play from library
    Honda77 Level 1 Level 1 (0 points)

    Same problem here. Movies in library and iTunes purchased videos won't play. Just get the spinning circle. Netflix, YouTube, music from the same hard drive and AirPlay all work normaly. I restored the apple tv and updated my iMac. Restarted my iMac, wireless router and apple tv. No luck. I was playing a episode of a tv show I have on my hard drive. When I finished one and selected the next it wouldnt play. HELP PLEASE!!

  • 6. Re: movies won't play from library
    AucklandMac Level 1 Level 1 (0 points)

    I am having the same problem also and after restoring via itunes still no change. 

     

    Does anyone know if Apple have recognized it as a bug in their software update yet ?

  • 7. Re: movies won't play from library
    lukefromscottsdale Level 1 Level 1 (0 points)

    This has been a problem in the past.  Last time it occured is when Apple did an update for iCloud.  Apple doesn't like to let their customers know when they screw something up, so I am sure it will probably work in the next day or so.  Before it was an authentication server issue.

  • 8. Re: movies won't play from library
    Honda77 Level 1 Level 1 (0 points)

    I just turned off home sharing on my iMac and turned it back on. Now it's working again. Don't know if it's just a coincidence or not. I'm back in business.

  • 9. Re: movies won't play from library
    Thaddeusf Level 1 Level 1 (0 points)

    I have changed the settings in iTunes to play on AppleTV (lower right option in the iTunes screen) and then I am able to start the movie in iTunes and it will start playing on the AppleTV.  Interestingly, once it starts playing I am able to use the AppleTV remote just as normal.

     

    Something is happening in iTunes which is causing the responsiveness to be quite poor.

     

    The host system is a Win7 64-bit, 6-core, 8Gb high-end system.  Both the PC and AppleTV are using wireless (802.11n). 

     

    This seemed to start when the number of movies in my library increased to over 110.

     

    It does seem a bit like an iTunes bug, doesn't it?  Would a network trace help?

  • 10. Re: movies won't play from library
    AucklandMac Level 1 Level 1 (0 points)

    After resetting everything sometime after 7pm NZ time things seem to be back up and running.

  • 11. Re: movies won't play from library
    The_Claff Level 1 Level 1 (5 points)

    And now tonight it worked. Makes no sense at all, and the update resetting all passwords etc is frustrating. I wish there was more communication from Apple since it clearly is tied to their end somehow.