Skip navigation

IOStorageFamily.kext issue

1420 Views 6 Replies Latest reply: Apr 3, 2013 3:58 PM by Jasper V.G. RSS
appleiser Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 28, 2011 10:03 PM

Hi all,

I recently attempted to change the icon for my hard drive. Instead of doing the copy and paste in the get info window, I had thought it would be a more thorough change if I modified the Internal.icns file within IOStorageFamily.kext (/System/Library/Extensions/IOStorageFamily.kext/Contents/Resources/Internal.ic ns I think). It all went fine replacing that icon until I tried plugging in a USB stick. I got an error message:

After two reboots, I got the same error message two more times when I plugged in a USB device. The USB doesn't show up in Finder or Disk Utility but it does register in system profiler when it is connected.

 

Luckily I had a backup of the original Internal.icns file so I replaced that, rebooted and now everything works fine. I have since just done the copy and paste in the get info window.

 

So can anyone tell me what was wrong with what I did to cause the error? Many places on the internet advised that replacing the Internal.icns file was the way to go for changing the icon, although I know they aren't always right? What should I have done differently and what actually screwed things up?

 

Cheers.

MacBook, Mac OS X (10.6.8)
  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Oct 28, 2011 10:29 PM (in response to appleiser)

    I don't know where you read such "informed" info but the proper way was to copy/paste the icon in the finder get info window.  You should never tinker with the apple provided drivers (kexts) and I guess now you know what can happen if you do.

     

    You most likely got the kext cache out of sync probably along with the finder realted cache(s).  Also, that kext is code signed.  That alone was enough to screw it up (see reference link).

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Oct 28, 2011 10:30 PM (in response to appleiser)

    See my updated reply above (re: code signed).

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Oct 28, 2011 10:43 PM (in response to appleiser)

    If candybar is actually doing that then IMO consider it malware (a) for the reason I stated earlier about no one (or thing) should be tampering with apple provided software and (b) if apple ever updates the system with an update for that kext then it will be replaced with the apple updated kext thus invaliding the previous edit.

     

    Code can easily recompute a bundle's code signature so if candybar is screwing around with the kext it could just update the code signing.  It wouldn't be the first time some 3rd party utility did such a thing.  I believe there's one that changes the appearance of OSX by changing a whole bunch of OS X stuff.  It think's it's kosher because it has an uninstaller that puts back the original stuff it clobbered.  Pretty insidious IMO.  Maybe candybar is doing the same kind of crap.  But in both these cases it won't get around a apple system wide update that potentially could revert the stuff these utilities clobbered.

  • Jasper V.G. Calculating status...
    Currently Being Moderated
    Apr 3, 2013 3:58 PM (in response to appleiser)

    Hi,

     

    (At first I want to say that my English is not that good, so there may be some faults in this anser.)

     

     

    I had the same problem when i did the same thing as you did.

    I changed some icons (so it would change all the drive's icons instead of one "via get info..."), and got the same issue.

    After I searched for the solution on how to reinstall the .kext, I came up with this site.

    http://ihackintosh.blogspot.be/2008/09/how-to-install-kext-file-on-osx86.html

     

    after following the steps, it fixed my problem, but the only down thing about this is that you need to have a backup (eg. a Time Machine Backup) to get the "IOStorageFamily.kext" file from before you made the change.

     

    I provide you with my .kext file. (I do not know if this will work for other machines yes or no, but I think is is the same for all Macs.)    I would first try with your own backed up file.

    I have a rMBP 15" with OSX 10.8.3 in case.

    -->https://www.dropbox.com/s/5fp9y56u5f245qf/IOStorageFamily.kext.zip<--

     

    I hope this will fix your problem.

     

     

    Grtz,

    Jasper

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.