Previous 1 2 Next 19 Replies Latest reply: Oct 1, 2013 5:56 PM by WOHSS
GigiDeLuxe Level 1 Level 1 (0 points)

I have wi-fi in my home (and the password) but my phone still won't connect

iPhone 4
  • mezzopoet Level 1 Level 1 (0 points)

    I am having the same problem. Everything was fine from the time I got my phone several months ago till last week when all of a sudden my iphone will not connect to my ATT Uverse wifi service at home. The laptop is fine and the other iphones in the house connect with no problem. ATT said the problem is not on their end because the laptop and other phones are connecting to the wifi and this makes sense to me. They are sending me a new gateway anyway to see if that helps. I appreciate that effort. At the Apple store the genius bar rep told me that since my phone is connecting to the wifi elsewhere, other than at home, (though I need to check this out), the problem can't be with the phone. I'm reading online that lots of iphone users are having this same issue at the moment with not connecting to the home wifi. The rep said iphone users are always having issues and most problems are user related rather than equipment related. When I said I'd been having some equipment problems of late (hard drive and logic board replaced in an 18 month old laptop) he told me how many hard drives he's had replaced as well as other repairs. I must say, I didn't really feel heard. All the settings were reset, however, and I was hopeful with a few tips he gave me that the situation would be better at home but it is not. It's very frustrating. In certain parts of the house the phone can connect to the 3G network and in other spots it cannot. I can't get any service (or extremely slow 3G service) from the places in the house where I normally use the phone with no problem. My empathy for what you're experiencing....

  • calimj Level 1 Level 1 (0 points)

    I thought I would chime in.  I also cannot get my iPhone 4 to connect to any wifi.  I've been on other message boards where people are having problems with only their home wifi.  I have that problem, too.  But, it's not just home wifi.  Ever since I upgraded to IOS5, can't connect to any wifi.  My phone will recognize the networks, but when I try to sign-on (with correct password), I keep getting the same message (unable to join network).  I've tried things others have recommended (forget this network, airplane mode on/off) with no luck.


    Has any one found a solution?

  • GigiDeLuxe Level 1 Level 1 (0 points)

    I solved the problem-YAY!  I had to re-install my router, then I was able to re-enter the default key for my wi-fi and my Netflix (wii) and iphone.  I use Linksys as my router btw and they have a great step by step guide online. Go to settings on your iphone, choose your wi-fi network, you want to configure this yourself so choose "Manual" and enter the "KEY" not the password- I hope this helps, it much easier to do it than to explain it but it's totally easy once you know what to do

  • Rational Beef Level 1 Level 1 (0 points)



    Possibly this will help -  worth a try.


    I had an issue with my daughters iPhone 4 and my Netgear router.  Put correct MAC address into the router, chose correct authentication WPA2-PSK into iPhone and correct passphrase - result "Cannot join network" message.  Tried everything & eventually gave up.


    I bought a 4s - same issue.  Both phones could see the network - I could even get the router's web page OK, but nothing beyond that.  Turned security OFF on the router, both iPhones could then join, turned security back on and they are still connecting.  To join went in manually with "other" network & set the SSID, security and passphrase that way.


    Give this a try - it might possibly work.



  • Kenny168 Level 1 Level 1 (0 points)

    Yessss! Problem solved. I turned on airplane mode and turn on wifi, select network, enter password and voila! The iphone picked up the wifi. Turned off airplane mode and revert to 3G. Wifi remained connected.

    Hope this helps.

  • cveraflor Level 1 Level 1 (0 points)

    I have Uverse as well. I can't get it to connect although it says it is. I checked the Advanced Settings and still can't figure it out. Att wants to charge me a fee to discuss the issue with their "Advanced Settings Team". Yeah right. I am going to try Apple Care. I think this has a lot to do with my Uverse because I can connect everywhere else. Very frustrating!!!!

  • ben_singapore Level 1 Level 1 (0 points)

    hi guys, I am using iPhone 4 and iPhone 4S at the moment.  facing the same problems like all the users here, good wifi at work, cafe, tapping from neighbours, etc but cannot connect at home. well, I managed to fix this issue last night with help of a fren after some try and errors.  I am using linksys WRT54G and a ADSL modem.


    plug your router to your notebook without connecting the your modem. goto setup by keying in, user and password is admin.


    make sure that your router ip is not the same as your modem ip.  for my instance I key in as my router ip.


    thats it, it works for my iphone 4/iOS 5 and iphone 4S/iOS5.0.1.


    after 2 months struggle finally the battle for me is over.


    give it a shot !

  • Michael JCM Level 1 Level 1 (0 points)

    Fine for home wifi but my iPhone 4 iOS5.0.1 has the same issue when trying to connect to wifi networks when travelling (hotels, friends house, etc...) and therefore without access to the router.


    I even had the case in a hotel where another person had the same iPhone an iOS .... his worked fine and mine could not connect !!!


    I have restarted various time the iPhone, reseted network settings to no avail


    Any ideas ?


    Thanks !

  • Lawrence Finch Level 7 Level 7 (33,370 points)

    Hotels and other WiFi hotspots require you to log in before using their networks. After connecting open Safari and enter any URL; it will redirect to the sign in page for the site.

  • LauraBme331 Level 1 Level 1 (0 points)

    Thank You I have netgear and I am going to try your suggestion when I get home hopefully it works

  • LauraBme331 Level 1 Level 1 (0 points)

    I am having the same problem as everyone one this discussion I made an appt to go to the genius bar for later today . Should I not go and just try some of the suggestions people put up

  • Sk8Dreams Level 3 Level 3 (855 points)

    ben_singapore - Your problem was due to your modem and router having the same IP address.  You could have had the same problem with any device you tried to connect via wifi, and is not related to the iPhone.

  • JohnPatrick Level 1 Level 1 (5 points)

    Yes ATt 's Uverse is the problem. Just make the password the same number as the router modem and you are good to go.

  • AlexandraTosh Level 1 Level 1 (0 points)

    Worked perfectly. Nice and simple too :-) Xx

Previous 1 2 Next