Previous 1 2 Next 19 Replies Latest reply: Oct 24, 2015 1:56 PM by bogie5371
RJ in AZ Level 1 (0 points)

cd stuck and will NOT eject


iMac, Mac OS X (10.6.8)
  • David JD Level 2 (390 points)

    Not even if you restart while holding mouse button down?.

  • Reecej88 Level 1 (0 points)

    Restart the computer and as soon as it powers up, hold the eject key on the keyboard. If this doesnt work then:

     

    Go to Appliactions, Utilities, then Disk Utility. The CD should be displayed in the panel on the left hadn side, Select it and click the 'Eject' button at the top (or right click the CD and click eject)

     

    Reece

  • simonfromlasalle Level 1 (0 points)

    Here is a compilation of suggestions that I have found for what to do when the CD won't eject (most didn't work for me).

     

    1) If it is mounted, open Disk Utility (in Applications --> Utilities) and eject from there

    2) Restart holding the eject button

    3) Restart holding down mouse button

    4) Restart holding down Command-Option-O-F to open Open Firmware.  When it opens, type "eject CD" without quotes and then "mac-boot".

    5) Open Terminal and type "drutil eject".

     

    The only thing that worked for me was #5 with the computer physically laying screen down on my desk.  It turned out that the paper label on my CD was peeled off at the corner and couldn't physical eject.  It seems that positioning the computer differently must have enabled the ejection mechanism to work more effectively.

     

    I  have an Intel based iMac.

  • monireh Level 1 (0 points)

    Yes!  The finder does not open either. So, I can't go to applications/utilities and eject from there. 

  • simonfromlasalle Level 1 (0 points)

    Why not do a hard reboot by holding down the power button or pulling the plug.

  • sdpitbull Level 3 (965 points)

    Never put a paper label CD in a slot loading drive. You were lucky you got it back out this time.

  • simonfromlasalle Level 1 (0 points)

    Yeah, that is something I learned the hard way.  I didn't even look at the label until I took it out.

  • RJ in AZ Level 1 (0 points)

    I've tried all the ideas, still the cd/dvd will not come out. is there something that I need to reset? this is getting scary.

  • sdpitbull Level 3 (965 points)

    RJ I think you will have to take the machine to the Apple Store if steps 1-5 above do not work. Sorry.

  • RJ in AZ Level 1 (0 points)

    Man!!!! that's not what I wanted to hear. I'll try them all one more time. Thank you....................................................

     

     

     

    Still looking for IDEAS       Please help.

  • Reece Johnson Level 1 (0 points)

    Here are some other ideas i found:

    shut computer down while holding the eject button on the wireless keyboard, turn computer on and it should eject.

     


    http://support.apple.com/kb/HT2285

     

    http://support.apple.com/kb/HT2801

     

    Reece

  • afromgreenwich Level 1 (0 points)

    Same problem, here.

     

    drutil eject

    holding down at setup

    ejecting from anywhere

    paper clips

    credit cards

    F12

    holding at angles

     

    ...all useless!

     

    I have tried EVERYTHING posted on youtube and on here about getting the disk out short of taking off the actual shell and, very frustratingly, nothing works. I am loathe to take my heavy imac on public transport twice and paying just to get a cd out.

     

    A lot of people seem to have this problem.

  • Melanie S Level 1 (5 points)

    Thank you! I had this problem and the Disk Utilities eject worked.

  • boscojones Level 1 (0 points)

    I turned my macbook pro upside down when I restarted and held the eject key and it worked.  I had the problem with my imac and fussed with it for an hour. Finally shut it down and started it the next day and it popped right out. It's worth fussing and even waiting a bit before heading to Apple repair .

Previous 1 2 Next