Previous 1 2 Next 16 Replies Latest reply: Oct 31, 2011 10:16 AM by SGKoeh
SGKoeh Level 1 (10 points)

I am in process of creating a site with iWeb on MacBook but want to continue working on it with my iMac. Both Lion OS. Copied folder from MacBook to iMac via flash drive but now can't figure out how to access it with iWeb.  From iMac, when I open iWeb, it wants me to create a new site. Haven't published it yet, and not ready to.  So, how can I access what I've started from the iMac?

iPhone 4, Mac OS X (10.6.8)
  • SGKoeh Level 1 (10 points)

    By the way, tried following instruction on but Lion OS has changed the Finder and I can't find User Library.  I can get as far as Application Support in the Shared Library but iWeb is not there.

  • Roddy Level 6 (17,265 points)

    iWeb stores the data in a Domain.sites2 file whose default location is Home Folder/Library/Application Support/iWeb. Move this to the equivalent location on the new Mac.


    There are a couple of things different about running iWeb on Lion. See this page under "iWeb & Lion OS X 10.7"...


  • QuickTimeKirk Level 9 (51,815 points)

    Did you copy the Domain.sites2 file from your other machine to the flash drive? That is the first step. It is not a "folder" as you state in your second sentence.

  • Old Toad Level 10 (133,300 points)

    In Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.


    For opening your domain file in Lion for the first time or to switch between multiple domain files  Cyclosaurus has provided us with the following script that you can make into an Applescript application with Script Editor. Open Script Editor, copy and paste the script below into Script Editor's window and save as an application.


    Just launch the application, find and select the domain file you want to open and it will open with iWeb. It modifies the iWeb preference file each time it's launched so one can switch between domain files.


    do shell script "/usr/bin/defaults write iWebDefaultsDocumentPath -boolean no"

    delay 1

    tell application "iWeb" to activate


    You can download an already compiled version with this link: iWeb Switch Domain.


    WARNING: iWeb Switch Domain will overwrite an existing Domain.sites2 file if you select to create a new domain in the same folder.  So rename your domain files once they've been created to something other than the default name.



  • SGKoeh Level 1 (10 points)

    Yes, I did.  And now I can open it from the new computer but can't save it.  I get "Couldn\U2019t create file" error message.  I'm wondering if it's looking to save it to the flash drive which I've removed?  I'd prefer to now save to local file on new computer, or access it through domain.sites, either way.


    I've noticed Old Toad says there's no way to import to iWeb -- is that what I'm encountering here?

  • SGKoeh Level 1 (10 points)

    Thanks for all the help - and I'm getting close.  I can now open my site on the new computer but when I try to save it, I'm receiving an error "Couldn\U2019t create file".  I have changed the Site Publishing Settings to save to local folder on the new computer but that doesn't seem to be working.  I closed iWeb without saving.


    Next I tried opening iWeb both from the Applications-iWeb, as well as from Domain.sites2 in Application Support-iWeb.  Opening from iWeb, it is asking me to choose a template (start from scratch).  From the Domain.sites2, same thing...."Choose a Template".


    Finally, I put the flash drive in that I'd used to get the site I was working on from the original computer I was using to create, over to the computer I wish to continue on (both OS Lion).  Click to open my site from the flash drive and again, it's asking me to "Choose a Template".


    Is this the issue you mention on your help page re: importing to iWeb not being possible?  It seems if I'm creating an iWeb file, I should be able to save it, and copy it to and/or open it from any computer with iWeb on it.

  • QuickTimeKirk Level 9 (51,815 points)

    We are not trying to "import". The Domain.sites2 is the only proper method to "move" iWeb data between machines or locations.

    I suspect the flash drive is corrupting the special "package". Domain.sites2 ia really just a special folder.

    Go back to the source machine and navigate to the Domain.sites2 file via the Finder.

    Control click (right click) and choose "Compress Domain...". This will append .zip to the file extension. Copy this .zip file to the flash drive and move it to the other machine.

    Once in its proper place double click to "expand" the .zip file.

  • SGKoeh Level 1 (10 points)

    Old Toad -


    I'm also wondering if my problem could be solved by what you mention with Script Editor.  This looks like serious stuff I'm afraid to touch without being certain.


    I found Apple Script Editor in Applications - Utilities.


    It opens a page "untitled".  Is this where you want me to enter "/usr/bin/defaults write iWebDefaultsDocumentPath -boolean noz" ? 


    I'm not familiar with "shell script" .... would you mind clarifying before I really mess something up with the scripts?  Thank you!

  • SGKoeh Level 1 (10 points)

    QuickTimeKirk -


    I'm afraid I am getting the same results.  To be sure, here is what I did:


    1. From source machine, Finder-Library-Application Support - iWeb (using the Option key with Finder's Go menu -- I don't have Library set to be visible on either computer) I right clicked my DomainFile and compressed it, the dragged the .zip file to the flash drive.


    2.  On new machine, from the flash drive I dragged the .zip file to the desktop, then opened Finder, same method as in 1. above.  Dragged the .zip from Desktop into Finder-Library-Application Support - iWeb.


    When I double-click the .zip, it expands, creating a file with same name, appended with a "2" (I've renamed my domain file so as to keep separate from other Domain files in the future). 


    Double-clicking the expanded file opens iWeb and asks me to choose a template.  


    ~ Gina

  • QuickTimeKirk Level 9 (51,815 points)

    Use the Finder while the file is still on the Desktop to "Expand" the .zip file. It should not apppend a "2" to the file.

    Drag this to the iWeb folder and "replace", when prompted, the older version.

  • Roddy Level 6 (17,265 points)

    Go to this page and look under "iWeb & Lion OS X 10.7", click on the link to download and follow the instructions to open your Domain.sites2 file...


  • SGKoeh Level 1 (10 points)

    I'm sorry, Roddy -- I've been trying to follow the instructions but no luck.  I have saved the domain from the source computer to a CD, and can open on the new computer but I can not save it.  It's running from the CD, not from the computer so if I eject the CD, I can no longer open the domain.  I can create and save a domain created on the new computer, I just can't seem to put a copy of another domain on the new computer and save it.

  • Old Toad Level 10 (133,300 points)

    Have you repaired disk permissions recently?  If not give it a try. I had some items not work properly after upgrading to Lion and a repair of disk permissions fixed it.  Worth a try.

  • SGKoeh Level 1 (10 points)

    QuickTimeKirk -


    No luck.  But to clarify -- it's adding a number to the file name each additional time I try to expand the .zip file. The first time I double clicked the .zip it didn't add number to file name.


    I have now tried burning the domain from the source computer on to a CD, and can open the domain from the CD on the new computer however, I can not save it to the new computer after I make changes to the site.  It's running from the CD, not from the computer --  if I eject the CD, I can no longer open the domain.


    By the way, though I'm not trying to work with multiple domains, as a test to insure iWeb is working on the new computer, I opened iWeb from the dock, created, and saved a new domain. No problems there. I just can't seem to put a copy of the domain created on one computer on the new computer and save it to continue working on, saving, and eventual publishing to URL.

Previous 1 2 Next