10 Replies Latest reply: Oct 31, 2011 3:47 AM by nick101
kLy Level 1 Level 1 (0 points)

Seems like there isn't a way for me to turn off the new mail notifications in IOS5.

 

I go into notification settings for Mail and turn off absolutely everything, but still when mails come in in the middle of the night my phone vibrates and goes "bong!", waking me up (even tho there isn't a notification any screen or badge icon, the sound and vibrate still comes through).

 

I know I can set my iCloud settings to manual rather than push, but I *do* want to get everything else pushed to me (calendars, contacts, etc.), just not mail and there doesn't seem to be distinct settings for each service, it's all or nothing.

 

Currently the only way I've been able to disable the mail notifications is force quitting mail. That works, however it's something that's very easy to forget.

 

Anyone else have an issle with this?

 

Thx!


iPhone 4, iOS 5
  • nick101 Level 5 Level 5 (4,690 points)

    Have you done Settings, Sounds, and turned off the sound for mail? And you might want to switch Vibrate to Off, same screen.

  • kLy Level 1 Level 1 (0 points)

    I know I can disable the audio and vibrate, but that seems to be working around the issue. Firstly, I don't want to disable vibrate. I like vibrate as it is and it's useful for many other things. And I don't want new mails to come in by themselves at all, eating up data and battery cycles.

     

    I hope there is a way to tell iOS5: just stop giving me new mail in the background, I'm not interested.

     

    Thx

  • nick101 Level 5 Level 5 (4,690 points)

    Ah - I see what you mean.

     

    The only way to get this is to turn off Push and, as you said in your first post, that's all or nothing.

     

    Sorry

  • Morituri Level 1 Level 1 (50 points)

    So, under Settings, Notifications, you move Mail down to Not In Notification Center?

     

    If I do this, I get no mail notifications at all, no audible alerts and nothing on the screen.

  • kLy Level 1 Level 1 (0 points)

    Yes, it's in "Not in notification Centre" and in fact I've made sure to turn off absolutely everything in its notification page, but I do still get the audio and vibrates for new mail

     

    I wonder what the difference is. Are you using push mail?

  • Morituri Level 1 Level 1 (50 points)

    I have both Push and Fetch mail accounts.

     

    I am using a 4S, set up as a new phone though.

     

    Maybe if you upgraded your OS, for some reason it doesn't honour the Notification Center.

     

    It is a pain in the proverbial, but can you do a complete reset of your phone and then add back the mail accounts. You really shouldn't have to but it might be the only way. Depends how important your need is.

  • nick101 Level 5 Level 5 (4,690 points)

    The issue is, I think that there are two separate mechanisms at work here.

     

    The Notification Center handles the new notifications UI, and if Mail is "not in", no mails will appear there.

     

    The Mail app itself has its own in-built-mechanism. If you have anything set up for it in Sounds, it'll honour that setting, regardless of Notifications.

     

    But, as we can now see, it's not just the noise the OP wants to control, it's the actual polling for mails, with to consequent network activity and battery drain.

     

    You can have both Push and Fetch accounts (I do too), but if an account is Push (suhc as iCloud), then *all* the data for that accpount is Push. The OP would like his Calendar and Contacts data top be Push and his Mail data to be Fetch (or manual). That's the separation that doesn't exist at present.

     

    Hope that makes sense

  • Morituri Level 1 Level 1 (50 points)

    Nick101 is correct, there is no way of turning off mail collection on a timed basis. The only thing you can do is set all the accounts to Manual mail collection when you go to bed and back to the previous setting when you get up.

  • kLy Level 1 Level 1 (0 points)

    Yes I think Nick has hit the nail on the head here. There's no way to separate the two. Previously in iOS4 and MobileMe, you did have this option.

     

    Seems like the only thing to do OOTB is to either manually kill mail or manually disable the account.

     

    What I will try do is turn iCloud mail to "Off", then add a separate mail account with IMAP and manually enter iCloud server settings, then set this separate account to manual mail fetching rather than push. Hopefully Apple hasn't put in some "clever" thing that tries to detect this and redirect you to the standard iCloud account setup.

  • nick101 Level 5 Level 5 (4,690 points)

    That should work - it's how you get a non-iOS5 phone to get iCloud mail.

     

    You might have a little trouble working out the server name. There are various ideas about this arund the web if you Goolge something like "iCloud mail iOS4"