Previous 1 2 3 Next 38 Replies Latest reply: Oct 29, 2012 3:48 PM by seeder.sam Go to original post
  • vincent449 Level 1 (0 points)

    Apple store replacend my wife's phone this morning after genius review - still feel like it's a bug not a hardware failure -  will skip upgrade to 5.01

  • tankie Level 1 (0 points)

    FIX: i had the same problem on my Iphone 4 os5.01, extremely frustrating. pressing the volume buttons just made "Ringer" appear on the screen and there was no volume control when playing music. Turns out there was some dust in the dock connector on the bottom.


    I just powered it down then gave the dock connector a clean ( i actually used a clean toothbrush) just a couple of brushes over the contacts. Powered it on again and it worked fine. Guess a bit of contaminant was shorting out some contacts letting the iphone think an accessory was connected.


    Wish i had done this before doing a complete factory restore. oh well.

  • wcs2 Level 1 (0 points)

    same problem discussed in this thread

  • tomfrombrockworth Level 1 (0 points)

    There was no change after an update to iOS 5.01, so took it to the Genius bar last night and it was replaced with a new 4S after an attempt to restore the software.  iCloud back-up restored it in the store, and was back to exactly the same as my old phone, right down to the pages open in Safari & position in the document I was halfway through reading in Instapaper. 


    I'm still convinced it's a software bug, but won't grumble with a new phone!

  • scousky Level 1 (0 points)

    thanks tankie!!!! was about to call apple but gave this trick a go....WORKED A BLOODY CHARM! get a toothbrush and give the docking part of iphone a decent scrub!!!

  • jlp06f Level 1 (0 points)

    I GOT IT TO WORK! I was having the same exact issue.


    Sound would only work when I had my headphones on. Once I pulled the headphones out, my volume bar would go away and I couldn't get itunes to play out of my speakers. I took a air pressure can for dust and blew it in the headphone and docking jack.... VIOLA!!!!!!!!!!!!! Now it works perfectly.



  • Revan Level 1 (0 points)

    I had exactly the same problem, all of a sudden no volume control when I wasn't using headphones but the ringer would still work. After trying several resets and restarts still did not work until I was trying to drain the battery by watching a video, I went to settings and changed the brightness to full so the battery would run down quicker and all of a sudden the volume control was back :) I have no idea why but it did. I just hope it dont go again. Hope this helps.

  • high time Level 1 (0 points)

    i tried cleaning with a toothbrush as well worked when i turn on the phone i no longer get the disapearing volume control  . thanks for the suggestion..

  • srode1000 Level 1 (15 points)

    Hi Guys,


    I have post eariler on another forum and I have the same problem, I have tried all the things listed here and nothing was perminant in fixing this painful iphone hating problem.... and failed.  You probably have the problem when you use youtube or your music external speaker that there is no volume bar and no sound.   I have had the same problem But I need to happily say that I now have the fix!!!!  This worked for me and I fixed it by myself so you don't need to go to apple or service centre or anything.


    Ok I like so many of you here truly believed this was as IO5 issue as it only dropped the sound on the speakers once that IO5 update came along.  I tried a bunch of reset, reboots, home clicks, lock and unlocks, to fix this and all failed.  some worked for an hour but then failed.  hours of my life that I will never get back.   but since I have learnt this is not a IO5 problem but a hardware issue! ...  and in paticualar is has to do with your bottom connection.  Your phone is thinking it is docked all the time.


    To fix the no sound problem what you need is...


    1.  a torch

    2.  a tooth brush

    3.  methalated spirits

    4. a butter knife


    Step 1.


    get your torch and shine it down the bottom connection plate to see what kind of dust, sand, hair or anything you have stuck in there.   all that need to be removed!  everything!  it might look clean but still thats ok go to step 2.


    step 2.


    Turn on your music app and put the speakers on!  If your phone is like mine it should not work.  you most probably don't even have the volume display to turn it on but its ok, just do it! and it should still play with no sound.   its important you try and run the speakers as this will show you that it is a hardware problem.


    step 3.


    Dip your tooth brush into some methated sprits.   then at your sink tap the exess metho out of your brush as you just want the brushes to be slightly damp, not soaking wet and then scrub the bottom connetiors on your iphone.  work the brush back and forward in a way that scoops the dirt out of the phone, not just pushing it side to side.


    (As you bushing you should notice the volume bar come back on or off as you scub.   This happened to me and that is how I realised I was on the right track to fixing this problem as I was doing something external that was actually controling when the volume display came on or off.   but once I cleaned it this still didn't fix the problem...)


    Step 4.


    Use the back side of a butter knife (not the sharp side) to gently slide over the connectors on the iphone.  Do this gently as you are only pushing down on the tiny metal contect bars and you should notice the volume display come on again.  slide it back and forward.  Now the area of interest is about 2/3 along the connection plate to the right.   This is the area that has the infomation sent when your iphone thinks its docked.


    This has worked for me and I have not had a problem since I did this 2 weeks ago.   I have since learnt that the new IOS 5 has activated a different part of the bottom conectors.  if you have been using dodgy connectors or unapproved apple cables (as I was)  any damage or hair and dirt on the terminal this is effecting it.  Try it.   just remember if you can do something external to your phone then there lies the problem.


    Hope this works for your phone as it did for mine.



  • mszelog Level 1 (0 points)

    My IP4 which has had the newest update for months started doing the same thing about one week ago.  The volume control just dissapeared and I couldn't hear incoming texts and didn't have audio with videos and music unless it was docked or the headphones were in. I tried  to power off/restore with no help. I called APPLE and for $30 they would answer my questions or I could drvie an hour away to the APPLE store!  So I decided to book a genius appointment, but suddenly the next day it worked!  About a week later it happened again!  This time it didn't come back on its own! I did a lot of researching on the internet and I found these possible problems (every site I saw said it wasn't the software). 


    1.  The IP4 thought my headphones were still in or...

    2.  The IP4 thought I was docked or..

    3.  The dock was dirty or the headphone jack was dirty


    I cleaned the headphone jack with a small cue tip and nothing.  I blew into the dock port and the volume reappeared for a few minutes, but kept going away.  Since the volume did reappear I figured I was on the right track.  I took a very small watch screwdriver and a tissue with a little water to clean it better.  Same result with the volume reappearing on and off.  So at this point I was very frustrated and made another genius appointment.  This morning I decided to try a little rubbing alcohol pad and pushed it in with a business card.  After a few minutes of gently washing the volume completely resotred!  It's been working all day and hopefully for good.  If it happens again I'm definitely going to see if I can get a new phone under warranty.  I'm really anal about taking good care of this phone and have never experienced this problem with my ipod or itouch.  I hope this suggestion helps other IP4 users!

  • ncs_ts Level 1 (0 points)

    my iphone 4 after I updated to ios 5 had no ringer, no music, no sound in apps,no keyboard clicks and only vibrated when I plugged it in my computer. however audio in you tube worked and I could change ring tones in the settings menu and it would play the ringtone, however the phone only vibrated when I would get a call.

      After messing with this thing for days.... I found a fix. IF YOU HAVE THE SAME PROBLEM AS ME THEN CHECK THIS OUT. I would post it here but it is a sh*tload of typing for me





    I posted my fix on the bottom of page 7. I hope this works for you all

  • joshIOShall Level 1 (0 points)

    hi im haviing a similar problem with my iphone 3GS i get no volume bar what so ever i dont get anything with headphones dockng stations or anything and this happened litrally after the update im quite annoyed as i do listen to alot of music on my phone



    basically the sliders for the volume have dissapeared in the music app i get no sound with apps and the only time i ever do get sound is wen someone rings me other than that nothing


    ive looked online everywear cant find anything that works i guess im hoping apple will pull there finger out with the next update if anyone does have any ideas on this problem other than cleaning the charge plug or the headphone jack please let me no asap as i dont think i can go much longer with out any music thank you

  • tankie Level 1 (0 points)

    hey joshIOShall that sounds very unfortunate. Usually the reason for the volume bar dissapearing is that the phone thinks an accessory is connected so it gives volume control to the accessory. Was the udpate done correcty? ie it wasnt interrupted or power cut out half way through? does there appear to be any damage to the dock connecter?

    Have you tried restoring from a backup in iTunes?


    How long after the update did the volume stop working?

    I take it this is after the iOS 5.0.1 update?


    You can try erasing your iphone ie restoring it back to factory settings (of course, saving a backup first). There are a couple of ways to do this, either from the iphone or via itunes (it may take a very long time using the iphone method). See if the volume works in this factory restored state without restoring from your personal backup, as this may restore some corrupted files. You can google how to do this or post back for specific instructions.


    However traditionally this fault is more associated with dust / corrosion around the physical connections.

  • Seçkin Level 1 (0 points)


    your tips are working. Thank you very much!