7 Replies Latest reply: Jun 18, 2012 6:48 PM by elenafromco
jayfromcentennial Level 1 Level 1

Every time I try to export a Final Cut Pro X project to youtube, share monitor pops open and then gives me the error message "codec not installed." I spent two hours today at the Apple Genius Bar, and it stumped the panel. Their final suggestion, which I just completed, was to delete the software, reinstall my system software (Snow Leopard), update the system software, then reinstall Final Cut Pro X. After another two hours of going through all that, guess what happened when I tried to export a project to youtube? Yep, "Codec not installed!" AAAAHHH! It exports to Quicktime OK, but the files end up being so huge, uploading them to youtube after that is implausible. Any suggestions out there? I guess I need to pop the extra $50 for Compressor?


Final Cut Pro X, Mac OS X (10.6.8)
  • Tom Wolsky Level 10 Level 10
    expertise.macosx
    Mac OS X

    When they reinstalled the OS did they erase the drive and start for a clean disk, or did they simply reinstall? QuickTime is not installing properly. The codec is H.264 and comes with QuickTime, unless there is a problem with the media in your project. What are the specs exactly? Nothing weird?

  • jayfromcentennial Level 1 Level 1

    Thanks for the shout. They didn't do the install there because I didn't have time. I reinstalled the system software myself. I didn't erase my disk because I didn't want to have to reload all my programs and files from an time machine backup and just reinstalled Snow Leopard, then updated it, then reinstalled the FCP X trial. I like the program OK, but it would be nice to figure out that it does what I want before dropping the $300, so I'm really glad they have the trial version. The video is just regular DV video from a sony camcorder. It imports fine and I can edit it fine. I can export it to quicktime OK, I just can't go directly to Facebook or Youtube.

  • jmedved Level 1 Level 1

    Happened to me as well.

    We got around it by exporting a smaller file size "apple tv" and then using the youtube uploder (site).

    Not pretty but it worked.

  • Brad Bechtel Level 1 Level 1

    Did you try installing the ProApps QuickTime codecs available through Software Update?

  • jayfromcentennial Level 1 Level 1

    Thanks for the shout Brad. I tried to download the most current ProApps codecs, but after I downloaded them, I couldn't install them because the installer said I already had more updated versions of the software installed. I'm a little concerned that I have something wrong with my system somehwere because I can't get iMovie 11 to work at all (freezes on "generating thumbnails" when I try to import from camera, and I also have iMovie HD (6.03) that won't work as after importing clips, they just show up as black screen with no audio or vidoe on playback. 

  • Navaar Level 1 Level 1

    If you have enough free disk space, or an external drive, install a completely new copy of the OS on that.  That way if it solves the problem, great, at least you'll know that'll fix it.  If it doesn't, then you haven't lost your primary installation.

  • elenafromco Level 1 Level 1

    Did any solutions work for you? I am having the same problem and I'm sure if I need two wipe my hd and reinstall everything again?