Previous 1 2 3 4 5 Next 62 Replies Latest reply: Jul 10, 2015 9:01 AM by foodsage Go to original post
  • aklick Level 1 Level 1 (0 points)

    This is a problem my husband and I have been having for a long time. Frankly I don't like iCloud at all. There are way to many buggs (like the fact that it uses a TON of data every midnight even though we are on wifi-we fixed that by turning off iCloud backups). Anyhow, thanks for the solution to the calendar issue.

  • AFear Level 1 Level 1 (0 points)

    I have this same exact problem as everyone else.  My primary AppleID is my gmail account and when my wife sends me calendar invites they dont show up.

     

    Apple please fix this.

  • aklick Level 1 Level 1 (0 points)

    There is a solution listed right in the thread. Here it is: Very quick and simple.

     

     

    In short go to https://www.icloud.com/

    sign in using your apple ID information

    Click on Calendar

    Click on the settings button in the upper right hand corner (looks like a cog)

    Click on preferences

    Click on advanced

    Uncheck "use icloud for incoming inviations"

     

    That will fix the issue. I'm not sure why apple doesn't fix this. It's as simple as them not coding "use icloud for incoming inviations". However it's also a very simple fix we can make.

     

     

    ************************************

     

     

    Okay, so I've found something:

     

    Until now, there have been many, many Apple product users who've created AppleIDs associated with external email accounts, including Gmail. Now that iCloud has been released, many of them have turned on portions of iCloud or perhaps gone so far as to create iCloud email addresses/aliases under their primary AppleID.

     

    Here's where it gets weird: there's a setting in iCloud calendar preferences turned on by default called "Use iCloud for incoming invitations". What this does is, if an invitation is sent to that primary AppleID (which is most often an external address) or its associated, newly-created iCloud address, it'll get routed to iCloud, preventing (blocking) the invite from being forwarded to that external address.

     

    For example, a user's primary, pre-iCloud AppleID is john1234@gmail.com. iCloud is opened to the public, he enables it on an iDevice or Lion OS X and it asks if him to enter his AppleID credentials (john1234@gmail.com) and asks if he wants to create an iCloud address, which he does, john1234@me.com.

     

    From now on, let's presume he's continuing to use his john1234@gmail.com account, because he's not really sure yet that he wants to make the switch to iCloud for email, etc. At this point, if another iCloud user sends him a calendar invite at his primary email,john1234@gmail.com, Apple has decided it'll route this invite directly to hisjohn1234@me.com iCloud alias, never letting it send out to his Gmail account.

     

    So, assuming he's not yet using iCloud email/alendar, he'll be clueless as to why he never received the invite OR, if he is using iCloud email/calendar alongside his primary Gmail account, he'll probably wonder how in the world an invite sent from a friend to his Gmail account is now showing up in his iCloud inbox/calendar.

     

    Why Apple's enabled this by default is beyond me. At this point, it's preventing me from going to iCloud full-time because I can't be sure invitees will get my calendar events!

  • djlucas Level 1 Level 1 (0 points)

    Thanks to all for their information. I spent a few hours on this last night and this is how I fixed my particular issue. To baseline, here is our setup: one iPhone 4 operating the latest official release and one New iPad (3rd generation whatever you call it) updated as well.

     

    My wife uses my Apple ID to get apps on her iPad and we added her gmail address to my profile so she could receive facetime calls and stuff on her device. My primary email and Apple ID is also a gmail address. To summarize when I look at my profile under Apple ID, I have three emails - my primary gmail, her gmail, and my newly created .me address (see below for the .me explanation)

     

    What I did not realize and ultimately what fixed our problem was that when setting up the phone, or even by enabling the cloud on my device, a ".me" address was not automatically created. Thus and very similar to folks on this and other threads, no matter how many times I added her to the invite list when making new entries, it would send nothing and when I went back to the event (close and re-open calendar), her name was gone. It suddenly made sense that because both of our email was on my Apple ID it would not work.

     

    Our fix happened after I completed setup of my ".me" iCould address. I know this sounds like an amazingly simple fix but it worked for us. I would say for all users having problems make sure you have a .me address set up through iCloud. It was free and took about a minute to configure.

     

    One downside that I noticed is that I have to now keep my iCloud email enabled on my phone or it will not send out new invites. Even though it is setup and configured (and gmail is still my primary), if I don't have it enabled under settings>mail, etc it will not send.

     

    The end result of this is that I can now send invites to her at her gmail address from my device even though both of our email addresses are listed under my Apple ID. I don't plan on giving out my ".me" address and I plan on putting an auto-forward on .me to send everything to my gmail. Hopefully that won't mess it up but for now it works great.

     

    Hope this helps someone. It was very frustrating and I feel the pain! Good luck..

     

    Luke

  • zmtiger Level 1 Level 1 (10 points)

    This is all so confusing.  All I want to do is send meeting requests from my iPhone 4 (5.0.1) or MBP (10.7.4 -

    MacBookPro8,2) (with or without *.ics attachments as required) from a specific email address to any email address.  All this from my @work email address.

     

    Currently I have linked iCal to iCloud – on the iPhone and MBP. When I create an iCal (MBP) event with invitees, they receive the request, but it's from noreply@me.  How does one use their personal or work email address?  This creates a whole new issue of recipient's servers sending the message to junk mail or 'Oh I was looking for your office email. What's @me.com? Should I use this email address from now on?'

     

    Since the invitation is from me.com, how does the recipient reply via email with a question about the meeting request, keeping the same email thread?

     

    If this meeting is cancelled an additional email is received.  The recipients can respond to the meeting organizer through iCloud. (The cancellation uses the organizer's email address as an alias I think, unlike the initial invitation.)  But the meeting organizer's AppleID email address is the reply to address.

    On my MBP I have the Me/My Card set up as my @work email address.

     

    Are all invitations sent through/from the Apple iCloud server using noreply@me.com?

  • MacMarkT Level 1 Level 1 (0 points)

    It appears that all invites go out as noreply@me.com.  IMO - this just another example of an incomplete solution from Apple.  I love much of what Apple does - but often they seem to not take into account even the simplest of features available in other products.   No group/distribution lists supported in IOS interface would be another example.

     

    It is rather bafferling to me why Apple would chose to remove the email address of the owner of an event.  It just seems unfinished.

     

    --

    -Mark

  • o1sowise Level 1 Level 1 (0 points)

    aklick wrote:

     

    There is a solution listed right in the thread. Here it is: Very quick and simple.

     

    In short go to https://www.icloud.com/

    sign in using your apple ID information

    Click on Calendar

    Click on the settings button in the upper right hand corner (looks like a cog)

    Click on preferences

    Click on advanced

    Uncheck "use icloud for incoming inviations"

     

    THANK YOU!!!

    This fixed a problem I've had for months, since moving to iCloud!!!

  • MacMarkT Level 1 Level 1 (0 points)

    Interesting place to hide a 'feature'

     

    Any option to change it in-app from OSX or IOS? 

     

    Thank you!

  • MacMarkT Level 1 Level 1 (0 points)

    Might be missing something - but I did the udpate - and emails do come from something besides noreply@me.com - but stil not coming from what I'd say is a normal address:

     

    2_PPTUI2OUIRRYTK57JQHQJPBJXFPNON22QGUMFHEHBSWGU3V463QMU5VIVKDLJUESDPL3UOXH2G4QS@imip.me.com

     

    ical.jpg

  • twelvereloaded Level 1 Level 1 (0 points)

    With the io6 upgrade. Everything has changed my invite capability . I created a new apple Id for my wife's phone. Don't remember the old one. Does apple have a phone number to ask someone as I need help with all this.  I tried clicking the

    "Receive iCloud invitations as:

     

    Email to xxxx@gmail.com

     

    Just like the example you gave MacMark and it still doesn't work

  • markeez Level 1 Level 1 (5 points)

    Having the same problem. The best "WORKAROUND" that i found to be able to send out and receive invites properly is to TURN OFF Calendar in iCloud and let your "Mac" handle the routing of invites locally. Also this may be tied to the contact card of the user. Step by step process is:

     

    1. Delete/Remove any Calendar account in iCal; including icloud, gmail. I mean ALL.

    2. Close iCal/Calendar.

    3. Alternatively, go to Systems Preferrence>>iCloud and UNCHECK the Calendars and Reminders.

    4. Next, open Contacts/Addressbook and look for your own personal card with your emails, numbers, address etc. Click it then go to "Card" on the Menu on top, and then click "Make this My Card". Then close contacts.

    5. Now open back iCal/Calendar. On the right, if you clicked Calendars, you will see 2 default calendar under "On My Mac". If you have this only. You did it right. You may add additional calendars/calendar headings from here on.

    6. Test to see if you can send invites. Create an Event then add invitees. You may try your other email accounts. This should send in the background using your Mail.app. YOu may note that it will use the Email account that is first listed under your "Inbox". For me right now, iCloud is listed first among my inboxes then Gmail then Yahoomail. IN case you will change the order, Calendar will use the first listed email account.

     

    Hope this provides a workaround for some who might want their invites capability in Calendar restored. This however hampers syncing the Calendar and Reminders. What you can do to sync the details is to also send to your iClloud email everytime you send invites.

  • bassewitz Level 1 Level 1 (0 points)

    I believe I have found a solution to the problem.

    At least for those of us who hardly (or never) use their iCloud eMail address.

    I created a test event in my iCloud calendar and invited my regular GMail address along with my girl-friend's GMail address (which also happens to be her iCloud/iTunes account) along with another GMail account I have.

    Only my second eMail address received the invitation.

    After looking through this thread I decided to look in the PREFERENCES in iCLOUD (gear icon in the upper right hand corner when you are in the CALENDAR).

     

     

    Under the ADVANCED section

     

     

    there is an option regarding the invitations. If you check EMAIL TO (YOUR EMAIL ADDRESS) instead of IN-APP NOTIFICATIONS you all of a sudden will receive your invitations just as you always have.

    This seems to be necessary for those of us who don't live in their iCloud calendars.

    Incidentally, both sides may have to set this.

    I hope this helps.

  • dmix007 Level 1 Level 1 (0 points)

    To make matters worse, I had to add my icloud account to my wifes iPad in order to be able to access my iCloud account at iCloud.com.  You can't even modify that option unless you have an apple device to associate your icloud account on.  It should be a simple fix to just switch the default option to send it to the 3rd party e-mail.

    Sometimes apple dumbs things down too much...

  • us326787 Level 1 Level 1 (0 points)

    For those having difficulty sending a calendar invites (I have a Iphone 5 on IOS6) to a gmail user.  I had this same problem.  None of the fixes proposed in this discussion thread helped.  Tried them all and none worked.  What did, however, was to send the invitation xyz@googlemail.com instead of xyz@gaxyz@gmail.com

  • us326787 Level 1 Level 1 (0 points)

    Sorry..dont understnad why the above does not show up correct. 

     

    Solution...in your invitation replace gmail.com with googlemail.com