Previous 1 5 6 7 8 9 Next 121 Replies Latest reply: Feb 16, 2016 12:18 PM by scottnamandaredhead Go to original post
  • marchandeur Level 1 Level 1

    Thanks for the tip, nastyswap.  Unfortunately, that did not solve the problem on my MacBook Pro.  I give up - I'm going to walk the computer into the Apple Store and let the Geniuses deal with it. 

  • Builder1 Level 1 Level 1

    I give up too. I have tried every tip in this thread and nothing works. My hope is that the new OS X coming out this month will fix it...

  • Builder1 Level 1 Level 1

    All of the sudden, my Photostream in iPhoto has remained enabled on both of my Macs over the last 3 days! Even after several re-boots it has since continued to work properly! It has not worked like this for months. I don't know what happened but I hope it stays this way....

  • Uberhamster Level 1 Level 1

    Posted a possible solution here.

  • J_B_A_R Level 1 Level 1

    I think I have found a solution for my 2 computers. It seems that iCloud needs unique iCloud Account Details names for each computer/iPhoto library. I was originally having (for a long frustrating time) the same problem of Photo Stream being setup to always be on and to automaticall synch and add all photos. When I would start iPhoto, most of the time it would be disabled. Also, when I would try to re-enable it, I started getting an alert stating that my iphoto library was in use and I would have to change, etc. (I cannot remember the exact alert statement, sorry). What I did was: on one of the computers, go to system settings/iCloud. Deselect the Photo Stream option. Then click on account details. I then changed the description name (I just added the computer "MACBOOK" to the existing descripton name already in use). I then re-enabled the Photo Stream option in the iCloud settings before closing the system preferences. After that, it stays on on both computers with no more issues. Only time will tell, but it has been working great so far. I would assume that this would have to be tru for each device and each would need a unique iCloud/accont details/description field/name.

    So, easy answer:

    1. Go to system settings/iCloud.

    2. Deselect the Photo Stream option.

    3. Open Account Details.

    4. Description field: add uniuque name to existing name in field. (may work with complete rename/not tried).

    5. Close Account Details window.

    6. Reselect the Photo Stream option.

    Hope this is the answer and help. If not, please respond. I will update if any issues arise.

  • Samma Lamma Level 1 Level 1

    I think you solved it for me! Nothing else had worked. My description was still "iCloud" and changing it from the default seemed to allow me to keep Photostream on. I only have it enabled on one computer, however I had to replace my hard drive a few months ago and I'm guessing it thought I had two conflicting "iCloud" computer accounts. Thanks J_B_A_R

  • J_B_A_R Level 1 Level 1

    Well, per my earlier post, Re: Photostream keeps turning off in iPhoto., the renaming of the iCloud account name on each computer/device to something unique for each, does not seem to work. It worked for a while, but after a few days, I had to re-enable iPhoto streaming on each computer in the iPhoto options. My family uses one of the computers, so I am not sure if this occured after a reboot. I am incided to think that this was the case. Sorry for any cofusion. I do not know of any more possible fixes. Hopefully Apple will have the issue resolved in the next software update.

  • J_B_A_R Level 1 Level 1

    Sorry. It seems that the "fix" does not work after all.

  • Builder1 Level 1 Level 1

    Sorry everyone, false alarm. Photostream worked great for about 5 days but is now disableing itself again after restart.

  • ermaly Level 1 Level 1

    Last manual photostream turn on today. Mountain Lion downloading. I think I will feel nostalgia for this bug as it has been part of my life for a year . The curiousity of what caused it remains though. Cheers.

  • Builder1 Level 1 Level 1

    YES! It looks like it is safe to say Mountain Lion has fixed the issue! After several re-boots Photostream is still on! I hope I'm not speaking too soon but it apprears to be fixed!

  • neilrcooper Level 1 Level 1

    Same problem as everyone else. Running Mountain Lion on iMac.

    The below makes no sense but fixed it.

    Turned Photostream off in System Preferences iCloud.

    Now iPhoto let me turn photostream on (which it didn't before).

    Back in System prefs iCloud found photostream had turned itself on.

    Quit iPhoto re-booted iMac and still all OK and working.

    Hope this simple fix works for others.

  • damongaspee Level 1 Level 1

    This is usually a temporary solution for me. Works for a couple days and then breaks again.

  • MikeChrista Level 1 Level 1

    For me Mountain Lion solved this problem that had been a constant nusiance with Lion.

  • Builder1 Level 1 Level 1

    Unbelievable!!! A week ago I reported that the Mountain Lion upgrade had fixed this. It did indeed work perfectly for over a week. However, I just opened iPhoto and found Photostream had disabled itself again! Still not fixed! I give up!

Previous 1 5 6 7 8 9 Next