13 Replies Latest reply: Sep 30, 2013 4:04 PM by niteowl
kwright2713 Level 1 Level 1 (0 points)

Hi, when I click any pdf on safari, it won't open the pdf it just brings up a dark grey screen and doesn't load. I am running Safari 5.1.1 and OSX Lion. I have removed the Adobe plugin from Library and put Adobe Reader in the trash, however, I am still getting the same problem.

  • kwright2713 Level 1 Level 1 (0 points)

    Solved it! Instead of going to Mscintosh and into my Library folder that way, I opened Finder, Clicked Go and Go to Folder and then typed in ~/Library and deleted the pdfviewer plugin that way and it worked.

  • jayafel Level 1 Level 1 (0 points)

    I am having the same problem.  I clicked the "missing plugin" link, downloaded the adobe file it wanted me to, and it still won't work. 

     

    This has been going on for awhile.  I am about to go back to Firefox or maybe Chrome.  As a graduate student, I download quite a bit of pdfs...

  • jayafel Level 1 Level 1 (0 points)

    i tried that, and it wouldn't work for me. 

  • kwright2713 Level 1 Level 1 (0 points)

    Have you deleted Adobe Reader as well as all of its plugins?

  • jayafel Level 1 Level 1 (0 points)

    i think so, some pdfs will open with preview now but some (like the EBSCO databases) won't open at all.

  • Ancient_One Level 1 Level 1 (30 points)

    Another possibility to to use the Schubert PDF plug in. It has been around for years and works great.

     

    http://www.schubert-it.com/pluginpdf/

     

    I do not know if it will work in Lion but it does work in Snow Leopard.

     

    Steve H

  • Carolyn Samit Level 10 Level 10 (95,950 points)
    I am running Safari 5.1.1 and OSX Lion

     

    Removing that plugin won't help with Adobe / Lion.

     

    Read here >  Known Issues | Adobe products on Mac OS 10.7 Lion

  • Gerd Rösser Level 1 Level 1 (0 points)

    Thanks,

    I had the same problem and deleting everything containing pdf in its name.

    I had to do this in both libraries: ~/Library/Internet Plug-Ins and /Library/Internet Plug-Ins

    Now it works again. ;-)

  • RockJedi Level 1 Level 1 (0 points)

    Thank Gerd and KWright.

     

    I had the same problem. (a temporary work around was I was right clicking on the grey screen, hitting save pdf to download, worked half the time)

     

    Now by deleting those plug ins, I dont see grey screen anymore.

     

    Thank you sooooo much.

  • Yermudder Level 1 Level 1 (0 points)

    I had the same experience with my new mac mini. I tried deleting the plug-ins and all that, but it didn't help. I finally discovered that I needed to open Adobe Reader directly first. Until you do that and say "yes" to the user terms, it won't open from Safari. That could be your only problem.

  • niteowl Level 2 Level 2 (385 points)

    Go to: Library/Internet Plug-ins and remove <AdobePDFViewerNPAPI.plugin>. That fixed the Safari issue but I'm still working on the same PDF issue in Firefox. I'm going to remove <AdobePDFViewer.plugin> to see if that fixes the Firefox PDF issue.

     

    Hey Yermudder, I found nothing about "User Terms" in either Reader v9.x.x nor Reader v11.x.x.

  • Yermudder Level 1 Level 1 (0 points)

    Dunno then. When I first downloaded Reader 11.0.04, it did the usual thing when I first installed it--showed me the User Terms and made me agree. After that it worked fine with Safari 6.0.5. I'm running Mountain Lion, if that makes any difference. Maybe you need to go to Safari preferences make sure the "Open safe files" box is checked.

  • niteowl Level 2 Level 2 (385 points)

    I believe that the Safari preferences setting "Open safe files" only deals with files actually DOWNLOADED to the computer, not stuff that isn't actually downloaded but that is supposed to open in a new Safari browser window.

     

    I have never had "Open safe files" selected, not ever, and I've never had PDFs not open in a browser window unless some other something or other was causing the problem, in this case it was  <AdobePDFViewerNPAPI.plugin>.

     

    Removing that Plugin is what worked for me......

     

    Since don't remember any version of Adobe Reader Application ever asking me to ‘accept terms’ when I've opened it (unless it was on the Adobe web site before I was allowed to download the software*) I can't say that it isn't also problematic.

     

    *That makes the most sense to me